Headlight question
Results 1 to 5 of 5

This is a discussion on Headlight question within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Just installed some HID lights on my 02 WRX. they work and all but here is my question. The HI/Lo ...

  1. #1
    Registered User Crazygerman's Avatar
    Join Date
    Dec 2013
    Location
    Boerne, Tx.
    Posts
    18

    Headlight question

    Just installed some HID lights on my 02 WRX. they work and all but here is my question.
    The HI/Lo doesn't work WHY? IT IS A Hi/Lo kit....
    the dash highbeam light stays on while lights are on WHY?
    Plus the Foglights no longer come on at all WHY?

    Thanks for any help on this matter in advance!

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    He simply abides. SD_GR's Avatar
    Join Date
    Jul 2002
    Location
    CA, US
    Posts
    22,206
    I Support ClubWRX

    Headlight question

    The sensible option is to remove the kit and use the correct 9007 bulbs.

    I suspect you'll want to retain the kit though. Therefore, search "DRL mod" and "fog light mod" for how-to threads. Bear in mind there is some sort of feedback nonetheless, so you may still have a (faint?) main beam indicator issue -- but not all cars exhibit this.

    So, you'll need the DRL mod at a minimum. Start there, see what happens, then explore the fog light mod. DIY threads exist on this forum; make sure you follow directions for your model.
    WRX Info Links, Courtesy TheJ
    The world breaks everyone and afterward many are strong in the broken places. Ernest Hemingway
    I lied. I cheated. I bribed men to cover the crimes of other men. I am an accessory to murder. But the most damning thing of all... I think I can live with it. And if I had to do it all over again - I would. Benjamin Sisko
    DISCLAIMER: Opinions expressed are the author's alone and are inherently worthless.

  4. #3
    Registered User Crazygerman's Avatar
    Join Date
    Dec 2013
    Location
    Boerne, Tx.
    Posts
    18
    Thank you I found my problem and fixed it will be posting a post on the matter so everyone will see any HID will work correctly if the wires are in the proper places....wires were in wrong sockets.

    Crazygerman02WRXWagOn

  5. #4
    He simply abides. SD_GR's Avatar
    Join Date
    Jul 2002
    Location
    CA, US
    Posts
    22,206
    I Support ClubWRX
    Oh I see, yes that happens. Good to hear.
    WRX Info Links, Courtesy TheJ
    The world breaks everyone and afterward many are strong in the broken places. Ernest Hemingway
    I lied. I cheated. I bribed men to cover the crimes of other men. I am an accessory to murder. But the most damning thing of all... I think I can live with it. And if I had to do it all over again - I would. Benjamin Sisko
    DISCLAIMER: Opinions expressed are the author's alone and are inherently worthless.

  6. #5
    Luke Skywalker Mikie13's Avatar
    Join Date
    Oct 2006
    Location
    Palmyra, NJ
    Posts
    20,603
    All those issues are occurring because I suspect you didn't do a legit retrofit...and did a cheap plug and play kit.
    The Hawk-Eye Alliance #90|The Blobeye Syndicate #0|The Stink-Eye Mob #0|N.E.R.D. Founding Member & #3
    2012 Lightning Red WRX Sedan Stock...for now Soon to be OpenSource tuned by: Mattypants @ WTF Tuning
    "If I have 10 ice cubes and you have 11 giraffes, how many pancakes can fit on the roof? Purple, because aliens donít wear hats" -Ying

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •