Well i cant figure it out letssee if you can
Results 1 to 12 of 12

This is a discussion on Well i cant figure it out letssee if you can within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; So my turbo used to hold psi just fine on my 03 wrx ( has up n down pipes n ...

  1. #1
    Registered User
    Join Date
    Aug 2011
    Posts
    8

    Well i cant figure it out letssee if you can

    So my turbo used to hold psi just fine on my 03 wrx ( has up n down pipes n tbe intake bcs and stage two tune) now when i hit boost it pegs the stock gauge at about 14 psi then its likemy turbo just shuts off till its around 9 psi then spools back up to 14 and continues to do that the whole time i have it floored. Ive steamed my engine to try and fine a vacume leak and tryed differnt tunes. Anyone have any ideas on what it is or howtofix it? i counted it in third gear it jumps back n forth like that 9 times before redline.

    WannaBeExpert

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User
    Join Date
    Sep 2013
    Location
    Montrose, CA
    Posts
    76
    let me give this a shot! this symptom is the ECU and the waste gate solenoid doing its job, have you check if your restrictor pill is where it should be? that is not partially clogged? the only way you can find vacuum leaks is only when you are on boost, so get a mighty vac and do a vacuum test with 20 psi into the system... hope this helps or at least is a starting point on troubleshooting....

    cheers

  4. #3
    Registered User
    Join Date
    Aug 2011
    Posts
    8

    ok

    Quote Originally Posted by blusuby View Post
    let me give this a shot! this symptom is the ECU and the waste gate solenoid doing its job, have you check if your restrictor pill is where it should be? that is not partially clogged? the only way you can find vacuum leaks is only when you are on boost, so get a mighty vac and do a vacuum test with 20 psi into the system... hope this helps or at least is a starting point on troubleshooting....

    cheers
    Ok I'll do that at my shop today as for the restrictor pill where would that be located and anything special I should use to clean it? Or just use our parts cleaner bin?
    WannaBeExpert

  5. #4
    Registered User wreckingball man's Avatar
    Join Date
    Jul 2012
    Location
    Rocky Top
    Posts
    2,272
    The pill is located between the nipple on the turbo cold side and the tee in the line.

    Technical Articles

    Also, for testing the system for leaks you do not have to go to 20psi and there are some hoses you need to unplug and cap. I believe Perrin has a write up on this and if it's the one I'm thinking of, it's the most detailed and deliberate write up I've read anywhere.

  6. #5
    Registered User subypete's Avatar
    Join Date
    Jan 2008
    Location
    Decatur, IL
    Posts
    131
    Quote Originally Posted by WannaBeExpert View Post
    So my turbo used to hold psi just fine on my 03 wrx ( has up n down pipes n tbe intake bcs and stage two tune) now when i hit boost it pegs the stock gauge at about 14 psi then its likemy turbo just shuts off till its around 9 psi then spools back up to 14 and continues to do that the whole time i have it floored. Ive steamed my engine to try and fine a vacume leak and tryed differnt tunes. Anyone have any ideas on what it is or howtofix it? i counted it in third gear it jumps back n forth like that 9 times before redline.

    WannaBeExpert
    You say you have a BCS? Is it a 3-port BCS? If so, you won't have a restrictor pill. Also, when you say steamed I am assuming you mean smoked. Steam condenses to water... you obviously don't want that in your intake.

    You need to find a way to take some data logs and post them here so that people have a better idea of whats going on. Do you have an AccessPort or a Tactrix cable? If you can, log the following:
    A/F Correction #1(%)
    A/F Learning #1(%)
    A/F Sensor #1(AFR)
    Engine Load (g/rev)
    Engine Speed
    Feedback Knock Correction
    Fine Learning Knock Correction
    IAM
    Ignition Total Timing
    Injector Duty Cycle
    Intake Air Temperature
    Manifold Absolute Pressure (PSI)
    Manifold Relative Pressure(corrected)(PSI)
    Mass Airflow (g/s)
    Mass Airflow Sensor Voltage
    Throttle Opening Angle(%)
    Vehicle Speed (mph)
    WGDC

    Logging this many parameters will significantly reduce your resolution, but it should provide some general insight into what is going on.
    2002 OBP WRX - Stage II - "Black Betty"
    1987 Subaru GL Wagon - Stock - "Mr. Ratburn" - SOLD

  7. #6
    Registered User
    Join Date
    Aug 2011
    Posts
    8
    Quote Originally Posted by subconfusion3209890
    You say you have a BCS? Is it a 3-port BCS? If so, you won't have a restrictor pill. Also, when you sayI steamed I am assuming you mean smoked. Steam condenses to water..anything viously dI'll t want that in youturbo ake.

    You need to find a way to tome data logs and post them here so that people have a better idea of whats going on. Do you have an AccessPort or a Tactrix cable? If you can, log the following:
    A/F Correction #1(%)
    A/F Learning #1(%)
    A/F Sensor #1(AFR)
    Engine Load (g/rev)
    Engine Speed
    Feedback Knock Correction
    Fine Learning Knock Correction
    IAM
    Ignition Total Timing
    Injector Duty Cycle
    Intake Air Temperature
    Manifold Absolute Pressure (PSI)
    Manifold Relative Pressure(corrected)(PSI)
    Mass Airflow (g/s)
    Mass Airflow Sensor Voltage
    Throttle Opening Angle(%)
    Vehicle Speed (mph)
    WGDC

    Logging this many parameters will significantly reduce your resolution, but it should provide some general insight into what is going on.
    sorry for confustion yes it was smoke not steam. Did it again and found nothing even at 20 psi so im sure its not a leak. Secound i have a grimspeed bcs and that t is gone from new hoses. Open for anything new now. Ill post a video of my turbo gauge and see if that helps any.
    WannaBeExpert

  8. #7
    Moderator Donkey's Avatar
    Join Date
    Apr 2005
    Location
    Da boonies
    Posts
    6,042
    I Support ClubWRX
    Sounds like typical boost oscillations. Shorten the wastegate arm a turn or two and see if it still happens.
    Resident Adviser @ WTF Tuning, LLC
    2002 FORESTER S
    1998 FORESTER S




  9. #8
    Registered User
    Join Date
    Aug 2011
    Posts
    8
    Here's a quick look at it
    VIDEO0027 - YouTube

  10. #9
    Moderator Donkey's Avatar
    Join Date
    Apr 2005
    Location
    Da boonies
    Posts
    6,042
    I Support ClubWRX
    Boost ocillations
    Resident Adviser @ WTF Tuning, LLC
    2002 FORESTER S
    1998 FORESTER S




  11. #10
    Registered User
    Join Date
    Aug 2011
    Posts
    8
    [QUOTE=Donkey;321699to Boost ocillations[/QUOTE]

    Really u can see my rpms all that happens within 3-4 grand

  12. #11
    Moderator Donkey's Avatar
    Join Date
    Apr 2005
    Location
    Da boonies
    Posts
    6,042
    I Support ClubWRX
    Quote Originally Posted by WannaBeExpert View Post
    Really u can see my rpms all that happens within 3-4 grand
    And that is when peak boost is generally being made then the boost pressure tapers down in the higher rpm. Google "boost oscillations"..........................
    Resident Adviser @ WTF Tuning, LLC
    2002 FORESTER S
    1998 FORESTER S




  13. #12
    Registered User Crazyced's Avatar
    Join Date
    Dec 2013
    Location
    Ottawa
    Posts
    59
    Datalogging WGDC will definitely tell you what the ECU is trying to archive boost wise.

    EDIT: You could give this a try:
    http://forums.nasioc.com/forums/show....php?t=1524173
    Last edited by Crazyced; 12-20-2013 at 12:09 PM.
    2004 Subaru Impreza WRX
    2004 Dodge Neon SRT-4

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •