Check engine came on then went away - 14' WRX
Results 1 to 4 of 4

This is a discussion on Check engine came on then went away - 14' WRX within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Hey guys, So yesterday, I was driving very "spirited" I guess you could say. I was running it pretty hard. ...

  1. #1
    Registered User
    Join Date
    Sep 2013
    Location
    West Palm Beach, FL
    Posts
    31

    Check engine came on then went away - 14' WRX

    Hey guys,

    So yesterday, I was driving very "spirited" I guess you could say.

    I was running it pretty hard. I was in 3rd gear, and went to switch gears quickly and accidentally went into 2nd gear. The RPM's went up to about 7,500 before I immediately pushed the clutch back in. The check engine light came on and the cruise control light was flashing. I pulled over, turned the car off, turned it back on and it was still there. It drove fine so I kept going to my destination. However, the cruise control was not working. Anyway, I got to the mall, turned it off, and about an hour later I came back. I turned it on, and the CEL was gone and the cruise control light stopped flashing and worked fine.

    Did the computer just reset itself or something? What happened? Do I have anything to worry about? It is still driving fine with no unusual behavior.

    (yes, I'm an idiot. Gotta be more careful. )

    Thanks,
    Adrian

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User
    Join Date
    Sep 2013
    Location
    Montrose, CA
    Posts
    76
    consider yourself lucky man that you did not blow your engine....... checked for any stored or memorized codes? it would be interesting why did it give you a CEL,,,,,, suspecting CPS that went way way way out of parameterss.....

    good luck

    German Silva

  4. #3
    Registered User CHRISesBUENO's Avatar
    Join Date
    Nov 2013
    Location
    Buffalo
    Posts
    59
    wish i knew, hopefully you atleast did the 1000 break in period method!

  5. #4
    Registered User
    Join Date
    Jul 2013
    Location
    Silicon Valley
    Posts
    229
    Take it to the dealer, it's under warranty. Blow the engine from shifting into too low a gear? More lucky you didn't severely damage your transmission.
    But seriously, it's under warranty, if you're concerned, take it to the dealer.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •