13 wrx misfire issue...strange fix
+ Reply to Thread
Results 1 to 6 of 6

This is a discussion on 13 wrx misfire issue...strange fix within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; So in my 13 for the past month or so I have had a rough idle/misfire like issue. The weird ...

  1. #1
    Registered User 99pgpgt's Avatar
    Join Date
    Nov 2012
    Posts
    251

    13 wrx misfire issue...strange fix

    So in my 13 for the past month or so I have had a rough idle/misfire like issue. The weird thing about it was that it didn't happen all the time. It stopped doing it for awhile until this past Saturday when the engine light came on for a P0300. I cleared the code since the dealer was closed and drove. I ran the tank down low thinking it may have been a bad mix of gas. I filled up yesterday and the car felt fine. Consisten WOT pulls and everything. Until today..I get out of class, start my car and it is idling crappy as hell. Then as I'm pulling out, the engine light comes on. I thought perfect. So I went to the Subie dealership and let them check it out for the second time for this issue.

    Tech scanned it and the miss was jumping between all 4 cylinders!! Weird huh?

    So he comes out and talks to me for a bit. He mentions that there is a ground wire that splits into 4 separate wires and there has been issues of the connection coming loose. I thought, well, an electrical issue would make sense since it doesn't do it all the time. He peeled back the wrapping and dropped some solder on the connection and what do you know...The miss is gone and it is smooth as hell.


    Just wanted to share this with anyone who may have the same odd miss issue with their 08+ WRX or STi.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Pro Manscaper Mikie13's Avatar
    Join Date
    Oct 2006
    Location
    Palmyra, NJ
    Posts
    21,203
    Interesting. Seems like some of these kinds of issues have come up recently too.
    The Hawk-Eye Alliance #90|The Blobeye Syndicate #0|The Stink-Eye Mob #0|N.E.R.D. Founding Member & #3
    2012 Lightning Red WRX Sedan
    ProcessWest TMIC Cobb SF Intake w/airbox Invidia Catless Downpipe Invidia Q300 Catback Kartboy Short Shifter
    OpenSource tuned by: Matty @ WTF Tuning

  4. #3
    Registered User 99pgpgt's Avatar
    Join Date
    Nov 2012
    Posts
    251
    Interesting is right!!!

    Originally I thought that maybe it was one of the common vacuum leaks. When I took it in before they showed that vacuum was fine. No leaks. And, that the 13 computer has advancements over the 12 model year that will set an engine light the minute there is a vac leak..Now, idk how much of a bull**** line that is or it could be true. But I really was not happy and I was relieved when the engine light came on.

  5. #4
    Registered User 99pgpgt's Avatar
    Join Date
    Nov 2012
    Posts
    251
    This is the section of harness that the wires are located in...


  6. #5
    Registered User cogito's Avatar
    Join Date
    Jul 2013
    Location
    Southern NH
    Posts
    366
    Good to know, as a 2013 WRX owner (5K). Will file that one for sure. Thanks
    2013 WRX Dark Grey Hatch
    1974 Datsun 260z Stroker

  7. #6
    Registered User Zitro's Avatar
    Join Date
    Jul 2013
    Location
    Seattle, WA
    Posts
    329
    I'm having the exact same idle issues on my '13, but I haven't thrown a light yet (2300 miles on the clock). Maybe when I swing by the dealership for my first oil change I'll have them check this. Thanks!
    **Stink-Eye Mob Member #96**

    2013 Rex Hatch Rally Blue
    Crying over money spent on this car and my obsession with hi-fi/ audiophile goodies

    "I would buy that car if I was the sort of person who looked at my sister and thought, mmmmmm." -Jeremy Clarkson, referencing the Ford Mustang

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •