2013 wrx, check engine light - Page 3
+ Reply to Thread
Page 3 of 3 FirstFirst 123
Results 31 to 38 of 38

This is a discussion on 2013 wrx, check engine light within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; well im going to do some pulls (nothing serious) and just see if the cel comes back. i will call ...

  1. #31
    Registered User
    Join Date
    Aug 2013
    Location
    Southwest Oklahoma
    Posts
    149
    well im going to do some pulls (nothing serious) and just see if the cel comes back. i will call sometime tomorrow in the am, if everything goes as planned tomorrow.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #32
    zax
    zax is offline
    \_(ツ)_/ zax's Avatar
    Join Date
    Nov 2008
    Location
    Neverland Ranch, Maryland
    Posts
    13,429
    I Support ClubWRX I Support ClubWRX
    Once a Subaru, always a Subaru.
    2015 CWP WRX STi ... But how did I get roped back into an EJ motor?!
    Zax's utterly unimaginably stock 2015 STi build thread
    Zax's Shaggin' Wagon Build Thread Now tuned for 99% pure Unicorn Jizz!

    Zach | Moderator -- Mid-Atlantic States, Tech & Modifying & General Repairs
    Rollin' with the Bugeye Mafia #302 | N.E.R.D. Subject Zero
    Facebook me here

    Your Mid-A local board: http://www.clubwrx.net/forums/mid-atlantic-states/

  4. #33
    \_(ツ)_/ Rambo's Avatar
    Join Date
    Oct 2010
    Location
    Portland, OR
    Posts
    5,132
    I Support ClubWRX
    Quote Originally Posted by zax View Post
    Once a Subaru, always a Subaru.
    Isaac -- 2003 WRX sedan Stg II - Gave its life for mine 6/2013.
    2007 Outback 3.0R wagon
    Proud owner of a N.E.R.D, Member 1.3810-23

    The pursuit of knowledge is hopeless and eternal... Hooray!!! - Professor Farnsworth

  5. #34
    Registered User
    Join Date
    Aug 2013
    Location
    Southwest Oklahoma
    Posts
    149
    Sorry i have not let you guys know anymore information about this, but it has been a busy few weeks for the military and have not had time.. I had to drive to dallas (3.5 hour drive for me), car drove fine all the way there and back.

    I did some pulls (wot) and have not had any issues since the time the light came on.

  6. #35
    Registered User
    Join Date
    Oct 2013
    Posts
    2
    Hey, Brenner

    I just registered to maybe give you some helpful info. I just purchased a 2013 Impreza 2.0, and had the CEL come on at under 200 miles, and I scanned the same code p0346. The dealership has my car right now and I'm waiting to hear back from them soon.

  7. #36
    Registered User
    Join Date
    Aug 2013
    Location
    Southwest Oklahoma
    Posts
    149
    Okay thanks! Let me know what they come up with. i have not been back to the dealership since it happened.

  8. #37
    Registered User
    Join Date
    Oct 2013
    Posts
    2
    Ok, got the results...

    Short answer = gremlins

    They pulled codes p0345 and p0346, ran diagnostics, checked the cam spacing, and everything checked out fine.

    They also contacted Subaru technical support and were told that maybe swapping the two cam sensors with each other may keep the false codes from coming back.

    I also forgot to mention that my car DID go into limp mode. Along with the CEL, the traction light came on and the cruise symbol started to flash because those features disable when the car goes limp.

    Hope this helps!!


    P.S. They also told me to advise you to get your car to the dealership if it comes on again in your WRX. ;-)

  9. #38
    Registered User
    Join Date
    Aug 2013
    Location
    Southwest Oklahoma
    Posts
    149
    Okay, thank you very much! I am hoping that it was also just a false reading in my car.

+ Reply to Thread
Page 3 of 3 FirstFirst 123

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •