2013 wrx, check engine light - Page 2
+ Reply to Thread
Page 2 of 3 FirstFirst 123 LastLast
Results 16 to 30 of 38

This is a discussion on 2013 wrx, check engine light within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Originally Posted by brennermoore he said to throw that sensor there could have been a lot of variables, and i ...

  1. #16
    \_(ツ)_/ Rambo's Avatar
    Join Date
    Oct 2010
    Location
    Portland, OR
    Posts
    5,137
    I Support ClubWRX
    Quote Originally Posted by brennermoore View Post
    he said to throw that sensor there could have been a lot of variables, and i should not have anything to worry about.. But just because it is under warranty i will probably take it to the dealer when i get time.
    Uh, yeah, the guy at O'Reilly's is a moron. Your car is using these sensors to control the ignition timing, and they're absolutely crucial to the proper functionality of the variable valve timing. The fact that you haven't thrown any misfire codes is a hopeful sign, but I wouldn't not wait around to take it to the dealer. At the very least, they should verify the car's timing and the belt tension to be sure you haven't skipped any teeth.

    Has the car gone into "limp mode" at all (significant power loss, and wastegate turbo pressure only)? What do you mean by "beating on it"? The car is hardly out of break-in.
    Isaac -- 2003 WRX sedan Stg II - Gave its life for mine 6/2013.
    2007 Outback 3.0R wagon
    Proud owner of a N.E.R.D, Member 1.3810-23

    The pursuit of knowledge is hopeless and eternal... Hooray!!! - Professor Farnsworth

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #17
    Registered User 99pgpgt's Avatar
    Join Date
    Nov 2012
    Posts
    251
    You may want to have them check out the same problem I had. Go to my thread, "13 wrx misfire"

  4. #18
    Registered User
    Join Date
    Aug 2013
    Location
    Southwest Oklahoma
    Posts
    149
    No it has not gone into limp mode as far as i know, i think that is something i would have noticed. Drove it back from the car show the day the cel came on and it drove perfectly normal. No difference in gas milage, or power. As far as beating on it, i was doing a 3rd gear pull when it came on, and yes the car is hardly out of its break in but it is passed it. So what am i going to get told now wait another 1000 miles for an additional break in? im curious as to what you are getting at with that statement.

  5. #19
    Registered User
    Join Date
    Aug 2013
    Location
    Southwest Oklahoma
    Posts
    149
    Also got a hold of my dealership, they had a car come in yesterday with the same problem.. they said its just the ecu reading codes wrong. i was told if i was to drive up there they couldnt do anything, they told me to flash the ecu.

  6. #20
    Registered User 99pgpgt's Avatar
    Join Date
    Nov 2012
    Posts
    251
    Quote Originally Posted by brennermoore View Post
    Also got a hold of my dealership, they had a car come in yesterday with the same problem.. they said its just the ecu reading codes wrong. i was told if i was to drive up there they couldnt do anything, they told me to flash the ecu.
    They told you to flash the ecu?... Uhh what.

  7. #21
    Registered User
    Join Date
    Aug 2013
    Posts
    31
    Quote Originally Posted by brennermoore View Post
    Also got a hold of my dealership, they had a car come in yesterday with the same problem.. they said its just the ecu reading codes wrong. i was told if i was to drive up there they couldnt do anything, they told me to flash the ecu.
    That's odd, what are you supposed to flash it with? Or did they tell you to come in and they would flash it?

  8. #22
    zax
    zax is offline
    \_(ツ)_/ zax's Avatar
    Join Date
    Nov 2008
    Location
    Neverland Ranch, Maryland
    Posts
    13,454
    I Support ClubWRX I Support ClubWRX
    Dafuq?

    This isn't right....
    2015 CWP WRX STi ... But how did I get roped back into an EJ motor?!
    Zax's utterly unimaginably stock 2015 STi build thread
    Zax's Shaggin' Wagon Build Thread Now tuned for 99% pure Unicorn Jizz!

    Zach | Moderator -- Mid-Atlantic States, Tech & Modifying & General Repairs
    Rollin' with the Bugeye Mafia #302 | N.E.R.D. Subject Zero
    Facebook me here

    Your Mid-A local board: http://www.clubwrx.net/forums/mid-atlantic-states/

  9. #23
    Registered User A265's Avatar
    Join Date
    Mar 2009
    Location
    in a igloo
    Posts
    777
    Do you have any other dealers close by? I would stay away from that dealership, how can they diagnose a problem like that over the phone? A other car had the same problem and the fix was x doesnt seem like good practice.

  10. #24
    Registered User
    Join Date
    Aug 2013
    Location
    Southwest Oklahoma
    Posts
    149
    There is one more up in oklahoma city, but i dont know this is just what they told me..they said they called up to subaru (like the main subaru in america), and they told them there has been a few of these cases and it has always been a false reading of the ecu..

    Also he meant just clear the codes, sorry if that was confusion. Like i said the cel was on for around an hour and then went away.. Has not came back on..

    They told me if i am to have another cel come on then to contact them, but until then he said he couldnt do anything.

  11. #25
    \_(ツ)_/ Rambo's Avatar
    Join Date
    Oct 2010
    Location
    Portland, OR
    Posts
    5,137
    I Support ClubWRX
    Quote Originally Posted by brennermoore View Post
    There is one more up in oklahoma city, but i dont know this is just what they told me..they said they called up to subaru (like the main subaru in america), and they told them there has been a few of these cases and it has always been a false reading of the ecu..

    Also he meant just clear the codes, sorry if that was confusion. Like i said the cel was on for around an hour and then went away.. Has not came back on..

    They told me if i am to have another cel come on then to contact them, but until then he said he couldnt do anything.
    That's odd. If the ECU can't read its own error codes properly, that sounds to me like a firmware bug. How did they tell you to clear the codes? Disconnect the battery?
    Doing that also resets the learned ECU timing values, so I wonder what effect this would have on your issue. It might help, I guess.

    This whole situation still smells fishy, though. If I saw a CEL on my brand new car, it would be at the dealer that same day, and I would demand a detailed explanation for exactly what's going on. It seems like the dealer is just lackadaisically passing you off.
    Isaac -- 2003 WRX sedan Stg II - Gave its life for mine 6/2013.
    2007 Outback 3.0R wagon
    Proud owner of a N.E.R.D, Member 1.3810-23

    The pursuit of knowledge is hopeless and eternal... Hooray!!! - Professor Farnsworth

  12. #26
    Registered User
    Join Date
    Aug 2013
    Location
    Southwest Oklahoma
    Posts
    149
    He didnt tell me how to the clear the codes.. They werent very informative. I am going to call the other dealership either later today, or tomorrow morning.

    I still havent noticed any differences in the car, i also havent let it above 3k rpms since. I will let you guys know what the other dealership advises.

  13. #27
    Registered User 99pgpgt's Avatar
    Join Date
    Nov 2012
    Posts
    251
    I would beat the hell out of it till it throws a code..then beat the hell out of it more till it blows.

    then go back to that dealer and tell em the light came on and the car blew up :/

    .....fix it

  14. #28
    Registered User 99pgpgt's Avatar
    Join Date
    Nov 2012
    Posts
    251
    Then call subaru of america and tell them what they told you to do...over the phone

  15. #29
    Registered User
    Join Date
    Aug 2013
    Location
    Southwest Oklahoma
    Posts
    149
    yea i was really thinking about beating on it until i threw another CEL. Okay i will have to do that tomorrow morning.
    This is just becoming frustrating

  16. #30
    Registered User 99pgpgt's Avatar
    Join Date
    Nov 2012
    Posts
    251
    Seriously, don't intentionally beat on it. I was trying to lighten up the situation lol

    But just drive the car and if it comes back, take it to the other dealer. I would also call SOA to let them know what that dealer told you to do without physically looking at the car. They should have told you to bring it in right away. Call the other dealership and let them know what the other dealer said to do and possibly talk to one of the more seasoned techs on the wrx platform.

+ Reply to Thread
Page 2 of 3 FirstFirst 123 LastLast

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •