white smoke
+ Reply to Thread
Results 1 to 5 of 5

This is a discussion on white smoke within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; So I got my car all together and it runs nice. there is a problem with the throw out baring, ...

  1. #1
    Registered User
    Join Date
    Jul 2013
    Posts
    12

    white smoke

    So I got my car all together and it runs nice. there is a problem with the throw out baring, it needs replaced so it makes a crazy noise until it heats up then pretty much goes away. but now we have another issue. after running the car, when you stop a white smoke (not a thick white smoke) will come threw the front top vent in the middle and only them. it smells like something is burning not so much wires but something else. i am wondering if its from the clutch or something else. you can smell it sometimes when driving but dont see smoke till its gone. and there is no smoke coming from anything else when you look under the hood when its runing. there is no ac at all in the car. so just wondering if anyone else has any ideas.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User Motoxdude6's Avatar
    Join Date
    Jan 2013
    Location
    Lubbock, TX
    Posts
    147
    did u use wd40 or liquid wrench on any nuts/bolts, on/near something that gets hot?

  4. #3
    Registered User
    Join Date
    Jul 2013
    Posts
    12
    No we didnt, but i figured it out. There was a piece of hose that came out of the fire wall that was laying aginst the exhaust and it was melting. I moved it and now there is no more white smoke

  5. #4
    Master Baiter EJ257's Avatar
    Join Date
    Aug 2007
    Location
    On a stream bank somewhere
    Posts
    19,863
    I Support ClubWRX
    Likely the A/C drain line
    2005 WRX STi (Mods | Virtual Dyno)

    Resident Tuner @ WTF Tuning

    "Never trust anything that bleeds for a week and lives ..."

    UNYSOC

  6. #5
    Registered User
    Join Date
    Jul 2013
    Posts
    12
    I dont know, could be there is no ac in my car so i am not quite sure i am just glad its gone.

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •