Electrical Door Problems - 2004 Wrx
+ Reply to Thread
Results 1 to 4 of 4

This is a discussion on Electrical Door Problems - 2004 Wrx within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; I cant pin point the problem on this one! i don't have a wrx wiring diagram which probably isn't helping! ...

  1. #1
    Registered User KenFerrari13's Avatar
    Join Date
    Jun 2012
    Location
    Harrisburg PA
    Posts
    67

    Electrical Door Problems - 2004 Wrx

    I cant pin point the problem on this one! i don't have a wrx wiring diagram which probably isn't helping! The doors just keep in the lock position, even when flipped manually. The door unlock/lock toggle doesn't work but i unplugged those one by one and that didn't do anything but i don't think that is the problem. All car security systems have been disabled but that didn't change anything either. The car just wants to stay in lock until i pull the fuse. Once fuse is pulled all is well but i want it back to normal. The key fob works like normal but still does not unlock doors only the key. The key has to be held to unlock or it will turn the key back to lock. IDK what it could be, HELP

    This is a video of whats going on. Hopefully someone has had the same problems and can help out!
    2004 Subaru WRX Locking Systems Problems - YouTube

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User StreetKing's Avatar
    Join Date
    Aug 2013
    Location
    NY/NJ
    Posts
    127
    I believe you got every little bit of information from me to solve this problem in the general chatbox.

    No problem btw.
    15 year old

  4. #3
    Registered User KenFerrari13's Avatar
    Join Date
    Jun 2012
    Location
    Harrisburg PA
    Posts
    67
    Turned out to be the Integrated Module was bad!

    Thanks Jewbaru

  5. #4
    Registered User StreetKing's Avatar
    Join Date
    Aug 2013
    Location
    NY/NJ
    Posts
    127
    Quote Originally Posted by KenFerrari13 View Post
    Turned out to be the Integrated Module was bad!

    Thanks Jewbaru & SK
    lol.
    15 year old

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •