2009 WRX AC issue
+ Reply to Thread
Results 1 to 2 of 2

This is a discussion on 2009 WRX AC issue within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; I have a 2009 WRX with 80kms. The AC isn't blowing cold, so I took it to a shop to ...

  1. #1
    Registered User
    Join Date
    Jan 2012
    Posts
    1

    2009 WRX AC issue

    I have a 2009 WRX with 80kms. The AC isn't blowing cold, so I took it to a shop to have it recharged. Well, turns out, it's not holding the charge -- only showing 0.43lbs instead of 1.1lbs. So, there's got to be a leak somewhere. We loaded up the UV dye and put it into the system and no leaks were detected. Problem is: the high side won't take the charge. It won't allow any Freon to go into the system. The compressor clutch is engaging properly when the AC it turned on, so maybe it's something in the compressor itself?

    My tech is not an AC expert, but he thinks that it's either the compressor not working properly, or possibly the high side pressure switch. Does anyone know if this is a known issue? or if you've ever heard of a faulty switch?

    Any help is very much appreciated.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User
    Join Date
    Jul 2012
    Posts
    49
    I think freon only goes in the low side. You should only hook your high side gauge to the high side. My '02 leaks out slow too and I can't locate the leak so this should be interesting. What do your gauges read?

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •