Suspension Making Creaking Noises? 2013 hatch
Results 1 to 9 of 9

This is a discussion on Suspension Making Creaking Noises? 2013 hatch within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; So with the weather being so nice I've been riding around with my windows down. I've started to notice that ...

  1. #1
    Registered User
    Join Date
    Oct 2012
    Location
    CT
    Posts
    307

    Suspension Making Creaking Noises? 2013 hatch

    So with the weather being so nice I've been riding around with my windows down. I've started to notice that depending on the size/number of bumps/potholes that I accidentally run over I can hear a creaking noise (think someone jumping on a really old bed with springs in the mattress) from the right from wheel area. I'm thinking that it has to do with the suspension somehow? and you can only hear it if something displaces the wheel past some certain point.

    The car is a 2013 wrx base hatch, just a little over 12,000 miles on it. Haven't noticed it until recently. I've switched over to/from winter tires since i've had it but other than oil changes nothing maintenance or performance wise has been done to the car.

    Any one have any ideas about what could be causing the noise? and if i should be concerned about it.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Resident Jackass ShiftingLanes's Avatar
    Join Date
    May 2013
    Location
    Riverdale, NJ
    Posts
    764
    I Support ClubWRX
    Likes DREWS said in the chat, "that's every subaru ever." If the people on here are saying it, I wouldn't be too concerned about it. However, it's your car and if you ARE concerned about it (and I take it you are since you've posted about it. I would be too, FYI), take it to your favorite local shop/dealer. If it were me and my car was still in warranty, I'd want to get in there and have them take a look at it. If you get a don't worry about it from them as well, you're golden.
    http://shiftinglanes.com
    '14 DGM WRX Limited Hatch
    I'm a build thread?
    Stink-eye Mob #49

  4. #3
    Registered User
    Join Date
    Oct 2012
    Location
    CT
    Posts
    307
    first subaru, first car, so as you can imagine I just want to make sure everything is "status quo". I just wanted to make sure that it wasn't something out of the ordinary, but I'll probably have the dealer just take a quick look next time i go in for service to ease my mind.

  5. #4
    and the Funky Bunch Calvinball's Avatar
    Join Date
    Jan 2012
    Location
    Philly Area
    Posts
    5,925
    You have a warranty. Take it to the dealer, they'll be able to tell if there is something wrong a lot better in person than we can through the internets.
    - Will
    First Mods: What to do and what not to do
    Current Car: 2014 Golf TDI
    Previous Cars:2012 WRB WRX Hatch, 2004 RSX-S, 1998 Grand Prix GTP
    "Isn't it amazing how smart you feel when you just aren't being stupid?"

  6. #5
    Registered User
    Join Date
    Oct 2012
    Location
    CT
    Posts
    307
    ^^ I know that's what I have to do, just thought I'd ask on here first to see if anyone else was having the same problem

  7. #6
    Registered User
    Join Date
    Jan 2012
    Location
    North Jersey
    Posts
    30
    I had a similar noise when i had my WL sway bar businga were running dry..Quick lube took car of it
    Do you have aftermarket sway bars?

  8. #7
    Registered User ProZach626's Avatar
    Join Date
    Aug 2008
    Location
    St. Louis Metro East
    Posts
    270
    You have a 2013. Theoretically you shouldn't have any problems with it. When you do, take it straight to the dealership and let it be their problem.

    Good luck.

  9. #8
    Registered User ProZach626's Avatar
    Join Date
    Aug 2008
    Location
    St. Louis Metro East
    Posts
    270
    You have a 2013. Theoretically you shouldn't have any problems with it. When you do, take it straight to the dealership and let it be their problem.

    Good luck.

  10. #9
    Registered User
    Join Date
    Oct 2012
    Location
    CT
    Posts
    307
    Quote Originally Posted by mru77 View Post
    I had a similar noise when i had my WL sway bar businga were running dry..Quick lube took car of it
    Do you have aftermarket sway bars?
    Everything is stock still.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •