Possible Problem 05 WRX
Results 1 to 6 of 6

This is a discussion on Possible Problem 05 WRX within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; this happens every once in a blue, but when i start the car after being off for about an hour ...

  1. #1
    Registered User JDMsoul's Avatar
    Join Date
    Mar 2012
    Location
    North Jersey
    Posts
    140

    Possible Problem 05 WRX

    this happens every once in a blue, but when i start the car after being off for about an hour or more, and rev it (not hard), i hear the sound you hear when a car needs power steering fluid/belt. its not as loud, but its definitely noticeable over my exhaust... after it warms up, or i take off, it doesnt do it anymore... any ideas as to what it could be? could this lead to something severe?

    any info is appreciated....
    Chris
    238 whp on stock turbo - Stage 2
    05 l WRB l WRX

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Pro Manscaper Mikie13's Avatar
    Join Date
    Oct 2006
    Location
    Palmyra, NJ
    Posts
    20,985
    Accessory belts? Inspect them and replace as necessary.

    How many miles?
    The Hawk-Eye Alliance #90|The Blobeye Syndicate #0|The Stink-Eye Mob #0|N.E.R.D. Founding Member & #3
    2012 Lightning Red WRX Sedan
    Stock...for now Soon to be OpenSource tuned by: Mattypants @ WTF Tuning

  4. #3
    Registered User JDMsoul's Avatar
    Join Date
    Mar 2012
    Location
    North Jersey
    Posts
    140
    just made 87K
    Chris
    238 whp on stock turbo - Stage 2
    05 l WRB l WRX

  5. #4
    Registered User Obeisance's Avatar
    Join Date
    Apr 2012
    Location
    not Ann Arbor
    Posts
    314
    Incidentally, I've recently become acutely aware of the noise that my cooling fans make as they kick on when the car is hot and I slow down. Could this also be the source of your noise?
    David - '05 WRX

  6. #5
    Registered User JDMsoul's Avatar
    Join Date
    Mar 2012
    Location
    North Jersey
    Posts
    140
    Quote Originally Posted by Obeisance View Post
    Incidentally, I've recently become acutely aware of the noise that my cooling fans make as they kick on when the car is hot and I slow down. Could this also be the source of your noise?
    I'm thinking no cause it only happens I "cold start" and rev. Other than that, I don't hear anything. It does sound like a belt. But not positive.
    Chris
    238 whp on stock turbo - Stage 2
    05 l WRB l WRX

  7. #6
    Registered User
    Join Date
    Nov 2012
    Posts
    8
    sounds like a belt or p\s pump to me. change both belts and see how it goes. make sure they are nice and tight

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •