Blue Smoke during cold start/12 WRX
Results 1 to 2 of 2

This is a discussion on Blue Smoke during cold start/12 WRX within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; So I have a 2012 WRX that I have owned for just over a year, about 7000+/- miles. A few ...

  1. #1
    Registered User
    Join Date
    Apr 2012
    Location
    Sacramento, Ca
    Posts
    26

    Blue Smoke during cold start/12 WRX

    So I have a 2012 WRX that I have owned for just over a year, about 7000+/- miles. A few months ago I start to see smoke coming out of my exhaust(both tips). The car just did not seemed balance, to much vibration in the engine, so I figured it was low compression in the #4 cyl, probably a ringland. Took it to the dealer and it was low compress in the #4 cyl, but was not a ringland. It was a cracked piston and a piece actually come off when the service tech took it out. They did not replace the block, just the piston, ringland, gaskets etc.. all covered by my warranty.
    Well just the other day I took off from a stop sign(not launching, but was probably about 2 1/2) an a big cloud of smoke out of the back. Now everytime I start it from a cold start I get a puff of bluish smoke for a few seconds then stops. Anyone have an idea's on cause or experience with this, thx.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User
    Join Date
    May 2012
    Posts
    12
    Blue smoke is oil burning. piston . The rings or valve guides get it checked again BC that's not right.....

    Sent from my MB886 using Tapatalk 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •