02 wrx new o2 sensor still throwing CEL HELP.!!
Page 1 of 3 123 LastLast
Results 1 to 15 of 40

This is a discussion on 02 wrx new o2 sensor still throwing CEL HELP.!! within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Ok guys I just purchased a Subaru wrx 02 and it had a check engine light so I took it ...

  1. #1
    Registered User
    Join Date
    Mar 2013
    Posts
    23

    Red face 02 wrx new o2 sensor still throwing CEL HELP.!!

    Ok guys I just purchased a Subaru wrx 02 and it had a check engine light so I took it to my local auto parts store to get the codes checked out they told me its my o2 sensors and the car is smoking with a rreeally heavy fuel smell nothing else just str8 raw fuel now I just purchased the own sensor for the upstream witch is by the right passenger front tire but the code is still coming on now if I disconnect the battery it clears the code if I drive it normal not beating on it it won't come on but once I open it up it will pop up in 5-10 min of driving it..

    I just want to know how to get the god damned cel light to stop appearing I hate it.!! >:/ now before I get flamed I am a n00b with subies ok I've owned boosted 240sx's so I'm familiar with turbo cars I built one from scratch n sold it to get this I'm starting to regret it..

    But any way any help will be appreciated and thank you for any input I already searched everywhere on the Internet for possibilities and found that it could be my air intake because its not a stock one and I've also found that if I drive it it should clear the code it's bin 2 days since I installed it and I purchased the right o2 sensor because I bought the OEM one for like 200.00 and it had a universal one on it but I heard they aren't good any help would be appreciated like I said thanks in advance.!!

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    He simply abides. SD_GR's Avatar
    Join Date
    Jul 2002
    Location
    CA, US
    Posts
    22,481
    I Support ClubWRX
    Post:

    The actual codes.
    The complete list of modifications.
    WRX Info Links, Courtesy TheJ
    The world breaks everyone and afterward many are strong in the broken places. Ernest Hemingway
    I lied. I cheated. I bribed men to cover the crimes of other men. I am an accessory to murder. But the most damning thing of all... I think I can live with it. And if I had to do it all over again - I would. Benjamin Sisko
    DISCLAIMER: Opinions expressed are the author's alone and are inherently worthless.

  4. #3
    Registered User
    Join Date
    Mar 2013
    Posts
    23
    Quote Originally Posted by SD_GR View Post
    Post:

    The actual codes.
    The complete list of modifications.
    Ok umma make a quick trip to the auto store so they can rescan it and ill post the exact codes its throwing and as far as I know I just purchased the car about 4 days ago and I haven't messed with anything besides the o2 sensor now from what I can see it has a front mount and the intake piping is not stock looks as if it was made to install the front mount and intake pipe I can also take pictures and post them up if needed

  5. #4
    He simply abides. SD_GR's Avatar
    Join Date
    Jul 2002
    Location
    CA, US
    Posts
    22,481
    I Support ClubWRX
    The plot thickens.

    Find and post all modifications and all CEL codes.

    (Parsing and sentences will likely increase the number of views and responses to your query.)
    WRX Info Links, Courtesy TheJ
    The world breaks everyone and afterward many are strong in the broken places. Ernest Hemingway
    I lied. I cheated. I bribed men to cover the crimes of other men. I am an accessory to murder. But the most damning thing of all... I think I can live with it. And if I had to do it all over again - I would. Benjamin Sisko
    DISCLAIMER: Opinions expressed are the author's alone and are inherently worthless.

  6. #5
    Registered User
    Join Date
    Mar 2013
    Posts
    23
    Quote Originally Posted by SD_GR View Post
    The plot thickens.

    Find and post all modifications and all CEL codes.

    (Parsing and sentences will likely increase the number of views and responses to your query.)
    P0171
    P0301
    P0302
    P0303
    P0037
    P0546
    P0171
    P10037
    P0546

    Are all the codes that came up now sorry I took so long now they say that the smoke coming out is gasoline it's not oil nor coolant is what they said

    Now for the mods:

    Front mount intercooler with an has ssqv bov
    The intake is not stock they have a specter filter on it now

    Keep in mind I have not changed anything they said all cylinders are misfiring and that can't be good :/ I'm lost and confused I have no idea why It would go from 2 codes it threw out 2 days ago witch was for the o2 sensor replaced that got the cel light to go off for a cruz put it in the garage took it out this morning and it was on immediately..

    Again I appreciate all the help I can get

  7. #6
    He simply abides. SD_GR's Avatar
    Join Date
    Jul 2002
    Location
    CA, US
    Posts
    22,481
    I Support ClubWRX
    If there is no aftermarket turbo on the car it could be that the car was returned to semi-stock for sale. As listed there is no reason to have the FMIC on the car. It is the FMIC which may have lead to the BOV and intake (though some people insist on using intakes for no reason anyway).

    Roll up your sleeves:

    First check that the test connectors under the dash are disconnected; they should not be connected.

    The PO171 should not be occurring legitimately if the car were running rich; a PO172 would be expected instead. Therefore the PO171 could be due to the intake and/or BOV or another such leak in vac or boost lines.

    Check the reference connection to the fuel pressure regulator.

    Follow the instructions in this thread:IF YOU HAVE A MISFIRE CODE ,PLEASE READ THIS!!!
    WRX Info Links, Courtesy TheJ
    The world breaks everyone and afterward many are strong in the broken places. Ernest Hemingway
    I lied. I cheated. I bribed men to cover the crimes of other men. I am an accessory to murder. But the most damning thing of all... I think I can live with it. And if I had to do it all over again - I would. Benjamin Sisko
    DISCLAIMER: Opinions expressed are the author's alone and are inherently worthless.

  8. #7
    Registered User Impreza2.0's Avatar
    Join Date
    Nov 2008
    Location
    Maine
    Posts
    900
    A picture of your engine from a few different angles would be very helpful so that we can see what if any mistakes could have been made in the installation of any aftermarket or replaced original parts.

    I had a similar set of symptoms when a fuel line was not reattached properly by a shop that replaced my inline filter. At this point, I would recommend against driving it until you have a chance to figure out what is wrong. Raw fuel is dangerous.

    A CEL is not something to force away, it should be addressed, since it is there to let you know that there is something that needs to be fixed to be safe.

    Removing the bulb will not fix a fueling issue.

    The stock fueling system is well made and has little trouble with the exception of a line which should have been replaced on recall a few years ago.

    SD_GR probably knows the recall notice number, if not I can find mine. It addresses a fuel leak on the pre-filter line on the drivers side next to the shock tower. Any Subaru dealership can replace this piece for no charge in under 1 hour.

  9. #8
    Registered User
    Join Date
    Mar 2013
    Posts
    23
    Dude thanks for the help imma try that to see if it gets fixed I just checked the plugs under the dash they are not connected I'm going to go down that list that you posted to see if it gets fixed I hope it's nothing too major to get fixed..

  10. #9
    Registered User
    Join Date
    Mar 2013
    Posts
    23
    Quote Originally Posted by Impreza2.0 View Post
    A picture of your engine from a few different angles would be very helpful so that we can see what if any mistakes could have been made in the installation of any aftermarket or replaced original parts.

    I had a similar set of symptoms when a fuel line was not reattached properly by a shop that replaced my inline filter. At this point, I would recommend against driving it until you have a chance to figure out what is wrong. Raw fuel is dangerous.

    A CEL is not something to force away, it should be addressed, since it is there to let you know that there is something that needs to be fixed to be safe.

    Removing the bulb will not fix a fueling issue.

    The stock fueling system is well made and has little trouble with the exception of a line which should have been replaced on recall a few years ago.

    SD_GR probably knows the recall notice number, if not I can find mine. It addresses a fuel leak on the pre-filter line on the drivers side next to the shock tower. Any Subaru dealership can replace this piece for no charge in under 1 hour.
    Ok thanks for the input as well I'm going to take pictures of everything and post them up so you can see what is exactly going on with the motor

  11. #10
    He simply abides. SD_GR's Avatar
    Join Date
    Jul 2002
    Location
    CA, US
    Posts
    22,481
    I Support ClubWRX
    I wonder if the car is running a map for a larger turbo that no longer exists or if some other return-to-stock-for-sale error is causing all this.
    WRX Info Links, Courtesy TheJ
    The world breaks everyone and afterward many are strong in the broken places. Ernest Hemingway
    I lied. I cheated. I bribed men to cover the crimes of other men. I am an accessory to murder. But the most damning thing of all... I think I can live with it. And if I had to do it all over again - I would. Benjamin Sisko
    DISCLAIMER: Opinions expressed are the author's alone and are inherently worthless.

  12. #11
    Registered User
    Join Date
    Mar 2013
    Posts
    23
    Quote Originally Posted by SD_GR View Post
    I wonder if the car is running a map for a larger turbo that no longer exists or if some other return-to-stock-for-sale error is causing all this.
    How would I find out if it was running a bigger turbo with a map I'm about to post the pictures of the engine to see what you all think

  13. #12
    He simply abides. SD_GR's Avatar
    Join Date
    Jul 2002
    Location
    CA, US
    Posts
    22,481
    I Support ClubWRX
    Ask the seller directly if possible for a complete list of what was once there for which the car has been mapped. If not, a pic is another option though that'll only tell us if the exhaust has been swapped, not whether a turbo was once there. Larger injectors are a clue though.
    WRX Info Links, Courtesy TheJ
    The world breaks everyone and afterward many are strong in the broken places. Ernest Hemingway
    I lied. I cheated. I bribed men to cover the crimes of other men. I am an accessory to murder. But the most damning thing of all... I think I can live with it. And if I had to do it all over again - I would. Benjamin Sisko
    DISCLAIMER: Opinions expressed are the author's alone and are inherently worthless.

  14. #13
    Registered User
    Join Date
    Mar 2013
    Posts
    23
    Quote Originally Posted by SD_GR View Post
    Ask the seller directly if possible for a complete list of what was once there for which the car has been mapped. If not, a pic is another option though that'll only tell us if the exhaust has been swapped, not whether a turbo was once there. Larger injectors are a clue though.
    Ok we'll I don't mean to take so long in replying but I'm finishing up a couple of things here I'm about to post some pictures of the set up

    Now so far what I found is that the spark plugs are gapped at .044 witch u believe is way to big of a gap and the maf was a little dirty cleaned it up going to re gap at .028 witch I believe is ideal for a stock set up but please correct me if I'm wrong but I'm almost done here I didn't know how hard it was to change the spark plugs they look ok don't look fouled or anything

  15. #14
    Registered User
    Join Date
    Mar 2013
    Posts
    23
    Click image for larger version. 

Name:	IMG_0215.jpg 
Views:	36 
Size:	81.8 KB 
ID:	112865Click image for larger version. 

Name:	IMG_0221.jpg 
Views:	36 
Size:	58.7 KB 
ID:	112866Click image for larger version. 

Name:	IMG_0224.jpg 
Views:	36 
Size:	49.8 KB 
ID:	112867Click image for larger version. 

Name:	IMG_0225.jpg 
Views:	36 
Size:	48.6 KB 
ID:	112868Click image for larger version. 

Name:	IMG_0227.jpg 
Views:	35 
Size:	83.6 KB 
ID:	112869Click image for larger version. 

Name:	IMG_0228.jpg 
Views:	36 
Size:	52.3 KB 
ID:	112870Click image for larger version. 

Name:	IMG_0229.jpg 
Views:	36 
Size:	60.2 KB 
ID:	112871Click image for larger version. 

Name:	IMG_0230.jpg 
Views:	35 
Size:	62.8 KB 
ID:	112872Click image for larger version. 

Name:	IMG_0232.jpg 
Views:	35 
Size:	67.1 KB 
ID:	112873

  16. #15
    Registered User
    Join Date
    Mar 2013
    Posts
    23
    for some reason all the pictures have not uploaded let me see if i can get them to upload of the engine bay

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •