Boost psi/wastegate issue
+ Reply to Thread
Results 1 to 5 of 5

This is a discussion on Boost psi/wastegate issue within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; How y'all doing? New guy here my 2002 wrx was peeking at 7 psi I ticketed around and finally after ...

  1. #1
    Registered User
    Join Date
    Mar 2013
    Location
    South jersey
    Posts
    11

    Boost psi/wastegate issue

    How y'all doing? New guy here my 2002 wrx was peeking at 7 psi I ticketed around and finally after bypassing my wastegate I found I can finally reach full boost and it drives fine. I would rather not keep it this way due to I'm sure it can harm the turbo after time but not sure what to start looking at. Any help would be great thank you.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Master Baiter EJ257's Avatar
    Join Date
    Aug 2007
    Location
    On a stream bank somewhere
    Posts
    19,853
    I Support ClubWRX
    Have you verified your BCS is still working?
    2005 WRX STi (Mods | Virtual Dyno)

    Resident Tuner @ WTF Tuning

    "Never trust anything that bleeds for a week and lives ..."

    UNYSOC

  4. #3
    Registered User
    Join Date
    Mar 2013
    Location
    South jersey
    Posts
    11
    Boot control silinoid ? Yes I did and it work fine

  5. #4
    Master Baiter EJ257's Avatar
    Join Date
    Aug 2007
    Location
    On a stream bank somewhere
    Posts
    19,853
    I Support ClubWRX
    All the vacuum lines in proper working order? Restrictor pill in place?
    2005 WRX STi (Mods | Virtual Dyno)

    Resident Tuner @ WTF Tuning

    "Never trust anything that bleeds for a week and lives ..."

    UNYSOC

  6. #5
    Registered User
    Join Date
    Mar 2013
    Location
    South jersey
    Posts
    11
    From what I noticed yes. I'm a complete nood to the wrx life and I bought the car knowing of the issue did research on what to check and look at and it seemed like the only thing that was working was how te previous owner had it set up it kind of has me astray bc it's my daily driver. Like I said it's running great you wouldn't even know there is an issue I'm just worried about longer term effects on the car

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •