help i think
Results 1 to 3 of 3

This is a discussion on help i think within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Recently picked up my 03 wrx.. driving to work this morning I noticed under full boost the break and battery ...

  1. #1
    Registered User
    Join Date
    Feb 2013
    Location
    lakewood/golden
    Posts
    8

    help i think

    Recently picked up my 03 wrx.. driving to work this morning I noticed under full boost the break and battery lights flash just for a second. I am able to duplicate it repeatedly. Stopped after work and had the alternator and battery tested both passed with flying colors. Also checked the break fluid resivor which was full.

    I am new here but learned a long time ago to search first that being sais i found only 1 thread and after reading it wasn't the same issue.

    Sorry for the spelling and punctipuation not easy on my phone to type this out

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Subaru Newb MainFrame's Avatar
    Join Date
    Sep 2002
    Location
    Texas, United States
    Posts
    7,946
    I Support ClubWRX I Support ClubWRX
    I had a "spare" alternator that was on its last legs installed for a short time.. it worked fine, except when accelerating hard the brake and battery lights would flash. I would bet on your alternator. Maybe it works okay at idle, but under load it isn't providing sufficient voltage.

  4. #3
    Registered User
    Join Date
    Feb 2013
    Location
    lakewood/golden
    Posts
    8
    Hmm bet that's it at least it makes since thanks I'll look into it

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •