Car wont fire.....
+ Reply to Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 16

This is a discussion on Car wont fire..... within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Car stalled out on me one nite and had to have it towed. 2004 wrx 2.0 invidia downpipe stage 2 ...

  1. #1
    Registered User Clark1989's Avatar
    Join Date
    Aug 2011
    Location
    Penn Run, Pennsylvania, United States
    Posts
    72

    Car wont fire.....

    Car stalled out on me one nite and had to have it towed. 2004 wrx 2.0 invidia downpipe stage 2 tune and turbo back exhaust and cobb sf intake. Changed fuel pump to a walboro 255 thinking it was fuel related car ran fine then stalled out the next morning at idle. Changed fuel filter in engine bay and ran fine then did same thing next morning. Drained all fuel changed filter under the hood again ran new 93 and now it wont fire
    2004 WRX Cobb SF
    TurboXs RFL Recirculating
    Invidia V2 DP SRS Catback 285hp 283ft lbs

    Jimmy
    Blobeye Syndicate #3553

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User UEDan's Avatar
    Join Date
    Oct 2011
    Location
    Santa Ana, CA
    Posts
    1,143
    Pull your plugs. Are you getting fuel? Clogged injectors?
    Fuel. Are you getting a spark. Coilpacks? Bad fuse?

  4. #3
    Registered User Clark1989's Avatar
    Join Date
    Aug 2011
    Location
    Penn Run, Pennsylvania, United States
    Posts
    72
    Definitely getting a steady stream of fuel and as for plugs and injectors i havent checked those yet. Would there be any CEL associated with bad plugs? Maybe crank or cam sensor possibly? But that would throw a CEL code if im not mistaken. At this point im very frustrated and would rather not take it to a garage to get bent over with diagnosing costs and labor....

  5. #4
    Registered User oguitar's Avatar
    Join Date
    Nov 2009
    Location
    Albuquerque, New Mexico, United States
    Posts
    1,021
    How old is the battery?
    Life is like riding a bicycle in order to keep your balance you must keep moving.

  6. #5
    Good news, everyone! xxxxxxxAnub1s's Avatar
    Join Date
    Jan 2005
    Location
    Eh, whaaaaa?
    Posts
    3,855
    I Support ClubWRX
    How well seated is the ground on your battery?
    Cody
    Hawk-Eye Alliance #727 N.E.R.D #255.255.255.0

    Your nighttime volunteer of near-useless information.
    Good news, everyone!

  7. #6
    Registered User Clark1989's Avatar
    Join Date
    Aug 2011
    Location
    Penn Run, Pennsylvania, United States
    Posts
    72
    Well ground wire looks fine and my battery is a subaru battery and its only around 4 months old. Even had it hooked to my truck when i tried to start it
    2004 WRX Cobb SF
    TurboXs RFL Recirculating
    Invidia V2 DP SRS Catback 285hp 283ft lbs

    Jimmy
    Blobeye Syndicate #3553

  8. #7
    Registered User Ingo's Avatar
    Join Date
    Mar 2012
    Location
    Colorado Springs, CO
    Posts
    1,110
    If it turns over strong with the starter it's most likely NOT the battery or its connections. Anything else is still possible... Pull the plugs, are they wet? If you get no spark they should be soaked in gasoline. If they're dry your injectors are likely not firing (not opening...), check your fuses also.
    You can't have everything - where would you put it?

  9. #8
    Pro Manscaper Mikie13's Avatar
    Join Date
    Oct 2006
    Location
    Palmyra, NJ
    Posts
    21,117
    What about the fuel filter in the pump assembly in the tank? That has been known to get clogged over time...
    The Hawk-Eye Alliance #90|The Blobeye Syndicate #0|The Stink-Eye Mob #0|N.E.R.D. Founding Member & #3
    2012 Lightning Red WRX Sedan
    Stock...for now Soon to be OpenSource tuned by: Mattypants @ WTF Tuning

  10. #9
    Registered User Clark1989's Avatar
    Join Date
    Aug 2011
    Location
    Penn Run, Pennsylvania, United States
    Posts
    72
    Ok update on car. Let it sit in a heated garage and it fired up. Why would it fire when warm but stall and just crank when cold?
    2004 WRX Cobb SF
    TurboXs RFL Recirculating
    Invidia V2 DP SRS Catback 285hp 283ft lbs

    Jimmy
    Blobeye Syndicate #3553

  11. #10
    Pro Manscaper Mikie13's Avatar
    Join Date
    Oct 2006
    Location
    Palmyra, NJ
    Posts
    21,117
    Battery.
    The Hawk-Eye Alliance #90|The Blobeye Syndicate #0|The Stink-Eye Mob #0|N.E.R.D. Founding Member & #3
    2012 Lightning Red WRX Sedan
    Stock...for now Soon to be OpenSource tuned by: Mattypants @ WTF Tuning

  12. #11
    Registered User Clark1989's Avatar
    Join Date
    Aug 2011
    Location
    Penn Run, Pennsylvania, United States
    Posts
    72
    Well car still wouldnt fire the other night even with it hooked up with jumpers to my truck
    2004 WRX Cobb SF
    TurboXs RFL Recirculating
    Invidia V2 DP SRS Catback 285hp 283ft lbs

    Jimmy
    Blobeye Syndicate #3553

  13. #12
    Good news, everyone! xxxxxxxAnub1s's Avatar
    Join Date
    Jan 2005
    Location
    Eh, whaaaaa?
    Posts
    3,855
    I Support ClubWRX
    So car turns over in cold or warm, won't start when cold. But will turn over and eventually run when it's warmed up? Could be fuel related, still.

    That is definitely typical bad battery behavior, although it usually rears it's head in the form of slow cranking; not cranking and lack of starting.
    Cody
    Hawk-Eye Alliance #727 N.E.R.D #255.255.255.0

    Your nighttime volunteer of near-useless information.
    Good news, everyone!

  14. #13
    Pro Manscaper Mikie13's Avatar
    Join Date
    Oct 2006
    Location
    Palmyra, NJ
    Posts
    21,117
    Valid point Code-man...


    Get a new wife.
    The Hawk-Eye Alliance #90|The Blobeye Syndicate #0|The Stink-Eye Mob #0|N.E.R.D. Founding Member & #3
    2012 Lightning Red WRX Sedan
    Stock...for now Soon to be OpenSource tuned by: Mattypants @ WTF Tuning

  15. #14
    Registered User Clark1989's Avatar
    Join Date
    Aug 2011
    Location
    Penn Run, Pennsylvania, United States
    Posts
    72
    Unplugged the maf sensor and car started up fine. Plugged it back in and had same issues.
    2004 WRX Cobb SF
    TurboXs RFL Recirculating
    Invidia V2 DP SRS Catback 285hp 283ft lbs

    Jimmy
    Blobeye Syndicate #3553

  16. #15
    Pro Manscaper Mikie13's Avatar
    Join Date
    Oct 2006
    Location
    Palmyra, NJ
    Posts
    21,117
    Quote Originally Posted by Mikie13 View Post
    Valid point Code-man...


    Get a new maf.
    See what I said up there?
    The Hawk-Eye Alliance #90|The Blobeye Syndicate #0|The Stink-Eye Mob #0|N.E.R.D. Founding Member & #3
    2012 Lightning Red WRX Sedan
    Stock...for now Soon to be OpenSource tuned by: Mattypants @ WTF Tuning

+ Reply to Thread
Page 1 of 2 12 LastLast

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •