'05 with P0244 and pinging on harder accel
+ Reply to Thread
Results 1 to 4 of 4

This is a discussion on '05 with P0244 and pinging on harder accel within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Please forgive me if you have already addressed this issue -- new to the site and I am trying to ...

  1. #1
    Registered User
    Join Date
    Feb 2013
    Posts
    3

    '05 with P0244 and pinging on harder accel

    Please forgive me if you have already addressed this issue -- new to the site and I am trying to help a friend fix his "baby".
    Need help with a completely stock 2005 legacy wagon that pings on hard accel and you feel it hold back for a sec then come back on boost and ping then shut down or "limp" then flashing cruise light and P0244 for boost control. the car runs fine under "normal" driving conditions as long I stay off the higher boost levels. I also have a leak from my Intercooler tank seal which I suspect is due to overboost. Any suggestions? I don't have any gauges so I don't know how much boost sets the code or how much actual boost the car is making but suspect Waste gate or Waste gate control solenoid. Then will replace Intercooler.

    2005 Legacy Wagon, 2.5L DOHC Turbo
    Car is COMPLETELY STOCK, friend has had since new.
    175k miles
    auto trans.

    He loves the car. Just can't figure this one out. Very mechanical I am just "new" to issues on this car.

    Thank you.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Moderator Donkey's Avatar
    Join Date
    Apr 2005
    Location
    Da boonies
    Posts
    6,296
    I Support ClubWRX
    Hopefully he is running 93 octane. You could try cleaning the solenoid with electronics cleaner or non-chlorinated brake cleaner. Also try Seafoaming the engine.
    Resident Adviser @ WTF Tuning, LLC
    2002 FORESTER S
    1998 FORESTER S




  4. #3
    Registered User
    Join Date
    Feb 2013
    Posts
    3
    Thank you. Is there any way to test the solenoid? At what pressure should the wastegate begin to open?

  5. #4
    Moderator Donkey's Avatar
    Join Date
    Apr 2005
    Location
    Da boonies
    Posts
    6,296
    I Support ClubWRX
    The solenoid can be tested via a 12 volt source. Unfortunately it's true operation is not "open/closed". It is controlled via the ECU by varying duty cycle. Also it is a PID type of control.
    Resident Adviser @ WTF Tuning, LLC
    2002 FORESTER S
    1998 FORESTER S




+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •