Got a MIL/CEL w/ a P0420 trouble code on my '04 WRX...Suggestions.
+ Reply to Thread
Results 1 to 6 of 6

This is a discussion on Got a MIL/CEL w/ a P0420 trouble code on my '04 WRX...Suggestions. within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Hi Fellas, I had replaced a upstream Oxygen Sensor on it several months ago (on my '04 WRX) and everything ...

  1. #1
    Registered User
    Join Date
    Sep 2012
    Location
    Northeast
    Posts
    8

    Got a MIL/CEL w/ a P0420 trouble code on my '04 WRX...Suggestions.

    Hi Fellas,


    I had replaced a upstream Oxygen Sensor on it several months ago (on my '04 WRX) and everything went well.

    Fast forward to about a week or two weeks ago got a MIL/CEL, and said to myself WTF now...got my scanning
    tool out and it read P0420 trouble code (Cat. Converter, [possibly downstream O2 senor] below threshold B1/B2).

    So I'm thinking...I had recently crossed a flooded exit ramp on a highway which submerged the whole exaust system
    for about 3-5 seconds and I am wondering if water got in the Cat Converter/O2 Sensor and if that had caused the
    problem...or maybe not...suggestions ?

    Thanks for any help/suggestions.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User Obeisance's Avatar
    Join Date
    Apr 2012
    Location
    not Ann Arbor
    Posts
    320
    Do you suppose that there is any chance that the water somehow damaged the electrical connections for the sensors? Maybe rust on old wires, or a short circuit? Did your recently installed O2 sensor have wires come loose over a few weeks?
    David - '05 WRX

  4. #3
    Registered User
    Join Date
    Sep 2012
    Location
    Northeast
    Posts
    8
    Quote Originally Posted by Obeisance View Post
    Do you suppose that there is any chance that the water somehow damaged the electrical connections for the sensors? Maybe rust on old wires, or a short circuit? Did your recently installed O2 sensor have wires come loose over a few weeks?


    Yeah that is a possiblity...It never had a Issue before that (other than the upstream O2 sensor that was replaced after 70K miles), and
    after the MIL/CEL lamp was reset it was good for a week or so...It happened only after the ponding/flooding Incident...Hhhmmm.

  5. #4
    Registered User
    Join Date
    Sep 2012
    Location
    Northeast
    Posts
    8
    Anyone with other suggestions or experiances...

  6. #5
    Registered User veteran011's Avatar
    Join Date
    Dec 2012
    Location
    Westchester Co, NY
    Posts
    34
    How long did the car run with a CEL for a bad O2 sensor before you replaced it? There's a possibility that you may need a new cat.
    WARNING: Has Dumb Ideas

    Dab of Oppo anyone?

  7. #6
    Registered User Obeisance's Avatar
    Join Date
    Apr 2012
    Location
    not Ann Arbor
    Posts
    320
    Any updates? I've now experienced a very similar CEL: I replaced the front A/F sensor this past summer (from P0031, I think) and I now have the P0420 (a few months after the replace, just like you). Have you been able to fix this?
    David - '05 WRX

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •