Factory alarm issues
Results 1 to 4 of 4

This is a discussion on Factory alarm issues within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Hey guys, ive been having problems with my alarm system lately... My alternator went bad last week, and my battery ...

  1. #1
    Registered User morgankwright26's Avatar
    Join Date
    Dec 2012
    Posts
    6

    Factory alarm issues

    Hey guys, ive been having problems with my alarm system lately... My alternator went bad last week, and my battery died a few times, had to disconnect it a few times for trouble shooting and whatnot,,, and ever since then, every time i unlock the car, the alarm goes off(thank god i disconnected my horn or else it would wake everyone on the block when i had to go anywhere), and the immobilizer kicks in, and i have to cycle the key three times to shut it off, and then i can go... this is getting pretty irritating, any ideas as to where to start? i dont have a keyless entry(that i know of) since i got the car about 3 weeks ago and they only gave me the door/ignition key..

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User Ingo's Avatar
    Join Date
    Mar 2012
    Location
    Colorado Springs, CO
    Posts
    1,110
    What year isit? The later ones all have remote locking (I think). If you hit the lock button inside the door and later just unlock with key, this is normal. I'm not sure if you can avoid the alarm by manually locking the door with the little lever at the inside handle... Meaning to lock all the doors while engine is still running, unlock the drivers door and then on exiting lock the drivers door manually. This might avoid activating the built in alarm. My guess is that the alarm WAS disabled before and the loss of power re-set it to "normal" i.e. functioning.
    You can't have everything - where would you put it?

  4. #3
    Registered User morgankwright26's Avatar
    Join Date
    Dec 2012
    Posts
    6
    2003,,, anyway to disable it or make it so that i dont have to deal with the immobilizer or flashing lights?

  5. #4
    Registered User Ingo's Avatar
    Join Date
    Mar 2012
    Location
    Colorado Springs, CO
    Posts
    1,110
    Not that I know of. Mine (a '09) when this happens the coded key overrides everything, it shuts up and it starts right away..., sorry to not be of more help with this. BTW, the remote thingy is QUITE expensive, but you might be able to get one used for cheap, Craigslist or E-bay, and program it into your car yourself. My WRX came with only one remote, the wifey NEEDED her own, that's why I know expensive, but programming is actually almost easy.
    You can't have everything - where would you put it?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •