popping/Knocking Sound?
Results 1 to 7 of 7

This is a discussion on popping/Knocking Sound? within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Hey guys, I have a 2007 Wrx with KW coilovers and ive been having this problem off and on for ...

  1. #1
    Registered User
    Join Date
    Oct 2012
    Location
    Lowell, MA
    Posts
    7

    popping/Knocking Sound?

    Hey guys,
    I have a 2007 Wrx with KW coilovers and ive been having this problem off and on for awhile...
    I can hear a popping noise coming from what seems to be the passengers side wheel well. It sounds almost like a popcorn Machine? Its been happening all the time lately when im over 40 MPH... but only when i dont have full throttle on the car... once i let off the gas or are just maintaining my speed the noise comes back and its not a steady pop it happens at random but very close together? Any imput would be appreciated. I have brought it to my local shop but they cant seem to figure out what it could be...

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Master Baiter EJ257's Avatar
    Join Date
    Aug 2007
    Location
    On a stream bank somewhere
    Posts
    19,663
    I Support ClubWRX
    Do the rears need a rebuild?
    2005 WRX STi (Mods | Virtual Dyno)

    Resident Tuner @ WTF Tuning, LLC

    "Never trust anything that bleeds for a week and lives ..."

    UNYSOC

  4. #3
    Registered User
    Join Date
    Oct 2012
    Location
    Lowell, MA
    Posts
    7
    to be honest i have the stock top mounts in the car in the front and the people at kinetic told me that they are shot so im going to get the group n mounts

  5. #4
    Registered User
    Join Date
    Oct 2012
    Location
    Lowell, MA
    Posts
    7
    the rears are leaking

  6. #5
    Registered User teflon_jones's Avatar
    Join Date
    Apr 2007
    Location
    8000' up in Colorado
    Posts
    6,753
    Did the noise start when you put on the coilovers, or was it there already?
    Scott
    Past Subies - '11 STI Limited stage 1+ and '04 STi stage 2+
    '13 Wrangler Rubicon - custom front bumper w/12k lb winch & off-road lights, skid plates, diff guards, etc.
    '04 Porsche 911 Turbo GT2 clone 600 HP/TQ
    '77 F-150 heavily modded for off-roading

  7. #6
    Registered User
    Join Date
    Oct 2012
    Location
    Lowell, MA
    Posts
    7
    i bought the car with the coilovers installed and the noise wasnt there but after about 8 months, the noise started and i had an alignment and after awhile the noise went away... then the noise came back againg but this time it is constant. ive checked all the suspension parts and cant seem to see anything that would be causing the problem

  8. #7
    Registered User
    Join Date
    Oct 2012
    Location
    Lowell, MA
    Posts
    7
    i had an alignment about 4 months ago and had brand new tires installed as well..

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •