inconsistent boost 2003 wrx
Results 1 to 12 of 12

This is a discussion on inconsistent boost 2003 wrx within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; starting yesterday my car has inconsistently been boosting. im curious what could be causing this? i have a factory oem ...

  1. #1
    Registered User
    Join Date
    Oct 2012
    Location
    Seattle WA
    Posts
    17

    inconsistent boost 2003 wrx

    starting yesterday my car has inconsistently been boosting. im curious what could be causing this? i have a factory oem turbo gague and it shows that i have boost but about 10% of the time the engine doesnt actually boost (also its not my gauge that is broken because i can feel the car not boosting). right after it doesnt boost my oil light comes on and flashes for about 2 seconds (oil was changed 950 miles ago). i was told that it could be my ecu and i need to reset it. is this true? if so how do i reset my map to the stock factory one. has anyone else had this problem?
    thanks for the help!
    Ben

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User
    Join Date
    Oct 2012
    Location
    Seattle WA
    Posts
    17
    correction, it is the oil pressure light that flashes

  4. #3
    Good news, everyone! xxxxxxxAnub1s's Avatar
    Join Date
    Jan 2005
    Location
    Eh, whaaaaa?
    Posts
    3,855
    I Support ClubWRX
    Are you sure it's the oil light and not the CEL? If the CEL is flashing then that means you have a misfire problem, and will need to sort that one out. If it's actually the oil light, that indicates a loss of pressure, and the car should be parked, no if's and's or but's, until you get it sorted out.

    What are your modifications? Sounds like another case of an improperly modified Subaru acting up.
    Cody
    Hawk-Eye Alliance #727 N.E.R.D #255.255.255.0

    Your nighttime volunteer of near-useless information.
    Good news, everyone!

  5. #4
    Registered User
    Join Date
    Oct 2012
    Location
    Seattle WA
    Posts
    17
    This is all that is done to it
    OEM SHORT SHIFTER
    OEM BOOST GAGUE
    OEM WEIGHTED SHIFT KNOB
    TSUDO 3inch TURBO BACK (catless) EXHAUST
    RALLY ARMOR MUD FLAPPS
    K&N AIR FILTER
    KYB SUSPENSION
    TENZO DC-5 17in bronze rims

    The weird thing is that 90% of the time it works perfectly fine. But then it randomly won't boost, and shortly after the light comes on for about 2 seconds if that.

  6. #5
    Captain James of the SS Impreza has gone down with the ship Drews's Avatar
    Join Date
    Aug 2008
    Location
    Davey Jones Locker
    Posts
    8,583
    I Support ClubWRX
    You probably need a tune. Check your oil too while you're at it. How many miles are on it and was the timing belt done?
    Hawk-Eye Alliance #Eleventy,000,000,000|N.E.R.D. Member 20,000
    Stable: 2014 Hyundai Veloster Turbo (Matte Grey), 06 LGT, 03 WRX, 98 RS, 00 OBS


    Resident Clubdub Debbie Downer. I'd love your ideas if you kept them to yourself. Subarus suck, get a new wife.

    Never argue with idiots. They'll drag you to their level and beat you with experience.

  7. #6
    Registered User
    Join Date
    Oct 2012
    Location
    Seattle WA
    Posts
    17
    125,000 I'm the 3rd owner I've had it about 3 weeks. Clean title and last service was at 90,000ish miles I think. Not sure off the top of my head. I haven't had any other problems with the car. However the other day I did redline my car and the limiter kicked in, I was doing 67 in 2nd gear. I don't think this has anything to do with the problem. But I figured I'd throw it out there.

  8. #7
    Captain James of the SS Impreza has gone down with the ship Drews's Avatar
    Join Date
    Aug 2008
    Location
    Davey Jones Locker
    Posts
    8,583
    I Support ClubWRX
    Quote Originally Posted by Bmatt2c View Post
    125,000 I'm the 3rd owner I've had it about 3 weeks. Clean title and last service was at 90,000ish miles I think. Not sure off the top of my head. I haven't had any other problems with the car. However the other day I did redline my car and the limiter kicked in, I was doing 67 in 2nd gear. I don't think this has anything to do with the problem. But I figured I'd throw it out there.
    Probably not. But I'd try and find out if the timing belt was done. I'd also get a tune.
    Hawk-Eye Alliance #Eleventy,000,000,000|N.E.R.D. Member 20,000
    Stable: 2014 Hyundai Veloster Turbo (Matte Grey), 06 LGT, 03 WRX, 98 RS, 00 OBS


    Resident Clubdub Debbie Downer. I'd love your ideas if you kept them to yourself. Subarus suck, get a new wife.

    Never argue with idiots. They'll drag you to their level and beat you with experience.

  9. #8
    Registered User
    Join Date
    Oct 2012
    Location
    Seattle WA
    Posts
    17
    Ok, thanks. Also when I get a tune, what kind of map would you suggest? Or should I have it reset to the stock tune?

  10. #9
    Captain James of the SS Impreza has gone down with the ship Drews's Avatar
    Join Date
    Aug 2008
    Location
    Davey Jones Locker
    Posts
    8,583
    I Support ClubWRX
    Quote Originally Posted by Bmatt2c View Post
    Ok, thanks. Also when I get a tune, what kind of map would you suggest? Or should I have it reset to the stock tune?
    You have an aftermarket downpipe so you'll want a stage 2 tune. Do not hammer on the car until you get a tune or at least log your car to see what the problem is.
    Hawk-Eye Alliance #Eleventy,000,000,000|N.E.R.D. Member 20,000
    Stable: 2014 Hyundai Veloster Turbo (Matte Grey), 06 LGT, 03 WRX, 98 RS, 00 OBS


    Resident Clubdub Debbie Downer. I'd love your ideas if you kept them to yourself. Subarus suck, get a new wife.

    Never argue with idiots. They'll drag you to their level and beat you with experience.

  11. #10
    Registered User
    Join Date
    Oct 2012
    Location
    Seattle WA
    Posts
    17
    Ok, I will try to not to drive it under boost in till then. Also i have been considering getting an accessport. I haven't really looked into it but I know generally what it does. After I get a stage 2 tune, would this be a good idea? I assume by stage 2 you mean a Cobb stage 2 tune?

  12. #11
    Captain James of the SS Impreza has gone down with the ship Drews's Avatar
    Join Date
    Aug 2008
    Location
    Davey Jones Locker
    Posts
    8,583
    I Support ClubWRX
    Quote Originally Posted by Bmatt2c View Post
    Ok, I will try to not to drive it under boost in till then. Also i have been considering getting an accessport. I haven't really looked into it but I know generally what it does. After I get a stage 2 tune, would this be a good idea? I assume by stage 2 you mean a Cobb stage 2 tune?
    Any stage 2 tune will do. Accessports are expensive, it just depends on the tuner you use.
    Hawk-Eye Alliance #Eleventy,000,000,000|N.E.R.D. Member 20,000
    Stable: 2014 Hyundai Veloster Turbo (Matte Grey), 06 LGT, 03 WRX, 98 RS, 00 OBS


    Resident Clubdub Debbie Downer. I'd love your ideas if you kept them to yourself. Subarus suck, get a new wife.

    Never argue with idiots. They'll drag you to their level and beat you with experience.

  13. #12
    Registered User
    Join Date
    Oct 2012
    Location
    Seattle WA
    Posts
    17
    Quote Originally Posted by Bmatt2c View Post
    This is all that is done to it
    OEM SHORT SHIFTER
    OEM BOOST GAGUE
    OEM WEIGHTED SHIFT KNOB
    TSUDO 3inch TURBO BACK (catless) EXHAUST
    RALLY ARMOR MUD FLAPPS
    K&N AIR FILTER
    KYB SUSPENSION
    TENZO DC-5 17in bronze rims

    The weird thing is that 90% of the time it works perfectly fine. But then it randomly won't boost, and shortly after the light comes on for about 2 seconds if that.
    Also forgot my car has a snorkus delete.. The intake silencer is removed

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •