loss of power and sputtering ticking sound
Results 1 to 3 of 3

This is a discussion on loss of power and sputtering ticking sound within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; hey everyone, i am new to this website but i have owned my 2007 wrx tr for about 1 1/2 ...

  1. #1
    Registered User
    Join Date
    Oct 2012
    Location
    Lowell, MA
    Posts
    7

    loss of power and sputtering ticking sound

    hey everyone, i am new to this website but i have owned my 2007 wrx tr for about 1 1/2 years now and the car is stage 2 tuned with full catless turboback exhaust intake and obviously ecu protune from dentsport garage.
    when i first bought the car it was amazing!!! a couple months later the car started making a sputtering/ ticking noise that can only be heard by me when im beside another car or against a guardrail...
    the noise is only there while the turbo is spooling or during boost. the noise is also accompanied by power loss. when i bought the car it had a dyno sheet to come with it that said i had about 243 hp and 300 ft lbs of torque to the wheels...
    i have brought it to the dealership and to kinetic motorworks in hampstead nh and they cant figure it out so i figured i would ask subie owners and see if anyone could help me out....?
    thankyou for you time...

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Master Baiter EJ257's Avatar
    Join Date
    Aug 2007
    Location
    On a stream bank somewhere
    Posts
    19,670
    I Support ClubWRX
    The ticking next to a guard rail leads me to believe it's an exhaust leak. The power loss indicates pre-turbo.
    2005 WRX STi (Mods | Virtual Dyno)

    Resident Tuner @ WTF Tuning, LLC

    "Never trust anything that bleeds for a week and lives ..."

    UNYSOC

  4. #3
    Registered User
    Join Date
    Oct 2012
    Location
    Lowell, MA
    Posts
    7
    im wondering if it could also be something to do with needing a tuneup... it has 73,000 and i dont think its ever had one.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •