p0420.........again.......
+ Reply to Thread
Results 1 to 10 of 10

This is a discussion on p0420.........again....... within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; so last march I got the p0420 code. Changed out the sensor and everything worked fine.......until 30 minutes ago.... The ...

  1. #1
    Registered User
    Join Date
    Feb 2012
    Location
    iowa
    Posts
    24

    p0420.........again.......

    so last march I got the p0420 code. Changed out the sensor and everything worked fine.......until 30 minutes ago.... The dreaded p0420 has returned. Before I go replacing the sensor again I thought I would stop by. Is it possible something else is wrong. Today the temp dropped to 30 degrees similar to what it was the first time. Is it possible the cold is causing a problem elsewhere or might I have gotten a bad sensor? It didn't happen until the car was fully warmed up. It seems unlikely that A) the original sensor went bad after only 32,000 miles and B) the replacement went bad after only 10,000. Anyone hear of something similar or am I unlucky?

    here's a link to my thread from march for the background
    another P0420 thread

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    and the Funky Bunch Calvinball's Avatar
    Join Date
    Jan 2012
    Location
    Philly Area
    Posts
    5,970
    Year, mileage, modifications?

    I only scanned your other thread, sorry if you already listed these items there.
    - Will
    First Mods: What to do and what not to do
    Current Car: 2014 Golf TDI
    Previous Cars:2012 WRB WRX Hatch, 2004 RSX-S, 1998 Grand Prix GTP
    "Isn't it amazing how smart you feel when you just aren't being stupid?"

  4. #3
    zax
    zax is offline
    \_(ツ)_/ zax's Avatar
    Join Date
    Nov 2008
    Location
    Neverland Ranch, Maryland
    Posts
    13,158
    I Support ClubWRX I Support ClubWRX
    You changed out the Rear O2 sensor? What mods are on the car and what year?

    If it's a 2L, I think high EGT will trip the catalyst efficiency code as well.
    2015 CWP WRX STi ... But how did I get roped back into an EJ motor?!
    Zax's utterly unimaginably stock 2015 STi build thread
    Zax's Shaggin' Wagon Build Thread Now tuned for 99% pure Unicorn Jizz!

    Zach | Moderator -- Mid-Atlantic States, Tech & Modifying & General Repairs
    Rollin' with the Bugeye Mafia #302 | N.E.R.D. Subject Zero
    Facebook me here

    Your Mid-A local board: http://www.clubwrx.net/forums/mid-atlantic-states/

  5. #4
    Registered User
    Join Date
    Feb 2012
    Location
    iowa
    Posts
    24
    its an 08 with 44,000 miles and no mods. One extra bit is that the gas mileage has jumped from 26mpg to 28mpg. Wouldn't that indicate something is wrong not just an accidental trip?

  6. #5
    Registered User
    Join Date
    Feb 2012
    Location
    iowa
    Posts
    24
    well I cleared the codes and the check engine light came back on. No ideas?

  7. #6
    Moderator Donkey's Avatar
    Join Date
    Apr 2005
    Location
    Da boonies
    Posts
    6,150
    I Support ClubWRX

    p0420.........again.......

    Well you can search "Subaru P0420" on Google to get more ideas or get ahold of the factory service manual and read the OBDII diagnostic section. On a stock vehicle it is a little harder to diagnose over the interweb.


    Sent from my magic banana
    Resident Adviser @ WTF Tuning, LLC
    2002 FORESTER S
    1998 FORESTER S




  8. #7
    Registered User Jd617x's Avatar
    Join Date
    Feb 2012
    Posts
    29

    p0420.........again.......

    That's emission warranty. I think coverage is 5yrs or 60k. Or federal emission 8yrs or 80k.

  9. #8
    Registered User
    Join Date
    Feb 2012
    Location
    iowa
    Posts
    24
    Quote Originally Posted by Jd617x View Post
    That's emission warranty. I think coverage is 5yrs or 60k. Or federal emission 8yrs or 80k.
    do I call a Subaru dealership to find out about that? I have no documentation for the warranty.

  10. #9
    Registered User
    Join Date
    Feb 2012
    Location
    iowa
    Posts
    24
    I called a Subaru dealer and asked about the warranty. The 8 year 80k mile thing is for catalytic converters only. Could there be some thing causing the o2 sensors to go bad? Don't want to spend $125 again if its just going to fail.

  11. #10
    Registered User
    Join Date
    Feb 2012
    Location
    iowa
    Posts
    24
    figured out the code is only getting tripped at 35 degrees or colder. Any ideas?

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •