Air conditioning problem!
Results 1 to 3 of 3

This is a discussion on Air conditioning problem! within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; I own a 04' WRX and my A/C just doesn't blow cold... Anyone else have this problem or does anyone ...

  1. #1
    Registered User
    Join Date
    Oct 2012
    Location
    Vancouver BC, Area.
    Posts
    6

    Air conditioning problem!

    I own a 04' WRX and my A/C just doesn't blow cold... Anyone else have this problem or does anyone know the solution to this?

    Thanks
    Rippel

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User jd92677's Avatar
    Join Date
    Jul 2010
    Location
    Cincinnati
    Posts
    2,136
    Not to be an a-hole but lots of people have a/c issues. The solution is to figure out what isn't working and fix it. There are so many things that could cause the a/c to blow warm,it would be silly to guess. If you don't own or have access to gauges and evac equipment, I would take it to a garage and have them diagnose it.
    Stink eye mob #727
    2011 WRX DGM Hatch, Protuned Stage 1

  4. #3
    Registered User jeremydingeman's Avatar
    Join Date
    Mar 2012
    Location
    Bothell, WA
    Posts
    234
    The high pressure AC line is quite common to go bad. More than likely you have a leak somewhere in the system and you are losing refrigerant. Also not to be an a-hole but with a question that vague you are probably better off listening to jd92677 and taking it to your local shop. Sorry.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •