turbo going laggy?
Results 1 to 6 of 6

This is a discussion on turbo going laggy? within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; i have a 2002 wagon wrx ive noticed its very sluggish or very laggy when i drive for the first ...

  1. #1
    Registered User
    Join Date
    Sep 2012
    Posts
    4

    turbo going laggy?

    i have a 2002 wagon wrx ive noticed its very sluggish or very laggy when i drive for the first 10 mmins even if i warm it up before driving then 10mins later going awsome is that normal ?

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User
    Join Date
    Sep 2012
    Posts
    4
    also my mods are mrt exaust and kn panel filter thats all

  4. #3
    Admiral Ackbar the 1st mycologist's Avatar
    Join Date
    Oct 2005
    Location
    Late Devonian
    Posts
    13,150
    I Support ClubWRX
    Sounds weird to me. I don't know what might cause that though.
    "From a little spark may burst a mighty flame." - Dante
    "The stitch is lost unless the thread is knotted." - Italian proverb

  5. #4
    OMG WTF MainFrame's Avatar
    Join Date
    Sep 2002
    Location
    Texas, United States
    Posts
    8,186
    I Support ClubWRX I Support ClubWRX
    Do you have any way of logging your IAM? It almost sounds like your ECU is resetting every time you turn the car off and it takes a little while for the IAM to climb back up..


    Is the car stock? Any kind of engine management?

  6. #5
    Registered User
    Join Date
    Sep 2012
    Posts
    4
    Quote Originally Posted by MainFrame View Post
    Do you have any way of logging your IAM? It almost sounds like your ECU is resetting every time you turn the car off and it takes a little while for the IAM to climb back up..


    Is the car stock? Any kind of engine management?
    yeah stock computer exuast from turbo back kn panel filter

  7. #6
    and the Funky Bunch Calvinball's Avatar
    Join Date
    Jan 2012
    Location
    Philly Area
    Posts
    5,975
    Quote Originally Posted by rangott View Post
    yeah stock computer exuast from turbo back kn panel filter
    Edit: Just saw that earlier post that you have aftermarket exhaust.

    Your writing style is a bit confusing to me.
    Last edited by Calvinball; 10-13-2012 at 04:54 AM.
    - Will
    First Mods: What to do and what not to do
    Current Car: 2014 Golf TDI
    Previous Cars:2012 WRB WRX Hatch, 2004 RSX-S, 1998 Grand Prix GTP
    "Isn't it amazing how smart you feel when you just aren't being stupid?"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •