Weird idle is back :( PLEASE HELP
+ Reply to Thread
Results 1 to 7 of 7

This is a discussion on Weird idle is back :( PLEASE HELP within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; So im lost on this one. Been having an issue during idle car drops from 750rpm to under 500 and ...

  1. #1
    Registered User
    Join Date
    Sep 2011
    Posts
    4

    Weird idle is back :( PLEASE HELP

    So im lost on this one. Been having an issue during idle car drops from 750rpm to under 500 and lights dim. Also while starting to move in first the car seems to skip slightly as if I just learned to drive stick.The sputter seems to happen from start to about 2500rpms
    Thought it was the iac so I cleaned it, no change.
    Then my front o2 died giving me the cel p0031. Car ran pig rich but my idle was perfect and she no longer seemed to sputter in first.
    Got my denso sensor in today and cleared the cel, but now the idle issue and sputter are back and most noticeable then ever.

    Im lost and dont even know where to begin to look
    Any ideas?
    Last edited by Prozak; 06-29-2012 at 10:11 AM.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    ClubWRX.net Vendor adam@kronosperformance's Avatar
    Join Date
    Nov 2005
    Location
    Princeton, NJ
    Posts
    3,988
    I Support ClubWRX
    What year and model car do you have? What are your modifications?
    ClubWRX.net's #1 Vendor! www.kronosperformance.com sales@kronosperformance.com Call/Text 732-742-8837 We Offer a Military Discount
    Our Facebook | Our Twitter | Our Instagram | Our Pinterest
    Our featured brands
    RALLY ARMOR | BC RACING | PERRIN | MISHIMOTO | GRIMMSPEED

  4. #3
    Registered User
    Join Date
    Sep 2011
    Posts
    4
    2002 Wrx sedan 165k
    full exhaust
    perrin bellmouth dp
    catless uppipe
    headers
    Shortram intake
    Walbro 255 fuel pump

    New fuel filter
    New Step colder ngk plugs
    New o2 Sensor

    Aem wideband
    Boost gauge
    tein basics

    Tuned by Brentuning
    17 psi from td04

    This is the most annoying problem because i dont know where to start or how to go about tracing the problem to its source

  5. #4
    Registered User
    Join Date
    Sep 2011
    Posts
    4
    anyone?

  6. #5
    Moderator Donkey's Avatar
    Join Date
    Apr 2005
    Location
    Da boonies
    Posts
    6,301
    I Support ClubWRX
    Check for a vacuum leak and clean the MAF. Without a datalog or some kind of diagnostic info there isn't much to go on.
    Resident Adviser @ WTF Tuning, LLC
    2002 FORESTER S
    1998 FORESTER S




  7. #6
    Registered User teflon_jones's Avatar
    Join Date
    Apr 2007
    Location
    8000' up in Colorado
    Posts
    6,753
    +1 ^^^ what he said
    Scott
    Past Subies - '11 STI Limited stage 1+ and '04 STi stage 2+
    '13 Wrangler Rubicon - custom front bumper w/12k lb winch & off-road lights, skid plates, diff guards, etc.
    '04 Porsche 911 Turbo GT2 clone 600 HP/TQ
    '77 F-150 heavily modded for off-roading

  8. #7
    Registered User
    Join Date
    Sep 2011
    Posts
    4

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •