.5 bar 7psi ? What is wrong
Results 1 to 11 of 11

This is a discussion on .5 bar 7psi ? What is wrong within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; So u have a stock 2002 wrx wagon just installed a oe boost guage and I'm only showing .5 bar ...

  1. #1
    Registered User Deciphe's Avatar
    Join Date
    Apr 2012
    Posts
    80

    .5 bar 7psi ? What is wrong

    So u have a stock 2002 wrx wagon just installed a oe boost guage and I'm only showing .5 bar I thought the stock was around 13? Any ideas on what to check I have no cels and it runs fine. Thanks for any help

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Good news, everyone! xxxxxxxAnub1s's Avatar
    Join Date
    Jan 2005
    Location
    Eh, whaaaaa?
    Posts
    3,855
    I Support ClubWRX
    The OE gauge reads in MPa, not bar. If you're reading .05 MPa, then you're getting 7.25 psi, which yes is a problem. You should be just under .1 MPa on that gauge at stock.

    To verify what the car is reading, you need to do some datalogging. The results you're seeing could be a result of a botched install, and I'm betting on it being just that.
    Cody
    Hawk-Eye Alliance #727 N.E.R.D #255.255.255.0

    Your nighttime volunteer of near-useless information.
    Good news, everyone!

  4. #3
    Registered User UEDan's Avatar
    Join Date
    Oct 2011
    Location
    Santa Ana, CA
    Posts
    1,129
    ^do that plus check the restrictor pill assembly.
    Does the car pull as it should?

    Sent from my DROID2 Global using Tapatalk 2

  5. #4
    Registered User Deciphe's Avatar
    Join Date
    Apr 2012
    Posts
    80
    My install cannot be to botched as I'm not a stranger auto/ mech world I have it installed exactly as instructions and tapped into tech bov line. There isn't really anything I can botch and it reads 0 Ofd and -.5 at idle all correct except the boost is low

  6. #5
    Registered User Deciphe's Avatar
    Join Date
    Apr 2012
    Posts
    80
    I am not sure if it pulls as it should I hadn't driven another this is my first wrx

  7. #6
    Registered User UEDan's Avatar
    Join Date
    Oct 2011
    Location
    Santa Ana, CA
    Posts
    1,129
    On a stock wrx 2 liter. Get started in first, clutch fully engage wot up to 6.5k you should feel your head getting pinned to the seat a bit. thats without boost. Then shift to second, wot up to 6.5k should produce some boost, certainly more than .5. Again, head still getting pinned feeling.
    Don't do that too much until you're sure nothings wrong.
    A bad pill restrictor assembly is a common cause for this problem. And it won't pull if that's the cause.

    Sorry for being wordy.dragged to the mall and I'm bored. And i had the same problem. auto zone didn't have the right size hose. OEM assembly was the only fix

    Sent from my DROID2 Global using Tapatalk 2

  8. #7
    OMG WTF MainFrame's Avatar
    Join Date
    Sep 2002
    Location
    Texas, United States
    Posts
    8,283
    I Support ClubWRX I Support ClubWRX
    For a stock car 7psi boost sounds about right for 1st gear.. how are you doing your pulls?

  9. #8
    Registered User Deciphe's Avatar
    Join Date
    Apr 2012
    Posts
    80
    Any gear wot max 7 have found that I think my bcs is not working

  10. #9
    OMG WTF MainFrame's Avatar
    Join Date
    Sep 2002
    Location
    Texas, United States
    Posts
    8,283
    I Support ClubWRX I Support ClubWRX
    That'll do it every time. Just so you know, anything other than the OEM BCS will require a retune.

  11. #10
    Registered User Deciphe's Avatar
    Join Date
    Apr 2012
    Posts
    80
    Ya I've tried the green connector test mode and of everything that clicks or runs the bcs does nothing. I may have one coming from a 07

  12. #11
    Registered User Deciphe's Avatar
    Join Date
    Apr 2012
    Posts
    80
    Anyone have a bcs many after upgrade?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •