Slight ticking noise after oil change. Should I be worried?
Page 1 of 2 12 LastLast
Results 1 to 15 of 16

This is a discussion on Slight ticking noise after oil change. Should I be worried? within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; I just picked up this WRX a month ago it's a 2005 with 128xxx on it. It's a one (female) ...

  1. #1
    Registered User
    Join Date
    May 2012
    Location
    Bat country, Nevada
    Posts
    13

    Slight ticking noise after oil change. Should I be worried?

    I just picked up this WRX a month ago it's a 2005 with 128xxx on it. It's a one (female) owner car that was Maintained well. It still runs great and pulls hard but after the oil change I got Thursday it seems like the motor is making a ticking noise that is present warm, cold, at idle and through the RPM band. Beings that I just bout the car I'm super paranoid about it... Does it sound ok to y'all? Oil was castrol GTX high mileage 5w-30.

    2005 WRX idle. Sound ok? - YouTube


    Sent from my iPhone

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    KHP
    KHP is offline
    Registered User KHP's Avatar
    Join Date
    Oct 2010
    Location
    Reno, NV
    Posts
    752
    Sounds normal to me...
    2011 WRX Limited Spark Silver (5 Door)

  4. #3
    Registered User Ryouko's Avatar
    Join Date
    Mar 2012
    Location
    South Jersey
    Posts
    85
    If you are trying to troubleshoot it, one thing I would try is blipping the throttle a little bit. At about the 12s mark in that video, you are aiming the camera at the two cables that connect to the throttle body. They are just in front of the passenger side edge of your intercooler. It may make the sound louder and easier to find the source of.

  5. #4
    Registered User Jables_WRX_Junki's Avatar
    Join Date
    Jun 2012
    Location
    PDX,Oregon
    Posts
    101
    do you kno if the previous owner used synthetic or not?

  6. #5
    Registered User
    Join Date
    May 2012
    Location
    Bat country, Nevada
    Posts
    13
    Not sure, they used a pennsoil 5w-30 is all I know.

  7. #6
    He simply abides. SD_GR's Avatar
    Join Date
    Jul 2002
    Location
    CA, US
    Posts
    22,556
    I Support ClubWRX
    Viscosity correct; noise IMO unlikely caused by oil itself.
    WRX Info Links, Courtesy TheJ
    The world breaks everyone and afterward many are strong in the broken places. Ernest Hemingway
    I lied. I cheated. I bribed men to cover the crimes of other men. I am an accessory to murder. But the most damning thing of all... I think I can live with it. And if I had to do it all over again - I would. Benjamin Sisko
    DISCLAIMER: Opinions expressed are the author's alone and are inherently worthless.

  8. #7
    Registered User Jables_WRX_Junki's Avatar
    Join Date
    Jun 2012
    Location
    PDX,Oregon
    Posts
    101
    if the previous owner ran synthetic. you will have to as well.

  9. #8
    He simply abides. SD_GR's Avatar
    Join Date
    Jul 2002
    Location
    CA, US
    Posts
    22,556
    I Support ClubWRX
    I don't see why, sorry? Also, what is a synthetic under that reasoning? Are hydro cracked bases also synths? I don't follow the logic.
    WRX Info Links, Courtesy TheJ
    The world breaks everyone and afterward many are strong in the broken places. Ernest Hemingway
    I lied. I cheated. I bribed men to cover the crimes of other men. I am an accessory to murder. But the most damning thing of all... I think I can live with it. And if I had to do it all over again - I would. Benjamin Sisko
    DISCLAIMER: Opinions expressed are the author's alone and are inherently worthless.

  10. #9
    Registered User Jables_WRX_Junki's Avatar
    Join Date
    Jun 2012
    Location
    PDX,Oregon
    Posts
    101
    Well what i was told by the mechanic at the japanese specialist shop that if its been ran on synthentic then you dont want to switch to a thicker base. I had used just some regular 5w-30 when i first got my sub:e and it ran hard could make some akward smells. drained my oil, refilled with synthetic, shes running perfectly. That and i used a bottle of 104 high octane boost fuel injecter cleaner

  11. #10
    Registered User
    Join Date
    May 2012
    Location
    Bat country, Nevada
    Posts
    13
    Sounds like I need to go synthetic then. Because when I get on it to pass someone it sometimes get a werid smell with it.

  12. #11
    He simply abides. SD_GR's Avatar
    Join Date
    Jul 2002
    Location
    CA, US
    Posts
    22,556
    I Support ClubWRX
    With all respect I see absolutely zero logic in any of this, sorry.
    WRX Info Links, Courtesy TheJ
    The world breaks everyone and afterward many are strong in the broken places. Ernest Hemingway
    I lied. I cheated. I bribed men to cover the crimes of other men. I am an accessory to murder. But the most damning thing of all... I think I can live with it. And if I had to do it all over again - I would. Benjamin Sisko
    DISCLAIMER: Opinions expressed are the author's alone and are inherently worthless.

  13. #12
    Registered User kornkid21792's Avatar
    Join Date
    Jul 2011
    Location
    billings mt
    Posts
    285

    \

  14. #13
    Registered User Ruh Roh's Avatar
    Join Date
    Dec 2011
    Location
    Pottstown PA
    Posts
    3,247
    i belive thats a myth,you can switch in between syn and conventional. if you use high mileage that swells your seals so id never use high mileage oil in mine. but ive switched types in my cars before. some people even make their own blend of 5050 oils

  15. #14
    doa
    doa is offline
    Registered User
    Join Date
    Sep 2011
    Posts
    36
    This is absolutely normal, go listen to any video anywhere of any subaru even the newer ones and they sound just like that.(newer models are a bit quieter) Mine is even louder than that. Anyone who disagrees has obviously never opened their hood while the engine was running.

  16. #15
    Registered User Jables_WRX_Junki's Avatar
    Join Date
    Jun 2012
    Location
    PDX,Oregon
    Posts
    101
    lol i didnt say any of you guys were wrong or that i was right. All i stated was what i was told from an experienced and respected mechanic.........people get ****y on these sites lol

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •