Need Help!!!! Strange noise from 2012 WRX Hatch
+ Reply to Thread
Results 1 to 10 of 10

This is a discussion on Need Help!!!! Strange noise from 2012 WRX Hatch within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Hey Guy's I finally got my 2012 WRX I have about 800 km's on it now. I have been breaking ...

  1. #1
    Registered User
    Join Date
    Apr 2012
    Location
    Canada
    Posts
    22

    Need Help!!!! Strange noise from 2012 WRX Hatch

    Hey Guy's

    I finally got my 2012 WRX I have about 800 km's on it now. I have been breaking in the car not taking it over 4000RPM. Just recently i noticed when I go a little harder on the throttle and the boost kicks in I get a really loud noise which seem's to be coming from the sunroof. It's really strange because when I open my window's the sound sound's like it coming from the engine area. The sound is almost like a sucking wind noise ( if that makes sense ). The sound was not there when I got the car, it just started around 600 km's. It might just be in my head but the car doesn't seem to pull as hard as it did the first couple of week's. Any idea's? Does this sound like a normal WRX sound. Thanks for any advice and help.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User AmateurX's Avatar
    Join Date
    Jul 2009
    Location
    Troy, Michigan
    Posts
    745
    Like this?

    hissing noise
    2011 WRX Limited, DGM; full tint, SPT CBE/STS w/ bushings, RA flaps, Enkei PF01s, Pink SuperTones, and ClubWRX.net stickers!
    My Photostream
    about.me

  4. #3
    Registered User
    Join Date
    Apr 2012
    Location
    Canada
    Posts
    22
    Sound's similar, I made an appointment but it's not till June 2nd. If anyone has any idea;s what it might be, just so I can tell the dealer to check it out, thanks,

  5. #4
    Registered User Jonny1106's Avatar
    Join Date
    May 2012
    Location
    Albuquerque, New Mexico
    Posts
    263
    Inspect all intake hoses for being loose, and tighten them all up. Thats what I would do first

  6. #5
    Registered User
    Join Date
    Apr 2012
    Location
    Canada
    Posts
    22
    Can't find any loose hoses, although I have no idea what I'm looking for....lol

  7. #6
    Registered User Jonny1106's Avatar
    Join Date
    May 2012
    Location
    Albuquerque, New Mexico
    Posts
    263
    Just look for intake hoses and just tighten the hise clamps. I dont have my wrx yet and not really sure what it looks like under the hood. That prob should fix the noise

  8. #7
    Registered User
    Join Date
    Apr 2012
    Location
    Canada
    Posts
    22
    I have tried to look for loose connection's but I didn't see anything. My car is going to Subaru on thursday May 31st to see what is going on. In the mean time my Cobb short shifter, front and rear bushing's and my Rally Armour Mud Flaps are going to be installed this week. I am really contemplating going stage 1 with Access Port. I talked to my dealership and it sound's like I could get away with it as long as I flash it back to stock when I bring it in for warranty work. He said that the service department would flag my car if I brought it in modified and then would deny claim's. I am really torn if I should flash it to stage 1 or not, any thought's? I have the Mod bug really bad and would like to go stage 2 very shortly with invidia TBE. Anyway's will keep you guy's updated. Thanks for your help.
    Last edited by Katchman; 05-26-2012 at 07:15 AM.

  9. #8
    Registered User
    Join Date
    Apr 2012
    Location
    Canada
    Posts
    22
    Just a quick Update, I took my car in today and they told me I had a exhaust leak from my turbo to my down pipe. So they changed out the gasket but there was still a bit of the same noise. They called me back a couple of hours later and told me that my turbo need's to be replaced. Crazy to think I only have 1500kn's on the car, I haven't driven it over 4000RPM's and already I have a exhaust leak and my turbo has to replaced. Oh well hopefully after those are fixed I will be good to go for a long time.

  10. #9
    Registered User AmateurX's Avatar
    Join Date
    Jul 2009
    Location
    Troy, Michigan
    Posts
    745
    Yikes! Sounds like a freak defect. At least you know what the problem is now.
    2011 WRX Limited, DGM; full tint, SPT CBE/STS w/ bushings, RA flaps, Enkei PF01s, Pink SuperTones, and ClubWRX.net stickers!
    My Photostream
    about.me

  11. #10
    Registered User Jonny1106's Avatar
    Join Date
    May 2012
    Location
    Albuquerque, New Mexico
    Posts
    263
    Dang bro hats crazy

    Sent from my Galaxy Nexus using Tapatalk 2
    2012 SWP 5door Premium!!!

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •