POOR WRX PERFORMANCE
Results 1 to 6 of 6

This is a discussion on POOR WRX PERFORMANCE within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Hello Everyone, Actually i have a stock 02 WRX and the problem is all about "no pulling power" from the ...

  1. #1
    Registered User
    Join Date
    Jun 2009
    Posts
    4

    Exclamation POOR WRX PERFORMANCE

    Hello Everyone,

    Actually i have a stock 02 WRX and the problem is all about "no pulling power" from the turbo. The readings on the boost gauge displays as it should be i.e. 1.0-1.2 bar but still as if driving a non-turbo car. Also, the sound on the BOV has been really low from the time there was no power still with boost being displayed at its highest. While running, the revs are slow to reach at every gears while exhaust very loud.

    Besides, the car runs perfect on normal. Turbo and Boost leaks and all of that has already been verified and they are fine. Clutch, flywheels, timing belt changed around 40000kms and its now around 75000kms. No other modifications has been made while the O2 front sensor and right hand side rocker cover gaskets have recently been replaced and again no other leaks has been noticed.

    I really cannot figure out if its a problem of clutch or turbo itself. Please provide any advise. Thank you

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Moderator Donkey's Avatar
    Join Date
    Apr 2005
    Location
    Da boonies
    Posts
    5,994
    I Support ClubWRX
    If it's stock then maybe you have a catalytic convertor going back causing high exhaust back pressure.
    Resident Adviser @ WTF Tuning, LLC
    2002 FORESTER S
    1998 FORESTER S




  4. #3
    Registered User teflon_jones's Avatar
    Join Date
    Apr 2007
    Location
    8000' up in Colorado
    Posts
    6,753
    How long ago did this start happening? Did it go from good boost to nothing overnight, or has it been a gradual change?
    Scott
    Past Subies - '11 STI Limited stage 1+ and '04 STi stage 2+
    '13 Wrangler Rubicon - custom front bumper w/12k lb winch & off-road lights, skid plates, diff guards, etc.
    '04 Porsche 911 Turbo GT2 clone 600 HP/TQ
    '77 F-150 heavily modded for off-roading

  5. #4
    Registered User
    Join Date
    Jun 2009
    Posts
    4
    Quote Originally Posted by Donkey View Post
    If it's stock then maybe you have a catalytic convertor going back causing high exhaust back pressure.
    can you please let me know more about what should be done to verify the prob you mentioned because even now the sound seems to have increase.

  6. #5
    Registered User
    Join Date
    Jun 2009
    Posts
    4
    Quote Originally Posted by teflon_jones View Post
    How long ago did this start happening? Did it go from good boost to nothing overnight, or has it been a gradual change?
    i've been running the car normally for a period of time but did not notice anything and still after changing the 02 sensors and rocker cover gaskets, i ran the car normally. Only after, i tried to run into full boost and noticed that there is no presence of turbo pull. The readings on the gauge stil indicates as if the boost are correct.

  7. #6
    Registered User UEDan's Avatar
    Join Date
    Oct 2011
    Location
    Santa Ana, CA
    Posts
    1,072
    Quote Originally Posted by y_wrx View Post
    can you please let me know more about what should be done to verify the prob you mentioned because even now the sound seems to have increase.
    When my uppipe got clogged the dealership checked the tempurature on the uppipe, turbo and downpipe. Probably with one of those noncontact temp guns, since they gave me exact temps.

    Uppipe and turbo were extremely hot(oil sheeering hot), the temp just dropped after the turbo, indicating bad exhaust flow.

    Sent from my DROID2 GLOBAL using Tapatalk 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •