Idle surge
Results 1 to 10 of 10

This is a discussion on Idle surge within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Hi guys, Just bought an 2006 impreza 2.0l 4wd. Just a small problem thats started. Once the car is hot ...

  1. #1
    Registered User
    Join Date
    Jun 2009
    Posts
    11

    Idle surge

    Hi guys,

    Just bought an 2006 impreza 2.0l 4wd.

    Just a small problem thats started. Once the car is hot the idle tends to surge up and down. Only seems to happen once warm.
    50,000km on it.
    No CEL and no fault codes showing.

    Any ideas most appreciated
    Cheers

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    ClubWRX.net Vendor adam@kronosperformance's Avatar
    Join Date
    Nov 2005
    Location
    Princeton, NJ
    Posts
    3,983
    I Support ClubWRX
    Just to clarify....are you sure you have a 2006? 2006s dont have 2.0 motors
    ClubWRX.net's #1 Vendor! www.kronosperformance.com sales@kronosperformance.com Call/Text 732-742-8837 We Offer a Military Discount
    Our Facebook | Our Twitter | Our Instagram | Our Pinterest
    Our featured brands
    RALLY ARMOR | BC RACING | PERRIN | MISHIMOTO | GRIMMSPEED

  4. #3
    Registered User MakeItRoar's Avatar
    Join Date
    Aug 2010
    Location
    Chicago, Illinois
    Posts
    321
    More info would be appreciated, a rough idle could be the idle air control valve, bad grounding, a bad MAF, boost vacuum leak, or a slough of other things. Mods? How much does it surge? Like 100-200K or like 500-700K?
    2006 WRX Limited -Pro-tuned VF-39, STI TMIC, STI factory I/C Sprayer, Throttle body Coolant Bypass, STI Exhaust, SPT Short Ram Intake, SPT Upper Front and Rear Strut Bar, Red Samco Radiator Hoses, STI Trunk, SPT Short Shifter, Aftermarket Rotors, Lamco Turbo Gauge, Catless Downpipe, Hella Supertones, RallyArmor Limited Edition Pink UR Flaps, 35% Tint, Grounding Mod, Walbro 255 Fuel Pump, SPT Heat Shield STI Piston Shift Knob!
    Hawk-Eye Alliance #430

  5. #4
    Registered User teflon_jones's Avatar
    Join Date
    Apr 2007
    Location
    8000' up in Colorado
    Posts
    6,753
    Where are you located? How many km's have you driven the car? How many km's after you bought it did this start, and how many km's has it been happening for?

    Have you tried basic stuff like cleaning your MAF, ensuring your air filter is clean, inspecting the hoses, etc?
    Quote Originally Posted by MakeItRoar View Post
    More info would be appreciated, a rough idle could be the idle air control valve, bad grounding, a bad MAF, boost vacuum leak, or a slough of other things. Mods? How much does it surge? Like 100-200K or like 500-700K?
    Wow if the car is surging even 100,000-200,000 RPM I'd be running like hell away from that car, never mind 500,000-700,000 RPM!!!!!!!
    Scott
    Past Subies - '11 STI Limited stage 1+ and '04 STi stage 2+
    '13 Wrangler Rubicon - custom front bumper w/12k lb winch & off-road lights, skid plates, diff guards, etc.
    '04 Porsche 911 Turbo GT2 clone 600 HP/TQ
    '77 F-150 heavily modded for off-roading

  6. #5
    Registered User
    Join Date
    Jun 2009
    Posts
    11
    Quote Originally Posted by teflon_jones View Post
    Where are you located? How many km's have you driven the car? How many km's after you bought it did this start, and how many km's has it been happening for?

    Have you tried basic stuff like cleaning your MAF, ensuring your air filter is clean, inspecting the hoses, etc?
    Wow if the car is surging even 100,000-200,000 RPM I'd be running like hell away from that car, never mind 500,000-700,000 RPM!!!!!!!
    Hi sorry,
    Wasnt too sure how much info you would need.

    Its done 52,000km and probably 2000km since we bought it. The problem has started in the last 300-500km and i havent done anything yet as i thought i would see your thoughts.
    When it surges it probably blips 100-200 rpm and you can see the lights dimming and brightening on the dash as it does it. Hope this helps

    Cheers
    Mark

  7. #6
    Registered User MakeItRoar's Avatar
    Join Date
    Aug 2010
    Location
    Chicago, Illinois
    Posts
    321
    Quote Originally Posted by teflon_jones View Post
    Wow if the car is surging even 100,000-200,000 RPM I'd be running like hell away from that car, never mind 500,000-700,000 RPM!!!!!!!
    Haha wow, didn't even realize I added K's...
    2006 WRX Limited -Pro-tuned VF-39, STI TMIC, STI factory I/C Sprayer, Throttle body Coolant Bypass, STI Exhaust, SPT Short Ram Intake, SPT Upper Front and Rear Strut Bar, Red Samco Radiator Hoses, STI Trunk, SPT Short Shifter, Aftermarket Rotors, Lamco Turbo Gauge, Catless Downpipe, Hella Supertones, RallyArmor Limited Edition Pink UR Flaps, 35% Tint, Grounding Mod, Walbro 255 Fuel Pump, SPT Heat Shield STI Piston Shift Knob!
    Hawk-Eye Alliance #430

  8. #7
    Registered User
    Join Date
    May 2010
    Posts
    24
    I'm not an expert by any means with these cars, but I posted almost the exact same problem a few days ago. A couple of the guys on here told me it was probably my spark plugs. I changed them, problem went away. NOW, I have more miles on my car, (74k) so it WAS due for plugs, where yours is close to the window to change them but not quite there yet. However, it might be worth the few bucks and 2-3 hours of labor to just do them and see. If nothing else, your tune-up is done early! Hope this helps!

  9. #8
    Registered User
    Join Date
    May 2010
    Posts
    24
    P.S. mine WAS ALSO only when warm and would jump around 100-200 rpm.

  10. #9
    Admiral Ackbar the 1st mycologist's Avatar
    Join Date
    Oct 2005
    Location
    Late Devonian
    Posts
    13,215
    I Support ClubWRX
    Quote Originally Posted by fl440 View Post
    Hi sorry,
    Wasnt too sure how much info you would need.

    Its done 52,000km and probably 2000km since we bought it. The problem has started in the last 300-500km and i havent done anything yet as i thought i would see your thoughts.
    When it surges it probably blips 100-200 rpm and you can see the lights dimming and brightening on the dash as it does it. Hope this helps

    Cheers
    Mark
    Did you just recently start using AC or defrost?
    "From a little spark may burst a mighty flame." - Dante
    "The stitch is lost unless the thread is knotted." - Italian proverb

  11. #10
    Registered User
    Join Date
    Jun 2009
    Posts
    11
    Quote Originally Posted by mycologist View Post
    Did you just recently start using AC or defrost?
    Nope, no AC use or anthing.

    Seems to run fine to warm up, then turn car off after a Period of driving. Then start it up again say 10-45 mins later and it surges 100-300rpm tops.

    Just had e spark plugs changed and all the throttle body, manifold cleaned.....

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •