97 wrx gremlins....
Results 1 to 2 of 2

This is a discussion on 97 wrx gremlins.... within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Hi, Im posting this on behalf of my brother inlaw, he has a 97 wrx that has started to exhibit ...

  1. #1
    Registered User
    Join Date
    Apr 2012
    Posts
    1

    Cool 97 wrx gremlins....

    Hi,

    Im posting this on behalf of my brother inlaw, he has a 97 wrx that has started to exhibit some very strange symptoms. He has had the car to a subaru mechanic and a 4wd/awd turbo specialist but no one can seem to find the problem, hoping someone here can help.

    The issues started when the head gaskets and steering rack were replaced. Then the turbo fried itself, (impeller shaft and bearings) and he took it back to the subaru guy who replaced the turbo, put it all back together. Now, the car was stalling so the air sensor was found to be faulty and replaced. Then boost pressure was too high, so the car went to a turbo specialist who fixed that however the car now made a grinding sound and still stalled at random. Went to another specialist who found a hole in the dump pipe. The whole exhaust was removed and inspected, dump pipe replaced and again, car put back together. The problem was still present so all electrical sensors were inspected with one or two replaced however no change to the issues. To rule out mechanical issues inside the engine, the valves, cylinders and heads where inspected and with no issues found.

    Now, im not a subaru guy but am a mechanic with turbo experience (diesel mechanic in road transport) so I offered to see if I can help as the labour costs trying to find this problem have caused him to give up. I drove it this morning and heres what I can noticed. The car makes a loud click sound (which sounds like the accuator rod loose on one end and slipping into position) followed by a grinding noise under full boost, and stalls at random between 1/2 -> full throttle. I could only get it to make the click/grind once or twice, the rest of the time the turbo whistle sounds a little sick or lower pitched then it should but there is no click and no grind. Power is fine and aside from the stalling at random under power, the car seems to run smooth and ok.

    He is at his wits end and if he cant find a solution is planing to have the car crushed and enjoy a bbq on its lifeless corpse.

    Any advice welcome.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User UEDan's Avatar
    Join Date
    Oct 2011
    Location
    Santa Ana, CA
    Posts
    1,095
    I'm not sure if the 97's had a carted uppipe but mine was clogged and caused the turbo to make a clacking noise under boost.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •