Boost help - Vaccuum line/Restrictor pill
Results 1 to 3 of 3

This is a discussion on Boost help - Vaccuum line/Restrictor pill within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Okay I need a little wisdom here please. When i bought my car it had a Boost controller on the ...

  1. #1
    Registered User Killerkanadian's Avatar
    Join Date
    Mar 2012
    Location
    Oklahoma
    Posts
    116

    Boost help - Vaccuum line/Restrictor pill

    Okay I need a little wisdom here please. When i bought my car it had a Boost controller on the car. Causing it to throw codes and over boost. I assumed it was an easy fix, so i took the boost controller off and replaced it with a vacuum line that fit snugly in it's place.

    Well today I got around to using my COBB AP, which I have a stage 2 tune installed. Car has a catless turbo back, and HKS intake. When I installed the tune I figured it was running pretty good. So today I figured I had some time I was gonna take a quick data log. I tried to figure out how exactly to do it, I ran a real time boost guage on the AP. Looks like my boost from 3-7k rpm is in the 7's PSI, with a maximum recorded boost of 9.2 PSI. The car runs and feels pretty dang good otherwise.

    So what I'm thinking is i don't have the right size vacuum line inbetween the turbo and wastegate where the boost controller was, or if it is the right size, i need a restrictor pill.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User Killerkanadian's Avatar
    Join Date
    Mar 2012
    Location
    Oklahoma
    Posts
    116
    Edit: Looks like there's supposed to be a T fitting, that connects to a solenoid? The waste gate selenoid? Guess i need to look around for what's missing a fitting.

    Picture of my make replaced vacuum line (yes it needs a trimming)

    Click image for larger version. 

Name:	vacuumline.jpg 
Views:	21 
Size:	79.4 KB 
ID:	103625

    And this, I just cut out of the vacuum hose that was attached to my boost controller. Is this perhaps the Restrictor?

    Click image for larger version. 

Name:	restirctorpill.jpg 
Views:	21 
Size:	52.4 KB 
ID:	103626

    Edit again: Supposed to look something like this? with the T connected to the turbo pipe and wastegate?

    Click image for larger version. 

Name:	solenoidzp2.jpg 
Views:	21 
Size:	74.4 KB 
ID:	103627
    Last edited by Killerkanadian; 03-31-2012 at 11:30 AM.

  4. #3
    Registered User Killerkanadian's Avatar
    Join Date
    Mar 2012
    Location
    Oklahoma
    Posts
    116
    Fixed my problem. Found the hose it was supposed to T off into. Bought a generic restrictor from autozone. Had it hooked up on the wrong side of the vacuum hose at first so it wasn't working. Did a little more research and put it in the correct spot. About pooped my britches when the car all of a sudden was boosting 16PSI, and almost slammed the car turning infront of me.

    Just glad the car is finally running right
    Last edited by Killerkanadian; 03-31-2012 at 02:14 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •