2010 wrx, 14k miles, had bumper repaired - now sputters and stalls
Page 1 of 2 12 LastLast
Results 1 to 15 of 18

This is a discussion on 2010 wrx, 14k miles, had bumper repaired - now sputters and stalls within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; good morning! i got in a MINOR accident and the body shop has repainted the front bumper (obv took off ...

  1. #1
    Registered User keana's Avatar
    Join Date
    Jun 2011
    Location
    Corning (city), New York, United States
    Posts
    20

    2010 wrx, 14k miles, had bumper repaired - now sputters and stalls

    good morning!
    i got in a MINOR accident and the body shop has repainted the front bumper (obv took off to do this).
    Ran fine home (about 3 miles) then stalled when i parked it.
    This morning it was sputtering, bogging out when i stepped on the gas, idling high then low, just all over the charts.
    I had to keep revving it so it wouldnt stall.
    my question, WHAT THE HECK would cause this?
    All the body shop did was fix the bumper?
    Any suggestions are so so greatly appreciated!
    Thank you!!!
    Keana

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Good news, everyone! xxxxxxxAnub1s's Avatar
    Join Date
    Jan 2005
    Location
    Eh, whaaaaa?
    Posts
    3,855
    I Support ClubWRX
    Did the CEL come on?
    Cody
    Hawk-Eye Alliance #727 N.E.R.D #255.255.255.0

    Your nighttime volunteer of near-useless information.
    Good news, everyone!

  4. #3
    Registered User keana's Avatar
    Join Date
    Jun 2011
    Location
    Corning (city), New York, United States
    Posts
    20
    no it has not.

  5. #4
    Registered User keana's Avatar
    Join Date
    Jun 2011
    Location
    Corning (city), New York, United States
    Posts
    20
    could it be a ground or battery issue? i'm TOTALLY lost on this one!!
    I dont know what they would have messed with to get the bumper off...

  6. #5
    Moderator rage-wrx's Avatar
    Join Date
    Aug 2010
    Location
    Yonkers/NYC
    Posts
    10,793
    I Support ClubWRX
    Do you have any mods?
    T0ny
    2011 WRX
    2012 FXT

    The Big 2011/2012 Mod Thread


    Ooh,hang on. That is the throb of a turbocharged flat four engine. A sound which,all over the world,heralds the imminent arrival of a moron - JC.

  7. #6
    Registered User keana's Avatar
    Join Date
    Jun 2011
    Location
    Corning (city), New York, United States
    Posts
    20
    cobb ap, aem cai, spt exhaust

  8. #7
    Registered User keana's Avatar
    Join Date
    Jun 2011
    Location
    Corning (city), New York, United States
    Posts
    20
    i'm being told to unhook the battery, touch the terminals together, then hook it back up. seem legit??

  9. #8
    Registered User
    Join Date
    Oct 2011
    Posts
    26
    I don't know about touching the terminals together, I've never done that. If you're wanting to reset the ecu, just leave the positive or negative terminal off for a few minutes. why don't you just bring it back to the shop? More than likely they left something unplugged.

  10. #9
    Pro Manscaper Mikie13's Avatar
    Join Date
    Oct 2006
    Location
    Palmyra, NJ
    Posts
    20,779
    Check the MAF? Is that plugged in correctly?

    I would not touch the terminals together, you have a better chance of shorting out any electronics doing that.

    If you want to reset the ECU, disconnect the battery, pump brakes multiple times in succession. This will drain any charge left in the system.

    I also second take it back to the shop if you're that lost...they are the wildcard in the equation.
    The Hawk-Eye Alliance #90|The Blobeye Syndicate #0|The Stink-Eye Mob #0|N.E.R.D. Founding Member & #3
    2012 Lightning Red WRX Sedan Stock...for now Soon to be OpenSource tuned by: Mattypants @ WTF Tuning
    "If I have 10 ice cubes and you have 11 giraffes, how many pancakes can fit on the roof? Purple, because aliens donít wear hats" -Ying

  11. #10
    Captain James of the SS Impreza has gone down with the ship Drews's Avatar
    Join Date
    Aug 2008
    Location
    Davey Jones Locker
    Posts
    8,525
    I Support ClubWRX
    Check your air filter. They may have knocked it off or it could be full of junk if the body shop wasn't too concerned with the quality of their work.
    Hawk-Eye Alliance #Eleventy,000,000,000|N.E.R.D. Member 20,000
    Stable: 2014 Hyundai Veloster Turbo (Matte Grey), 06 LGT, 03 WRX, 98 RS, 00 OBS


    Resident Clubdub Debbie Downer. I'd love your ideas if you kept them to yourself. Subarus suck, get a new wife.

    Never argue with idiots. They'll drag you to their level and beat you with experience.

  12. #11
    Moderator rage-wrx's Avatar
    Join Date
    Aug 2010
    Location
    Yonkers/NYC
    Posts
    10,793
    I Support ClubWRX
    I agree.I could be the filter since the CAI is located right behind the front bumper.

    Sent from my HTC PH39100 using Tapatalk
    T0ny
    2011 WRX
    2012 FXT

    The Big 2011/2012 Mod Thread


    Ooh,hang on. That is the throb of a turbocharged flat four engine. A sound which,all over the world,heralds the imminent arrival of a moron - JC.

  13. #12
    Registered User keana's Avatar
    Join Date
    Jun 2011
    Location
    Corning (city), New York, United States
    Posts
    20
    Thank you so much!
    the MAF was NOT plugged in correctly.
    Thank goodness it was such an easy fix.
    Embarassing driving it home from work with the jerking and stalling, but all is well now! ha
    Thank you again

  14. #13
    Moderator rage-wrx's Avatar
    Join Date
    Aug 2010
    Location
    Yonkers/NYC
    Posts
    10,793
    I Support ClubWRX
    Mikie is glad to be of assistance.
    T0ny
    2011 WRX
    2012 FXT

    The Big 2011/2012 Mod Thread


    Ooh,hang on. That is the throb of a turbocharged flat four engine. A sound which,all over the world,heralds the imminent arrival of a moron - JC.

  15. #14
    Pro Manscaper Mikie13's Avatar
    Join Date
    Oct 2006
    Location
    Palmyra, NJ
    Posts
    20,779
    Quote Originally Posted by rage-wrx View Post
    Mikie is glad to be of assistance.
    ZOMG I got one right!!!!!!!



    The Hawk-Eye Alliance #90|The Blobeye Syndicate #0|The Stink-Eye Mob #0|N.E.R.D. Founding Member & #3
    2012 Lightning Red WRX Sedan Stock...for now Soon to be OpenSource tuned by: Mattypants @ WTF Tuning
    "If I have 10 ice cubes and you have 11 giraffes, how many pancakes can fit on the roof? Purple, because aliens donít wear hats" -Ying

  16. #15
    Registered User keana's Avatar
    Join Date
    Jun 2011
    Location
    Corning (city), New York, United States
    Posts
    20

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •