07 STI pulls hard to the right after a tire change over??? - Page 2
Page 2 of 2 FirstFirst 12
Results 16 to 17 of 17

This is a discussion on 07 STI pulls hard to the right after a tire change over??? within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; I'm going to set all the pressure exactly the same when the tires are cold and I'm going to swap ...

  1. #16
    Registered User Venom351R's Avatar
    Join Date
    Oct 2010
    Location
    Maine
    Posts
    326
    I'm going to set all the pressure exactly the same when the tires are cold and I'm going to swap the front tires to the back. I'll do it on monday I work all weekend and dont have time before work or when I get home.
    2007 WRX STI- Stock 13.8@102

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #17
    Registered User Venom351R's Avatar
    Join Date
    Oct 2010
    Location
    Maine
    Posts
    326
    I set the pressure to 35 in each tire when cold and it seems to have fixed the issue. It eventually pulls but thats due to the roads and the frost coming up. It goes quite a long ways w/out pulling. I do have a slight vibration at 70MPH, If it does it again tomorrow on the way to work then I'll take it back and have the balance checked on the tires.
    2007 WRX STI- Stock 13.8@102

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •