Having bluetooth connection issues with your 2011?
+ Reply to Thread
Results 1 to 11 of 11

This is a discussion on Having bluetooth connection issues with your 2011? within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; My OG Droid used to pair up no questions asked after I turned the head unit on. Not so much ...

  1. #1
    Registered User Heide264's Avatar
    Join Date
    May 2010
    Location
    Pittsburgh, PA
    Posts
    4,231
    I Support ClubWRX

    Having bluetooth connection issues with your 2011?

    My OG Droid used to pair up no questions asked after I turned the head unit on. Not so much with my Galaxy Nexus. After reading around for a while and fighting with it (hitting the connect button 3-4 times to get it to connect... random disconnects.. etc), I found a result from google that suggested pairing it from your steering wheel controls as opposed to the head unit.

    ..I'll be darned if it didn't work. Had to go through the voice prompts by first clearing out my phone from memory and then hitting the phone off the hook button etc... But darn, it syncs right up now once the head unit is on.

    Whatever. Not going to ask questions. Just wanted to post up here in case other people were having this frustrating issue.
    Quote Originally Posted by Trainrex
    He was throwing balloons filled with sulfuric acid and shrapnel at the swat team. They finally had to take him down with rubber bullets.
    2011 STi Build Log
    -Part 1 - Reading, Data Logging, and Analyzing Data
    -Part 2 - Turbocharger 101 & Basic Boost Control
    -Part 3 - EcuFlash, Experimental Defintions, and a Drive By Wire Intro

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User SamXp's Avatar
    Join Date
    Nov 2010
    Location
    Winston-Salem, NC
    Posts
    463
    I need to try this! I pair using the head unit menu and constantly have to hit the connect button in my hTC Rezound 3-4 times to get it to connect. My old phone (hTC EVO 4G) was connected through the steering wheel / voice prompts and it connected each time automatically. I thought it was the phone, but I'm hoping you're right!

  4. #3
    Registered User SamXp's Avatar
    Join Date
    Nov 2010
    Location
    Winston-Salem, NC
    Posts
    463
    Just tried this and it works!! Man, that was SO annoying, with the connection issues. Now it connects right away, no problem. I was even able to find and delete several other phones that were paired, that I couldn't find through the head unit menus.

    Thanks!!!

  5. #4
    Registered User Heide264's Avatar
    Join Date
    May 2010
    Location
    Pittsburgh, PA
    Posts
    4,231
    I Support ClubWRX
    Quote Originally Posted by SamXp View Post
    Just tried this and it works!! Man, that was SO annoying, with the connection issues. Now it connects right away, no problem. I was even able to find and delete several other phones that were paired, that I couldn't find through the head unit menus.

    Thanks!!!
    No problem. Was annoying the living snot out of me. I have no idea why it works - seems like it pairs it as a phone instead of music or something. *Shrug*

    Glad somebody else out there was having the same issue. Enjoy.
    Quote Originally Posted by Trainrex
    He was throwing balloons filled with sulfuric acid and shrapnel at the swat team. They finally had to take him down with rubber bullets.
    2011 STi Build Log
    -Part 1 - Reading, Data Logging, and Analyzing Data
    -Part 2 - Turbocharger 101 & Basic Boost Control
    -Part 3 - EcuFlash, Experimental Defintions, and a Drive By Wire Intro

  6. #5
    U.S. Combat Veteran (3ID) Stu_Gotti's Avatar
    Join Date
    Jan 2011
    Location
    Southern Maryland
    Posts
    921
    I Support ClubWRX
    I've always used my SWC so I imagine that's why I never had issues :] Well except this one time I had a kernel that didn't support the pairing, but that's a different scenario lol.
    My Build | Facebook | I may appear calm, but in my head I've killed you three times

  7. #6
    Registered User 03WRX's Avatar
    Join Date
    Nov 2002
    Location
    Dallas, TX
    Posts
    320
    I did a search and found this thread! Thank you so much! I was having the exact same problem of it not auto-connecting whenever I would get into my car. That is weird how going through the SW controls would fix that.
    2012 Black WRX Premium
    2003 wrb WRX - Cobb Stage 2

  8. #7
    Registered User Axex's Avatar
    Join Date
    Aug 2011
    Location
    North Cackalaky
    Posts
    280
    Thanks for bumping this! Somehow I missed this one even though I have this issue and I swear I searched for it

  9. #8
    Registered User 03WRX's Avatar
    Join Date
    Nov 2002
    Location
    Dallas, TX
    Posts
    320
    Glad it helped you! This thread should be a sticky.
    2012 Black WRX Premium
    2003 wrb WRX - Cobb Stage 2

  10. #9
    Moderator rage-wrx's Avatar
    Join Date
    Aug 2010
    Location
    Yonkers/NYC
    Posts
    10,820
    I Support ClubWRX
    Bumping an old thread with an issue I'm having. This may be unique.

    We got a 2012 Forester with an almost identical HU as my 2011 WRX. Setup is the same for both HUs.

    I recently paired my HTC with the Foresters's HU BT. Had no issues. Works perfectly.

    I go back to the WRX. I turn the HU on( the phone is already paired with this HU). It shows BT "not connected". Although it is showing me the phone info on the HU screen ( with battery life info etc). I can make calls using BT( although it says not connected). But for the life of me I cannot get it to play music over BT. I tried unpairing & pairing again multiple times. Still it is a no go.

    Any ideas on what to do ?
    T0ny
    2011 WRX
    2012 FXT

    The Big 2011/2012 Mod Thread


    Ooh,hang on. That is the throb of a turbocharged flat four engine. A sound which,all over the world,heralds the imminent arrival of a moron - JC.

  11. #10
    Registered User
    Join Date
    Apr 2014
    Posts
    11
    im having the same issue with my Galaxy S4. Im going to try this right now using the steering wheel controls. I'll be damned if this works.

  12. #11
    Registered User
    Join Date
    Feb 2014
    Location
    PNW -WA STATE - rainy side
    Posts
    412
    I Support ClubWRX
    My 2014 came with a skinny extra manual that says to do it that way. I just changed from a HTC POS to Galaxy Note 3 and it paired up instantly.

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •