Cruise Control doesn't set anymore
+ Reply to Thread
Results 1 to 11 of 11

This is a discussion on Cruise Control doesn't set anymore within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; My cruise control in my 2004 suddenly stopped working the other day. The cruise light comes on still, but when ...

  1. #1
    Registered User subiesayshi's Avatar
    Join Date
    Feb 2012
    Location
    Central New York
    Posts
    19

    Cruise Control doesn't set anymore

    My cruise control in my 2004 suddenly stopped working the other day. The cruise light comes on still, but when I click to set it, it doesn't work. I've tried pulling the brake pedal out in case it stuck, but it still doesn't work. My question is, is this something I could fix or how much do you think a dealer or shop would charge to get it fixed? Any info would be helpful really.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User
    Join Date
    Jul 2011
    Location
    CT/OH
    Posts
    24
    There is a switch that is activated by the clutch pedal, you should see it about 2/3 of the way up the pedal. There will be a hole that is supposed to have a rubber bumper in it, if you see just an empty hole about 3/8" of an inch, that means the bumper fell out and the switch will not close. This makes the cruise control system think that the clutch pedal is engaged (Pressed in) and will not activate cruise control. What I did was get a screw with a very flat head that was the diameter of the hole, and put a nut on the back to hold it in place.

  4. #3
    He simply abides. SD_GR's Avatar
    Join Date
    Jul 2002
    Location
    CA, US
    Posts
    22,965
    I Support ClubWRX
    Same here; I used a plastic grommet from a home supply store. No problems since.
    WRX Info Links, Courtesy TheJ
    Man is a brute.... If you're cruel to him, he respects and fears you. If you're kind to him, he plucks your eyes out. Alexis Zorbas
    I lied. I cheated. I bribed men to cover the crimes of other men. I am an accessory to murder. But the most damning thing of all... I think I can live with it. And if I had to do it all over again - I would. Benjamin Sisko
    DISCLAIMER: Opinions expressed are the author's alone and are inherently worthless.

  5. #4
    Registered User subiesayshi's Avatar
    Join Date
    Feb 2012
    Location
    Central New York
    Posts
    19
    Hmm, thanks for the info. I'll check it out tomorrow.

  6. #5
    Registered User subiesayshi's Avatar
    Join Date
    Feb 2012
    Location
    Central New York
    Posts
    19
    So I checked the rubber bumper out, it's still in place where it's supposed to be. Perhaps the problem is more internal?

  7. #6
    He simply abides. SD_GR's Avatar
    Join Date
    Jul 2002
    Location
    CA, US
    Posts
    22,965
    I Support ClubWRX
    If you do not see a white piece of plastic on the pedal but do see a hole, that's the problem.

    If you have a CEL, that's the problem.

    Otherwise it gets complicated. Either of those two going on?
    WRX Info Links, Courtesy TheJ
    Man is a brute.... If you're cruel to him, he respects and fears you. If you're kind to him, he plucks your eyes out. Alexis Zorbas
    I lied. I cheated. I bribed men to cover the crimes of other men. I am an accessory to murder. But the most damning thing of all... I think I can live with it. And if I had to do it all over again - I would. Benjamin Sisko
    DISCLAIMER: Opinions expressed are the author's alone and are inherently worthless.

  8. #7
    Registered User subiesayshi's Avatar
    Join Date
    Feb 2012
    Location
    Central New York
    Posts
    19
    Everything on or around the pedal is where it's supposed to be. There's no hole anywhere. I have a CEL on, but the code says small leak/loose gas cap, unless more codes have been added by now. I wouldn't think the cruise control would set off a code, but maybe I'm wrong?

  9. #8
    The Default One SeattleJeremy's Avatar
    Join Date
    Jul 2004
    Location
    Seattle, WA
    Posts
    4,488
    When the CEL is turned on the cruise control will not work. Buy a new gas cap, clear the code, and see if that fixes it.

  10. #9
    Registered User subiesayshi's Avatar
    Join Date
    Feb 2012
    Location
    Central New York
    Posts
    19
    The cruise control has always worked when the CEL is on. It was on for a year before the car became mine, and it's been on and off for a while now.

  11. #10
    The Default One SeattleJeremy's Avatar
    Join Date
    Jul 2004
    Location
    Seattle, WA
    Posts
    4,488
    It's defiantly possible you have another CEL code. Have the codes read again and post them here. We'll try to help you fix the problem.

    Fuel filer caps are known to fail from time to time, if that's one of the problems, at least that's an easy fix ($6 on Amazon)

  12. #11
    Registered User subiesayshi's Avatar
    Join Date
    Feb 2012
    Location
    Central New York
    Posts
    19
    So I read the codes again, this time it was a camshaft sensor code. I'll be replacing the sensor soon. Would that affect the cruise control?

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •