Bad Alternator?
Results 1 to 3 of 3

This is a discussion on Bad Alternator? within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Hello everyone. I have a JDM 1995 Impreza STI (95,000 km on the engine), and I have been experiencing a ...

  1. #1
    Registered User AmnJoker333's Avatar
    Join Date
    Feb 2012
    Location
    Misawa AB, Japan
    Posts
    1

    Bad Alternator?

    Hello everyone. I have a JDM 1995 Impreza STI (95,000 km on the engine), and I have been experiencing a little trouble with it lately. The voltage meter next to my boost gauge fluctuates occasionally, causing my headlights to brighten and dim while I am driving, but it doesn't happen all the time. Also there is occasionally a squealing sound when I first start my car, and will occur when I am idling the engine at a stoplight, or driving in the lower RPMs, but will go away at higher RPMs. Would this indicate a bad alternator, or something else? Can an alternator alone cause this squealing? Would the belt cause the voltage fluctuations? Thanks!

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Good news, everyone! xxxxxxxAnub1s's Avatar
    Join Date
    Jan 2005
    Location
    Eh, whaaaaa?
    Posts
    3,855
    I Support ClubWRX
    The belt being loose will cause the squeeling and if it is slipping will cause a drop in alternator output, yes. I'd recommend replacing your drive belts.
    Cody
    Hawk-Eye Alliance #727 N.E.R.D #255.255.255.0

    Your nighttime volunteer of near-useless information.
    Good news, everyone!

  4. #3
    Registered User jgardiner's Avatar
    Join Date
    Oct 2010
    Location
    Calgary, Canada
    Posts
    316
    Also make sure that your battery terminals are clean.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •