Grinding noise coming from 5spd
Results 1 to 8 of 8

This is a discussion on Grinding noise coming from 5spd within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Does anyone else get a grinding noise coming from the transmission while accel. and decel. in gear? It happens loudest ...

  1. #1
    Registered User
    Join Date
    Nov 2011
    Location
    San Antonio/Houston
    Posts
    36

    Grinding noise coming from 5spd

    Does anyone else get a grinding noise coming from the transmission while accel. and decel. in gear? It happens loudest between 2k-3k rpm. I had a recent issue with a corroded seal in the tranny, but the dealership fixed it last week and now i can hear the grinding noise even better. Its an 05 wrx with 88k miles. Any ideas?

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    zax
    zax is offline
    \_(ツ)_/ zax's Avatar
    Join Date
    Nov 2008
    Location
    Neverland Ranch, Maryland
    Posts
    12,571
    I Support ClubWRX I Support ClubWRX
    I wouldn't worry about a noise. My transmission makes a cacophony of noises at all times. Are you able to smoothly shift into all gears? If you're worried, drain the transmission fluid and look for chunks of metal on the magnetic drain plug.
    2015 CWP WRX STi ... But how did I get roped back into an EJ motor?!
    Zax's utterly unimaginably stock 2015 STi build thread
    Zax's Shaggin' Wagon Build Thread Now tuned for 99% pure Unicorn Jizz!

    Zach | Moderator -- Mid-Atlantic States, Tech & Modifying & General Repairs
    Rollin' with the Bugeye Mafia #302 | N.E.R.D. Subject Zero
    Facebook me here

    Your Mid-A local board: http://www.clubwrx.net/forums/mid-atlantic-states/

  4. #3
    Registered User
    Join Date
    Nov 2011
    Location
    San Antonio/Houston
    Posts
    36
    Yeah but in low rpm i can feel it struggling and making some kind of grinding noise before it makes power (before like 2500rpm). Im going to check the fluid tomorrow morning. But the dealership i bought it from just resealed the tranny cause of a leak and flushed it.

  5. #4
    \_(ツ)_/ Rambo's Avatar
    Join Date
    Oct 2010
    Location
    Denial
    Posts
    4,798
    I Support ClubWRX
    ^^Just because a dealer sealed and flushed it doesn't mean you're golden. Why was the tranny leaking in the first place? How long was the car driven before the leak was detected? You can probably see where this is going...

    As an aside, my transmission makes all kinds of noises, especially when I lift off the throttle in lower gears. However, gear shifts are all silky smooth, and the diffs are doing their job admirably.
    Isaac -- 2003 WRX sedan Stg II - Gave its life for mine 6/2013.
    2007 Outback 3.0R wagon
    Proud owner of a N.E.R.D, Member 1.3810-23

    He who shall be last, shall be sideways and smiling... - Jeremy Clarkson

  6. #5
    Registered User
    Join Date
    Nov 2011
    Location
    San Antonio/Houston
    Posts
    36
    Yeah that's my point. I don't trust they took car of any extra problems they saw. They leak was coming from the shift linkage. A friend and i put it up on the lift and found the leak immediately. A shop confirmed that the seal inside was corroded. I bought the car in Oct. at 83k miles and noticed the leak about 2 weeks later. Got it fixed after haggling with the dealership about 2 weeks ago. I took it to the other shop again today and they said that's just normal operation, some have that noise some don't.

  7. #6
    Registered User Pavia's Avatar
    Join Date
    Dec 2006
    Location
    Philly/DE area
    Posts
    2,934
    Quote Originally Posted by zax View Post
    I wouldn't worry about a noise. My transmission makes a cacophony of noises at all times. Are you able to smoothly shift into all gears? If you're worried, drain the transmission fluid and look for chunks of metal on the magnetic drain plug.
    I just find roll pins on my plug, lol
    06 GTO M6 Quicksilver, SLP 455 Bobcat, LS7 Clutch w/ SS line (RPM tune:373rwhp/373rwtq)
    07 WRX TR M5 Garnet Red Pearl w/ Straight PPGs and Cusco front LSD (Agile tune:307whp/343wtq)

  8. #7
    zax
    zax is offline
    \_(ツ)_/ zax's Avatar
    Join Date
    Nov 2008
    Location
    Neverland Ranch, Maryland
    Posts
    12,571
    I Support ClubWRX I Support ClubWRX
    Quote Originally Posted by Pavia View Post
    I just find roll pins on my plug, lol
    Did you get that fixed yet?
    2015 CWP WRX STi ... But how did I get roped back into an EJ motor?!
    Zax's utterly unimaginably stock 2015 STi build thread
    Zax's Shaggin' Wagon Build Thread Now tuned for 99% pure Unicorn Jizz!

    Zach | Moderator -- Mid-Atlantic States, Tech & Modifying & General Repairs
    Rollin' with the Bugeye Mafia #302 | N.E.R.D. Subject Zero
    Facebook me here

    Your Mid-A local board: http://www.clubwrx.net/forums/mid-atlantic-states/

  9. #8
    Registered User Pavia's Avatar
    Join Date
    Dec 2006
    Location
    Philly/DE area
    Posts
    2,934
    Quote Originally Posted by zax View Post
    Did you get that fixed yet?
    Finally. The pin was actually just debris from the reassembly. Not cool but at least the plug caught it. But then both axle seals started seeping and had to be replaced today.
    06 GTO M6 Quicksilver, SLP 455 Bobcat, LS7 Clutch w/ SS line (RPM tune:373rwhp/373rwtq)
    07 WRX TR M5 Garnet Red Pearl w/ Straight PPGs and Cusco front LSD (Agile tune:307whp/343wtq)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •