result of a DEALER OIL CHANGE... - Page 2
Page 2 of 2 FirstFirst 12
Results 16 to 22 of 22

This is a discussion on result of a DEALER OIL CHANGE... within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; I saw that post in that other thread, I am definitely getting that. Worth a try for only ....

  1. #16
    Registered User xFalleNx's Avatar
    Join Date
    Nov 2010
    Location
    Voorhees, NJ
    Posts
    4,030
    I saw that post in that other thread, I am definitely getting that. Worth a try for only $20.
    --Anthony 2011 DGM WRX stg2+sf intake WTFtuned \_(ツ)_/

    Official Subie owner as of 01/10/11
    Stink Eye Mob #87

    Bye bye Bimmer
    Hellooo '11 REX

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #17
    The Member michaelwfox's Avatar
    Join Date
    Nov 2011
    Location
    North GA
    Posts
    3,437
    I Support ClubWRX
    ^agreed!
    GTA:O ClubWRX Crew

    My "Build" Thread!

    2006 WRX TR
    Hawk-Eye Alliance #1856...ssshhh don't tell anyone!

  4. #18
    Gold Member lokey's Avatar
    Join Date
    Jan 2011
    Location
    Crofton, MD
    Posts
    2,164
    I Support ClubWRX
    Mine came yesterday.
    Greg
    Build Thread
    ProTuned Stage 3ish '11 WRX Ltd HB (SWP) ~ 354 awhp 404 ft-lb tq on E85
    Friends don't let friends drive Mitsubishis.

  5. #19
    Registered User slitlymodified's Avatar
    Join Date
    Dec 2010
    Posts
    105
    We had a problem here. A new tech who no longer works here was puttin on oil filters too tight causing leaks. Sucks about your situation but it's not a shock. I had them do my oil at work in my dads truck and they never put his oil filler cap back on. I do all oil changes at home now. And yes I work at a Subaru dealer... And unfortunately my work sucks. Anyways good luck!

  6. #20
    Registered User st3v3.w's Avatar
    Join Date
    Oct 2011
    Location
    Chicago
    Posts
    48
    so an update, subaru fixed the problem, it was a "defective oil filter" said the service guy. whatever that means... now i gotta go pick my baby up

  7. #21
    Moderator rage-wrx's Avatar
    Join Date
    Aug 2010
    Location
    Yonkers/NYC
    Posts
    10,761
    I Support ClubWRX
    You should have asked him to show you the filter & explain.
    T0ny
    2011 WRX
    2012 FXT

    The Big 2011/2012 Mod Thread


    Ooh,hang on. That is the throb of a turbocharged flat four engine. A sound which,all over the world,heralds the imminent arrival of a moron - JC.

  8. #22
    Registered User Pavia's Avatar
    Join Date
    Dec 2006
    Location
    Philly/DE area
    Posts
    2,934
    The first question you should always ask if you take your car to Jiffy Lube (or equiv) is "Did you put oil in it..."

    Sad state of affairs for car work these days
    06 GTO M6 Quicksilver, SLP 455 Bobcat, LS7 Clutch w/ SS line (RPM tune:373rwhp/373rwtq)
    07 WRX TR M5 Garnet Red Pearl w/ Straight PPGs and Cusco front LSD (Agile tune:307whp/343wtq)

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •