2012 TPMS (issue) keeps turning off and on
Page 1 of 2 12 LastLast
Results 1 to 15 of 27

This is a discussion on 2012 TPMS (issue) keeps turning off and on within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Hey guys, I think I may have a defective TPMS sensor on my car. It's 3 days old and the ...

  1. #1
    Registered User Jabbathewhat's Avatar
    Join Date
    Dec 2011
    Location
    Pembroke Pines, FL
    Posts
    188

    2012 TPMS (issue) keeps turning off and on

    Hey guys, I think I may have a defective TPMS sensor on my car. It's 3 days old and the TPMS sensor light turns on and off throughout the day. It sometimes turns on when I hit a hard bump. I checked all 4 tires and they look good. My questions are:

    1) Do the sensors log this somewhere an if so can the dealer see which run it is coming from?

    2) what is the OEM setting for tire pressure? Is there a high low that the sensor recognizes?

    3) any of you guys run into this issue yet?

    I want to take it to the dealer but it is so sparatic at this point, im afraid that they won't be able to duplicate. If it does log this data it would be easier to spot.
    12/27/11 - Ordered
    01/16/12 - Received
    2012 WRX Hatch World Rally Blue

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Moderator rage-wrx's Avatar
    Join Date
    Aug 2010
    Location
    Yonkers/NYC
    Posts
    10,793
    I Support ClubWRX
    I'd check the cold tire pressure first.You cannot tell if pressure is upto spec by looking at it.A drop of 5psi will trigger the TPMS.

    Spec can be found on the driver side door jamb.
    T0ny
    2011 WRX
    2012 FXT

    The Big 2011/2012 Mod Thread


    Ooh,hang on. That is the throb of a turbocharged flat four engine. A sound which,all over the world,heralds the imminent arrival of a moron - JC.

  4. #3
    Registered User Jabbathewhat's Avatar
    Join Date
    Dec 2011
    Location
    Pembroke Pines, FL
    Posts
    188
    Quote Originally Posted by rage-wrx View Post
    I'd check the cold tire pressure first.You cannot tell if pressure is upto spec by looking at it.A drop of 5psi will trigger the TPMS.

    Spec can be found on the driver side door jamb.
    Yeah I need to do that but it still doesn't explain the random off and on of the sensor.

    Do you know if it logs this data somewhere?
    12/27/11 - Ordered
    01/16/12 - Received
    2012 WRX Hatch World Rally Blue

  5. #4
    Supporting Member mjboudreaux77's Avatar
    Join Date
    Sep 2007
    Location
    Northern Vermont
    Posts
    843
    I Support ClubWRX
    I don't think the ECU is logging this. I have never had the issue on my '11.

    Since you live in Florida, I don't think you are experiencing huge temperature differences throughout the day. I would take it to the dealer and see what they say. This issue will bite you later when you get the car inspected.
    If I don't die by Thursday, I'll be roarin Friday night - Jimmy Buffett

  6. #5
    Moderator rage-wrx's Avatar
    Join Date
    Aug 2010
    Location
    Yonkers/NYC
    Posts
    10,793
    I Support ClubWRX
    Never heard of this but it is unlikely that the ECU is logging tire pressures.I still say,check tire pressure before taking it to the dealer.

    I've had the TPMS on my SUV light up after I hit a pothole and go away after a while.
    T0ny
    2011 WRX
    2012 FXT

    The Big 2011/2012 Mod Thread


    Ooh,hang on. That is the throb of a turbocharged flat four engine. A sound which,all over the world,heralds the imminent arrival of a moron - JC.

  7. #6
    Registered User Jabbathewhat's Avatar
    Join Date
    Dec 2011
    Location
    Pembroke Pines, FL
    Posts
    188
    I'll check that out shortly and let you guys know what's up. Thanks or the advice.
    12/27/11 - Ordered
    01/16/12 - Received
    2012 WRX Hatch World Rally Blue

  8. #7
    Registered User Jabbathewhat's Avatar
    Join Date
    Dec 2011
    Location
    Pembroke Pines, FL
    Posts
    188
    Ok so I finally went outside this morning to check the tire pressure on the car. To my surprise it is reading 47psi all around!!! I checked the door jam and it said 32 and 33 psi. Could this be the reason my TPMS is acting weird? Also what's the deal with the car coming with such high psi on the tires???
    12/27/11 - Ordered
    01/16/12 - Received
    2012 WRX Hatch World Rally Blue

  9. #8
    Moderator T0rque's Avatar
    Join Date
    Dec 2004
    Location
    Medford, Oregon
    Posts
    25,518
    I Support ClubWRX
    Yes


    Lead Wrench @ WTF Tuning, LLC

  10. #9
    Moderator rage-wrx's Avatar
    Join Date
    Aug 2010
    Location
    Yonkers/NYC
    Posts
    10,793
    I Support ClubWRX
    Quite possibly.Whats the deal?Idiots at the dealer doing car prep.
    T0ny
    2011 WRX
    2012 FXT

    The Big 2011/2012 Mod Thread


    Ooh,hang on. That is the throb of a turbocharged flat four engine. A sound which,all over the world,heralds the imminent arrival of a moron - JC.

  11. #10
    Registered User Jabbathewhat's Avatar
    Join Date
    Dec 2011
    Location
    Pembroke Pines, FL
    Posts
    188
    ***update***.
    Looks like all the tires were at 51psi which is the max of the tire. WTH!!! So I dropped them all to the recommended pressure and went for a drive. So far no more sensor light showing up. Word of advice to new car owners, check the tire pressure from factory.
    12/27/11 - Ordered
    01/16/12 - Received
    2012 WRX Hatch World Rally Blue

  12. #11
    KHP
    KHP is offline
    Registered User KHP's Avatar
    Join Date
    Oct 2010
    Location
    Reno, NV
    Posts
    752
    If you set the pressure of the tires right after the car has been driven, then make sure to check the pressure once again before driving the following day. Pressure should be set first thing in the morning before driving. You'll end up with an under inflated tire if you set your pressure with a warm tire.
    2011 WRX Limited Spark Silver (5 Door)

  13. #12
    Registered User Jabbathewhat's Avatar
    Join Date
    Dec 2011
    Location
    Pembroke Pines, FL
    Posts
    188
    I did it on a cold tire but thanks for the info.
    12/27/11 - Ordered
    01/16/12 - Received
    2012 WRX Hatch World Rally Blue

  14. #13
    mrd
    mrd is offline
    Registered User mrd's Avatar
    Join Date
    Nov 2010
    Location
    Livermore,CA
    Posts
    172
    I have this issue on legacy, from time to time, when temp drops down. When this happens I adjust the presure, and it works for a while. On wrx this issue doesn't show, as I don't have tpmss on winter set.
    Every time I get car from shop pressure is messed up, and I check it then.
    Again I don't drive legacy, so what happens between checks I don't know.

  15. #14
    KHP
    KHP is offline
    Registered User KHP's Avatar
    Join Date
    Oct 2010
    Location
    Reno, NV
    Posts
    752
    Quote Originally Posted by Jabbathewhat View Post
    I did it on a cold tire but thanks for the info.
    Cool! Was just making sure. You mentioned that pressure was 47 psi, and your second measurement was at 51 psi. I was thinking that the 4 PSI difference had to do with a warm tire measurement.
    2011 WRX Limited Spark Silver (5 Door)

  16. #15
    Moderator T0rque's Avatar
    Join Date
    Dec 2004
    Location
    Medford, Oregon
    Posts
    25,518
    I Support ClubWRX
    check the spare tire.. Does anyone know if the spare tire has a sensor? they usually do have tpms sensors also and could be tripping a light.


    Lead Wrench @ WTF Tuning, LLC

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •