2011 WRX After one year: Issues/Problems? - Page 7
+ Reply to Thread
Page 7 of 8 FirstFirst 12345678 LastLast
Results 91 to 105 of 117

This is a discussion on 2011 WRX After one year: Issues/Problems? within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; I've taken the car in for the rear deck rattle, but not the front. As soon as one was fixed ...

  1. #91
    Registered User djclue8713's Avatar
    Join Date
    Aug 2010
    Location
    Springfield, MA
    Posts
    567
    I've taken the car in for the rear deck rattle, but not the front. As soon as one was fixed another appeared! Now that it's getting warmer out I don't hear it as much, but I'll be sure to bug the dealer the next time I'm in for a service.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #92
    Lando Calrissian DemonWRX's Avatar
    Join Date
    Jul 2011
    Location
    Cloud City, Bespin
    Posts
    3,314
    I Support ClubWRX
    Quote Originally Posted by Deangelo Vickers View Post
    I have 1,400 miles on a stock 2011 WRX and hear rattling on front pillars/dash when it's cold. Sounds like others have had similar experience (although might be the result of mods). The car is clearly under warranty. Has anyone tried to get this addressed at the dealer?
    yeah, there are a few that had the dealer fix under warranty....the dealer will simply remove the panel that is making noise and pit small amounts of that sticky backed foam weather striping between the plastic panel and where ever it contacts the body or another panel.

    If you are so inclined, you can do this yourself to your whole car for under $20
    Stink-Eye Mob #39
    N.E.R.D. Operative #8

  4. #93
    Registered User AmateurX's Avatar
    Join Date
    Jul 2009
    Location
    Troy, Michigan
    Posts
    745
    Quote Originally Posted by DemonWRX View Post
    If you are so inclined, you can do this yourself to your whole car for under $20
    That's probably the best option anyway. I've had my door rattle repaired at least 3 times, and it's on its way back. I figure if I fix it myself I'll do it right, or at least have the know how to do it again if need be.

    Sent from Tapatalk, cuz I can't get enough.
    2011 WRX Limited, DGM; full tint, SPT CBE/STS w/ bushings, RA flaps, Enkei PF01s, Pink SuperTones, and ClubWRX.net stickers!
    My Photostream
    about.me

  5. #94
    Registered User st3v3.w's Avatar
    Join Date
    Oct 2011
    Location
    Chicago
    Posts
    48
    So, I recently picked up a bottle of touch-up paint from the dealer, do you guys have any experience with it? it is pretty neat how they have the brush AND a pen form. I never applied it before and wanted some advice. Am i suppose to blob it on and smear excess off? or color it on with pen. all of the chips are on the hood of the car. I have like 4 of them now and I can only see more in the future. surprisingly there is nothing on my bumper...

    thanks.

  6. #95
    Registered User SamXp's Avatar
    Join Date
    Nov 2010
    Location
    Winston-Salem, NC
    Posts
    463
    29,100 miles and have the following issues:
    Day 1) Fuel door won't pop open. I have to pry it open after pulling the release lever.
    2) Creaking from transmission during shifts on cold mornings. It has been to the dealer three times. They lubed it the first two times and replaced a bushing the last time, which made it much worse. Need to bring it back and insist they fix it for good before my warranty runs out.
    3) Rear window spray hose was pinched beneath the spoiler, dealer fixed it.
    4) Front right instability, dealer replaced leaky strut.

  7. #96
    Registered User tommy_c's Avatar
    Join Date
    Jun 2011
    Location
    Philadelphia, PA
    Posts
    478
    Quote Originally Posted by st3v3.w View Post
    So, I recently picked up a bottle of touch-up paint from the dealer, do you guys have any experience with it? it is pretty neat how they have the brush AND a pen form. I never applied it before and wanted some advice. Am i suppose to blob it on and smear excess off? or color it on with pen. all of the chips are on the hood of the car. I have like 4 of them now and I can only see more in the future. surprisingly there is nothing on my bumper...

    thanks.
    DO NOT USE THE PEN. Use a toothpick or something small to dab. I would use a small amount to start if its a deep chip/scratch. When/If you use the brush, cut the bristles shorter so that you have more control over how much you want to spread the paint. I actually ordered the Dr. Color Chip system for my rock chips on my fender so I'll probably do a small write up on how that goes. That system looks a lot better than the normal pens you get from the dealership.
    2011 WRX 5-Door WRB
    Cobb AP Stage 1 - SPT Exhaust - Bayson R Lip - 30% Tints

    2006 Honda CBR600RR
    Jardine RT-1 Exhaust - Fender Eliminator - Integrated Front & Rear Signals

    2001 Audi TT - Sold

  8. #97
    Registered User sportsman's Avatar
    Join Date
    Oct 2011
    Location
    Santa Cruz California
    Posts
    109
    2011 sti hatch 25k no issues so far.

    had the car repainted completely and color sanded with ppg stopped the chip problem. still obsidian black!!

    No drive train problems yet i am surprised cause i beat the piss out of it.

    The funnest car i have ever owned no doubt.
    Second place just means you were first too lose!

  9. #98
    Registered User tommy_c's Avatar
    Join Date
    Jun 2011
    Location
    Philadelphia, PA
    Posts
    478
    Quote Originally Posted by sportsman View Post
    2011 sti hatch 25k no issues so far.

    had the car repainted completely and color sanded with ppg stopped the chip problem. still obsidian black!!

    No drive train problems yet i am surprised cause i beat the piss out of it.

    The funnest car i have ever owned no doubt.
    What was the reason you went with a full repaint? Care to share the price for a job like that?
    2011 WRX 5-Door WRB
    Cobb AP Stage 1 - SPT Exhaust - Bayson R Lip - 30% Tints

    2006 Honda CBR600RR
    Jardine RT-1 Exhaust - Fender Eliminator - Integrated Front & Rear Signals

    2001 Audi TT - Sold

  10. #99
    Registered User sportsman's Avatar
    Join Date
    Oct 2011
    Location
    Santa Cruz California
    Posts
    109
    So after owning my car about two weeks i got pelted with a million pieces of glass on the hwy.
    It made the car look like it had been driven for ten years. So my insurance paid for the front bumper,fenders,mirrors,
    hood,roof,and two front doors to be repainted i asked the shop how much more it would be to just repaint everything else and it was very cheap so i just went for it. they also replaced my headlights and windshield.

    i was bummed that it happened but at-least the after market paint does not chip as easy.
    Second place just means you were first too lose!

  11. #100
    Registered User WRXpa's Avatar
    Join Date
    Jan 2012
    Location
    Philly Burbs
    Posts
    344
    Quote Originally Posted by SamXp View Post
    29,100 miles and have the following issues:
    Day 1) Fuel door won't pop open. I have to pry it open after pulling the release lever.
    2) Creaking from transmission during shifts on cold mornings. It has been to the dealer three times. They lubed it the first two times and replaced a bushing the last time, which made it much worse. Need to bring it back and insist they fix it for good before my warranty runs out.
    3) Rear window spray hose was pinched beneath the spoiler, dealer fixed it.
    4) Front right instability, dealer replaced leaky strut.
    An outstanding issue should still be covered after the warrantee has expired.
    I have a low Reynolds number

    TP Stage 1 - 2012 WRX Premium 5-Door SWP
    Pics!


  12. #101
    Registered User westsideguy's Avatar
    Join Date
    Aug 2009
    Location
    San Diego
    Posts
    7
    I've had my 2009 black hatch since september 2009 and I'm still stoked to drive it. Right now I go to school and drive alot, so i have another daily driver at the moment as to not rack up miles on the subie, but I've got about a little over 30,000 miles on it. I always thought my clutch was heavy and I simply wrote it off as me not knowing how a clutch felt when i first got it (being my first stick shift car and all). But then I drove my friend's 2008 sedan and I was shocked to feel his clutch and how light it felt to me. I was always afraid to mention anything to the dealer cause I know a tranny job can be pretty expensive with labor and all, but I finally asked what was covered under warranty and concluded it wasn't my clutch disc cause it wasn't slipping, but hard engagement was almost inevitable if not totally babying the car.
    Anyway, i took the car in knowing i only had to pay a small deductible for the clutch work and the tech found that my stock pressure plate was "warped". Of course I'll never be able to see the actual part cause its immediately documented and stored at the dealer, but I get the car back tomorrow and I can't wait to drive it. They concluded that premature would be caused on the actual clutch disc itself so I am getting the entire clutch assembly (pressure plate, clutch disc, t/o bearing) put on for free!! Can't wait to break the new components in

  13. #102
    Registered User
    Join Date
    Oct 2010
    Posts
    68
    Coming up on 15 months and about 22,000 miles.

    1. Vibrating clutch pedal after going WOT in 2nd or 3rd gear. Could finally replicate reliabliy for dealer and they lubed the clutch fork. Issue has not returned.

    2. Standard rattles

    3. Standard terrible paint. It's not in horrible shape after using sound washing and drying techniques, but the front end will get worse with time.

    4. Tiny crack on lower left side front bumper from nailing a cone at autocross this past weekend. Guess going for those extra tenths wasn't worth it. Also lost two fender liner clips--replaced at dealer for like $5.

    5. Tiny curbage on right front wheel after trying to get out of the way of an ambulance in traffic. Still have not found any word on touch-up color for the 2011 wheels, but it's not even noticeable unless you're looking for it.

    6. Tiny ding on right-rear fender line. Will probably be difficult/expensive to PDR, so I'll wait until I have some more.

    About to flash cobb stage 1 and have loved the car since I've owned it.

  14. #103
    Lando Calrissian DemonWRX's Avatar
    Join Date
    Jul 2011
    Location
    Cloud City, Bespin
    Posts
    3,314
    I Support ClubWRX
    Quote Originally Posted by Foolycooly View Post
    1. Vibrating clutch pedal after going WOT in 2nd or 3rd gear. Could finally replicate reliabliy for dealer and they lubed the clutch fork. Issue has not returned.
    Can you give more info on this issue, and what it took for the dealer to fix it? I have the same issue, and have been doing my best to just ignore it, but if it is a part that needs lubed, I will get my dealer to fix it.
    Stink-Eye Mob #39
    N.E.R.D. Operative #8

  15. #104
    Registered User
    Join Date
    Oct 2010
    Posts
    68
    Quote Originally Posted by DemonWRX View Post
    Can you give more info on this issue, and what it took for the dealer to fix it? I have the same issue, and have been doing my best to just ignore it, but if it is a part that needs lubed, I will get my dealer to fix it.
    Technically speaking, that's all I know. The only reason why I was able to point the dealer to that is that someone had the same issue resolved on NASIOC. I was able to replicate the problem and the tech was sort of puzzled by it, acknowledging that it was weird. I suggested that someoneone had the problem fixed by lubing the clutch fork. They did so, and the problem went away.

  16. #105
    Registered User djclue8713's Avatar
    Join Date
    Aug 2010
    Location
    Springfield, MA
    Posts
    567
    Quote Originally Posted by Foolycooly View Post
    Technically speaking, that's all I know. The only reason why I was able to point the dealer to that is that someone had the same issue resolved on NASIOC. I was able to replicate the problem and the tech was sort of puzzled by it, acknowledging that it was weird. I suggested that someoneone had the problem fixed by lubing the clutch fork. They did so, and the problem went away.
    I've had this issue intermittently, but not enough for me to bug the dealer about. The one that's annoying for me is the squeak when taking off out of first (throwout bearing?). Anyone else?

+ Reply to Thread
Page 7 of 8 FirstFirst 12345678 LastLast

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •