Just Went Stage 2 and Now a Clanging Rattle
Results 1 to 4 of 4

This is a discussion on Just Went Stage 2 and Now a Clanging Rattle within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Title says...most of it. I've got a brand new 2011 WRX sedan w/ 12,000mi on it and I just put ...

  1. #1
    Registered User bbrock171's Avatar
    Join Date
    Sep 2011
    Location
    Northern Virginia
    Posts
    179

    Just Went Stage 2 and Now a Clanging Rattle

    Title says...most of it. I've got a brand new 2011 WRX sedan w/ 12,000mi on it and I just put an AEM intake, an Invidia catless DP on it and flashed a Stage 2+ map. I also put in Cobb shifter bushings. I drove it for a few days and all seemed well until I went on a road trip and I started to notice a loud, metal, clanging rattle while decelerating especially around 2000-2500rpm. I can hear it a little once in a while in other rpm ranges but it gets very loud and annoying right in that range. Now it is very prominent and I even notice it during easy driving around town. I checked every single nut and bolt I touched while doing my install (twice) and everything is tight. Both of the exhaust gaskets are brand new. I'm totally stumped. I just lifted the car and checked everything again. I decided to add a zip-tie to the O2 sensor wire and took it for a spin; everything seemed fine until about 5min into the ride and the rattle came back full force. Where did I go wrong? Please Help!

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Sammich Makin' Pwincess wrxtreme06's Avatar
    Join Date
    May 2007
    Location
    orlando flawduh
    Posts
    12,686
    I Support ClubWRX
    what youre describing is the exact rattle i had in my car after my exhaust install. come to find out it was my exhaust hanger. did you check those?

    desiree
    your friendly, neighborhood subaru girl
    abbigale : 06 impreza wrx tr: cobb stage II
    hawkeye alliance #11:11//
    wingl3ss @ll!ance #17 // lvl 80 N.E.R.D.

  4. #3
    Registered User bbrock171's Avatar
    Join Date
    Sep 2011
    Location
    Northern Virginia
    Posts
    179
    Quote Originally Posted by wrxtreme06 View Post
    what youre describing is the exact rattle i had in my car after my exhaust install. come to find out it was my exhaust hanger. did you check those?
    Yeah, I checked all the hangers even though I only installed a downpipe. Now the rattle is changing constantly. The rpm range that does it changes daily and sometimes it's only on idle or it doesn't do it when it's cold first thing in the morning but will start up again as soon as the car is warm. I guess I need to get a buddy to help me listen to it while someone is revving the engine. I can't really locate it while listening from inside the car.

  5. #4
    Moderator T0rque's Avatar
    Join Date
    Dec 2004
    Location
    Medford, Oregon
    Posts
    25,518
    I Support ClubWRX
    all the heat shields off the motor that you unbolted? How about the bracket that hangs down to hold the downpipe in place?


    Lead Wrench @ WTF Tuning, LLC

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •