Air Discharge on 2011 WRX when accellerator is pressed
Page 1 of 2 12 LastLast
Results 1 to 15 of 16

This is a discussion on Air Discharge on 2011 WRX when accellerator is pressed within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Good Day, Urgent help required. When i press the accelerator pedal on my 2011 wrx i hear an air discharge ...

  1. #1
    Registered User
    Join Date
    Dec 2011
    Posts
    6

    Air Discharge on 2011 WRX when accellerator is pressed

    Good Day,

    Urgent help required. When i press the accelerator pedal on my 2011 wrx i hear an air discharge coming from the outside and cool air comes out from the air vents in the inside of the car.

    Can anyone assist me with this? Want to take the car to the dealer on Wed. only has 7000kms on it.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User teflon_jones's Avatar
    Join Date
    Apr 2007
    Location
    8000' up in Colorado
    Posts
    6,753
    I don't exactly understand what you mean... So basically when you go faster you get air out of the vents? That's normal when the fan is off because the system is totally sealed. You actually get less air out of the vents with the fan on the slowest setting than you do with it off.
    Scott
    Past Subies - '11 STI Limited stage 1+ and '04 STi stage 2+
    '13 Wrangler Rubicon - custom front bumper w/12k lb winch & off-road lights, skid plates, diff guards, etc.
    '04 Porsche 911 Turbo GT2 clone 600 HP/TQ
    '77 F-150 heavily modded for off-roading

  4. #3
    The Fruit mangostick's Avatar
    Join Date
    Oct 2009
    Location
    VB VA .. the ghetto on the sea
    Posts
    4,735
    Scott I'm curious if he's got a boost/vac leak .. the part about stepping on the go pedal and hearing air escapting the system makes me curious if the intercooler to throttle body hose has developed a leak or isn't seated correctly. I found mine (2010 wrx) not secured fully to the throttle body from the factory.

    since the actuators on the hvac controls are vac driven a leak could cause the fresh air vent to open letting cold outside air in. *shrug*

    Desigan.. if you can, bring it to the dealer and describe the problem. With the car that new and that low in mileage it will definitely be a warranty issue if there is anything in need of repair.
    OBP 2010 5dr *traded*
    SWP 2013 FRS
    My name is Shawn, I'm a Devout Practicalist and I'm addicted to flat4's
    This page has had 1,666 visits
    SUCH IS MANGO!

  5. #4
    Registered User teflon_jones's Avatar
    Join Date
    Apr 2007
    Location
    8000' up in Colorado
    Posts
    6,753
    Interesting one mango haven't heard it's set up that way.
    Scott
    Past Subies - '11 STI Limited stage 1+ and '04 STi stage 2+
    '13 Wrangler Rubicon - custom front bumper w/12k lb winch & off-road lights, skid plates, diff guards, etc.
    '04 Porsche 911 Turbo GT2 clone 600 HP/TQ
    '77 F-150 heavily modded for off-roading

  6. #5
    Moderator T0rque's Avatar
    Join Date
    Dec 2004
    Location
    Medford, Oregon
    Posts
    25,518
    I Support ClubWRX
    If its an 11 take it to the dealer.


    Lead Wrench @ WTF Tuning, LLC

  7. #6
    The Fruit mangostick's Avatar
    Join Date
    Oct 2009
    Location
    VB VA .. the ghetto on the sea
    Posts
    4,735
    Quote Originally Posted by teflon_jones View Post
    Interesting one mango haven't heard it's set up that way.
    With the hvac actuators I'm going on assumption.. I very well could be wrong. Many of the cars I've run across in the past are vac driven.. so.. dunno. But I'm with Bo on this one.. I'd be back at the dealer with a dumb face and a " its doin somethin goofy " explanation. It has a warranty, I'd let the dealer do the thinking/work.

    In regards to the ic to tb hose though.. I was shocked and a little pissed to find (at 60K miles no less) that the hose was never seated right. It didn't leak until I went stageII, however it could have at any time before that.
    OBP 2010 5dr *traded*
    SWP 2013 FRS
    My name is Shawn, I'm a Devout Practicalist and I'm addicted to flat4's
    This page has had 1,666 visits
    SUCH IS MANGO!

  8. #7
    Registered User
    Join Date
    Dec 2011
    Posts
    6
    Thanks guys. will be taking it in Wed. to elaborate on the sound when accel is pressed. the harder i press it the more air comes out of the air vents and when the windows are open i can hear air escaping from the engine compartment. it sounds as if air coming out of a blow off valve. There are no mods in this car.
    Last edited by Desigan; 12-26-2011 at 11:46 AM.

  9. #8
    Registered User
    Join Date
    Dec 2011
    Posts
    6
    it's a bit annoying as this is one the the best drives(in terms of handling and accel) out there.

  10. #9
    Registered User
    Join Date
    Dec 2011
    Posts
    6
    Question guys. How much horsepower can i get outta this car if i wanna mod it down the line. i still wanna keep the 5 spd transmission

  11. #10
    Registered User SRTSamb's Avatar
    Join Date
    Mar 2011
    Location
    Virginia
    Posts
    719
    Quote Originally Posted by Desigan View Post
    Question guys. How much horsepower can i get outta this car if i wanna mod it down the line. i still wanna keep the 5 spd transmission
    That totally depends on how you want to mod and what you want to do with the car.

    TBE and tune you are looking at the 270ish hp range (conservatively depending on the dyno)

    Lokey and others have build threads you should look at
    2011 OBP WRX::Invidia Catless DP::Cobb CAI::TP 93 STG2::KB STS::Perrin Sways::

  12. #11
    The Fruit mangostick's Avatar
    Join Date
    Oct 2009
    Location
    VB VA .. the ghetto on the sea
    Posts
    4,735
    does the car run funny at all? If you have a leak after the turbo you'll have a rushing sound with more throttle input but diminishing power and then it'll backfire and blow flames out of the exhaust (the ecu is adding fuel where more air should also be but isn't.. thus the backfire and flames) ..

    if its not acting funny I'd still take it in and describe what you've found. Either way its still very early in the warranty so I doubt they'll give you any trouble about it.
    OBP 2010 5dr *traded*
    SWP 2013 FRS
    My name is Shawn, I'm a Devout Practicalist and I'm addicted to flat4's
    This page has had 1,666 visits
    SUCH IS MANGO!

  13. #12
    Registered User
    Join Date
    Dec 2011
    Posts
    6
    Mango,

    You may be right, when i increased accel, i heard a creek, did not want to push it any harder.

  14. #13
    Registered User sjcurtis's Avatar
    Join Date
    Sep 2010
    Location
    Selma, Alabama
    Posts
    856
    Is there anything done to the car like CAI, BOV or BPV?

  15. #14
    The Fruit mangostick's Avatar
    Join Date
    Oct 2009
    Location
    VB VA .. the ghetto on the sea
    Posts
    4,735
    mine was completely factory.. it was while I was removing the ic to change the dp I noticed.. and found all the evidence that it had been bleeding off boost for some time.

    Desigan take it to the dealer and let them work it out. Seriously..with a car that new.. its in the hands of the warranty. As long as the car isn't modified you should be fine.
    OBP 2010 5dr *traded*
    SWP 2013 FRS
    My name is Shawn, I'm a Devout Practicalist and I'm addicted to flat4's
    This page has had 1,666 visits
    SUCH IS MANGO!

  16. #15
    Registered User
    Join Date
    Dec 2011
    Posts
    6
    Done, thanks guys. the findings where as follows:

    - car was depleting boost because of a loose pipe from the turbo to intercooler. Dealer tech fixed it within 1.5hrs. Back in action.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •