check engine light po171 - Page 2
Page 2 of 3 FirstFirst 123 LastLast
Results 16 to 30 of 32

This is a discussion on check engine light po171 within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Gas mileage is suspicious for no. 8 or no. 9 in the list above. Makes me think. Let us know ...

  1. #16
    He simply abides. SD_GR's Avatar
    Join Date
    Jul 2002
    Location
    CA, US
    Posts
    22,562
    I Support ClubWRX
    Gas mileage is suspicious for no. 8 or no. 9 in the list above. Makes me think. Let us know what you work out.
    WRX Info Links, Courtesy TheJ
    The world breaks everyone and afterward many are strong in the broken places. Ernest Hemingway
    I lied. I cheated. I bribed men to cover the crimes of other men. I am an accessory to murder. But the most damning thing of all... I think I can live with it. And if I had to do it all over again - I would. Benjamin Sisko
    DISCLAIMER: Opinions expressed are the author's alone and are inherently worthless.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #17
    Registered User bradsorensen's Avatar
    Join Date
    Nov 2011
    Location
    kingston wa
    Posts
    132
    I Support ClubWRX
    Ok so i replaced the rear o2 sensor and when down to napa to clear the codes and it said i had po171 and po134. For some reason my cobb accesses port did not pick up this code. the po134 code is for the front o2 sensor not responding or receiving, witch would have been nice to know before replacing the rear o2 sensor but while replacing the rear o2 sensor i noticed that the wires where partly frayed(see pic attached). so it turns out that it still would have had to replace it anyway at some time. after clearing the cel it did come back on like i thought because i need to replace the front o2 censor witch was the original problem. Im not happy with my cob accesses port on reading codes because even with the cel on now it says that there are no codes to be found(2nd time with this problem.) I am very happy to know the real problem now and will order a new front o2 sensor and replace. Thanks for everyone help on this issue and will post after the new sensor is installed.
    Last edited by bradsorensen; 12-31-2011 at 10:23 PM.

  4. #18
    Registered User bradsorensen's Avatar
    Join Date
    Nov 2011
    Location
    kingston wa
    Posts
    132
    I Support ClubWRX
    sorry wrong pics

  5. #19
    Registered User bradsorensen's Avatar
    Join Date
    Nov 2011
    Location
    kingston wa
    Posts
    132
    I Support ClubWRX
    update just replaced the front o2 sensor and the car has no more check engine light problem resolved!

  6. #20
    Registered User
    Join Date
    Feb 2012
    Location
    San Diego
    Posts
    19
    Alright hopefully there are still active people on this thread cause I really need some help.. This damn p0171 code is killing me! I've replaced MAF sensor, checked for vacuum leaks and I just installed a new front o2 sensor and the damn CEL came back on yesterday. Is there anything else I'm missing? I need to smog the car before the end of the month since my plates expire . Any help would be greatly appreciated!. And also another quick question, since I just installed the new o2 sensor should I reset the ECU (take off negative, step on gas), and drive the car around so it can read the new sensor?

  7. #21
    Moderator Donkey's Avatar
    Join Date
    Apr 2005
    Location
    Da boonies
    Posts
    6,095
    I Support ClubWRX
    Read post #10. I you have not tried everything on that list then that is where to continue. Also using a smoke machine is the proper/most efficient way to check for vacuum leaks. Most novice,unexpierenced mechanics tend to think the proper way to check for vacuum leaks is with your eyeballs. It's not. You generally will never spot a blown out lower TGV/manifold gasket or a torn turbo inlet pipe unless those parts are removed.
    Resident Adviser @ WTF Tuning, LLC
    2002 FORESTER S
    1998 FORESTER S




  8. #22
    Registered User
    Join Date
    Feb 2012
    Location
    San Diego
    Posts
    19
    Alright thanks man, I gotta look for a shop with a smoke machine. This damn CEL is stressing me out since I don't wanna pay like 200 dollars for someone to "smog" my car. I'd rather fix it and clear the CEL. I'm also thinking of cleaning the IAV since I read it could also be the problem. I really thought the stuttering was gonna go away with the new o2 sensor but its still there when i go on the freeway and hit higher speeds

  9. #23
    Registered User
    Join Date
    Feb 2012
    Location
    San Diego
    Posts
    19
    Also I noticed that the MAF sensor doesn't really sit perfectly well on short ram.. maybe this could be the problem? When I got the car I noticed the previous owner had used sealant around the MAF sensor, maybe I should go back to stock air box? or get a new short ram that's carb legal. ?

  10. #24
    He simply abides. SD_GR's Avatar
    Join Date
    Jul 2002
    Location
    CA, US
    Posts
    22,562
    I Support ClubWRX
    I prefer the stock air box personally.
    WRX Info Links, Courtesy TheJ
    The world breaks everyone and afterward many are strong in the broken places. Ernest Hemingway
    I lied. I cheated. I bribed men to cover the crimes of other men. I am an accessory to murder. But the most damning thing of all... I think I can live with it. And if I had to do it all over again - I would. Benjamin Sisko
    DISCLAIMER: Opinions expressed are the author's alone and are inherently worthless.

  11. #25
    Registered User
    Join Date
    Feb 2012
    Location
    San Diego
    Posts
    19
    Cant find a damn stock air box anywhere -.-

  12. #26
    He simply abides. SD_GR's Avatar
    Join Date
    Jul 2002
    Location
    CA, US
    Posts
    22,562
    I Support ClubWRX
    They must exist though, keep searching wreckers or used parts ads.

    If you saw a gap at the MAF, that can certainly cause a PO171. This doesn't mean it's the problem, but it absolutely is a problem. In fact I'd be surprised if it's not the cause of the CEL but that's just me.

    In any case, I'd be even more surprised if your car passed smog with a non-CARB intake on, since it's not a legal part and usually when they do the visual inspection they are awake enough to see what's directly in front of them. You need an air box anyway I'd guess.
    WRX Info Links, Courtesy TheJ
    The world breaks everyone and afterward many are strong in the broken places. Ernest Hemingway
    I lied. I cheated. I bribed men to cover the crimes of other men. I am an accessory to murder. But the most damning thing of all... I think I can live with it. And if I had to do it all over again - I would. Benjamin Sisko
    DISCLAIMER: Opinions expressed are the author's alone and are inherently worthless.

  13. #27
    Registered User
    Join Date
    Feb 2012
    Location
    San Diego
    Posts
    19
    Yeah i was planning on clearing the CEL first and then getting a carb legal short ram before the smog but since the short ram pipe could be the problem i should probably get a new one. Thanks for the help man

  14. #28
    He simply abides. SD_GR's Avatar
    Join Date
    Jul 2002
    Location
    CA, US
    Posts
    22,562
    I Support ClubWRX
    See if you can borrow one to save $ before buying. You will need all sensors reporting "ready" for smog.

    Send in the registration $ regardless to avoid late fees (check with DMV but I think this works).
    WRX Info Links, Courtesy TheJ
    The world breaks everyone and afterward many are strong in the broken places. Ernest Hemingway
    I lied. I cheated. I bribed men to cover the crimes of other men. I am an accessory to murder. But the most damning thing of all... I think I can live with it. And if I had to do it all over again - I would. Benjamin Sisko
    DISCLAIMER: Opinions expressed are the author's alone and are inherently worthless.

  15. #29
    Registered User
    Join Date
    Feb 2012
    Location
    San Diego
    Posts
    19
    Can't find a stock air box but I'm gonna keep looking. I also heard this kind of knock today and got worried.. doesn't sound horrible but I really have no idea what it could be.. does anyone have any idea? here is a short vid I took.
    wrx 2002 knock? - YouTube

  16. #30
    Registered User
    Join Date
    Apr 2012
    Location
    NV
    Posts
    6
    My CEL just came on and I got a P0171. My MAF and IACV have been cleaned. I've ordered a front o2 sensor. cuz my problems seem to match that one more... but I was wondering if a bad PCV could also cause the CEL?

Page 2 of 3 FirstFirst 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •