Just replaced the duty solonoid
Results 1 to 3 of 3

This is a discussion on Just replaced the duty solonoid within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Hi, I have a WRX 2001 that I have purchased for my wife. Had its 170K service no issues, except ...

  1. #1
    Registered User
    Join Date
    Dec 2011
    Posts
    1

    Just replaced the duty solonoid

    Hi,

    I have a WRX 2001 that I have purchased for my wife. Had its 170K service no issues, except the duty solonoid, which has now been replaced. After the service the car ran perfectly, but yesterday they replaced the duty solonoid and the car seems to be struggling when idle, it doesnt cut out but gets close. Would the ECU need to be reset considering the duty soloniod is now working (no telling how long it had not been working as we only has the car for 2 weeks)? I am a little stuck.

    Thanks for any help.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    He simply abides. SD_GR's Avatar
    Join Date
    Jul 2002
    Location
    CA, US
    Posts
    22,290
    I Support ClubWRX
    You could simply try resetting the ECU and see what happens I suppose. To do so, remove the battery's earth lead, press the brake pedal for a few moments, then reconnect the battery.
    WRX Info Links, Courtesy TheJ
    The world breaks everyone and afterward many are strong in the broken places. Ernest Hemingway
    I lied. I cheated. I bribed men to cover the crimes of other men. I am an accessory to murder. But the most damning thing of all... I think I can live with it. And if I had to do it all over again - I would. Benjamin Sisko
    DISCLAIMER: Opinions expressed are the author's alone and are inherently worthless.

  4. #3
    Moderator Donkey's Avatar
    Join Date
    Apr 2005
    Location
    Da boonies
    Posts
    5,994
    I Support ClubWRX
    Quote Originally Posted by PJW1971 View Post
    Hi,

    I have a WRX 2001 that I have purchased for my wife. Had its 170K service no issues, except the duty solonoid, which has now been replaced. After the service the car ran perfectly, but yesterday they replaced the duty solonoid and the car seems to be struggling when idle, it doesnt cut out but gets close. Would the ECU need to be reset considering the duty soloniod is now working (no telling how long it had not been working as we only has the car for 2 weeks)? I am a little stuck.

    Thanks for any help.
    What solenoid exactly did they replace and why?
    Resident Adviser @ WTF Tuning, LLC
    2002 FORESTER S
    1998 FORESTER S




Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •