Weird noise in engine bay
+ Reply to Thread
Results 1 to 3 of 3

This is a discussion on Weird noise in engine bay within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; I'm going to try to describe this as best as possible. I have an 04 WRX other than the EJ207 ...

  1. #1
    Registered User
    Join Date
    Jan 2011
    Posts
    36

    Weird noise in engine bay

    I'm going to try to describe this as best as possible.

    I have an 04 WRX other than the EJ207 version 8 sti swap all I have is a cat back and Short ram intake. The other day I noticed the turbo not sounding normal, instead of the normal *sssshhh sound (gears 1-3 constant sound), now when in 4th the turbo sounds more like *sssh sssh sssh sssh (gear 4 not constant). I was wondering how can I fix it? since it doesn't sound like a good thing.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Pro Manscaper Mikie13's Avatar
    Join Date
    Oct 2006
    Location
    Palmyra, NJ
    Posts
    21,203
    well, how to fix would be contingent on what the problem is...and that's not a very good description of a problem.

    Stock v.8 engine and turbo? Sounds like your turbo is fluttering under full 4th gear load (that is if the problem is occurring under WOT). Has the driveability of the car changed at all? Still feeling full power? Also, where are you located? Sounds like it is just wastegate flutter to me which isn't always a problem.
    The Hawk-Eye Alliance #90|The Blobeye Syndicate #0|The Stink-Eye Mob #0|N.E.R.D. Founding Member & #3
    2012 Lightning Red WRX Sedan
    ProcessWest TMIC Cobb SF Intake w/airbox Invidia Catless Downpipe Invidia Q300 Catback Kartboy Short Shifter
    OpenSource tuned by: Matty @ WTF Tuning

  4. #3
    Registered User
    Join Date
    Jan 2011
    Posts
    36
    yes, currently stock v8 and turbo. I was going to get it tuned but I noticed this issue, and was wondering if this can cause problems after the tune. And yes, when under WOT it does start to flutter and then stops after 5.5k rpms. as for the power, it feels like something is holding it back (feel the car somewhat struggling).

    --I'm located in New Jersey.

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •