EATING GAS! CHECK ENGINE LIGHT? HELP
+ Reply to Thread
Page 1 of 3 123 LastLast
Results 1 to 15 of 33

This is a discussion on EATING GAS! CHECK ENGINE LIGHT? HELP within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Ok so Ive got an 02 wrx with 124k on body, and 50k on motor. sti vf-39 turbo and sti ...

  1. #1
    Registered User
    Join Date
    Dec 2011
    Posts
    14

    EATING GAS! CHECK ENGINE LIGHT? HELP

    Ok so Ive got an 02 wrx with 124k on body, and 50k on motor. sti vf-39 turbo and sti injectors. Check engine light came on and since then been EATING GAS, guy i bought car from said he got it checked out and it came up as 02 sensor failure. (i bought car knowing this, the guy was real nice, i gotta a decent deal) Car still runs and drives pretty well. let me know what you think, thanks
    Last edited by ewd199; 12-03-2011 at 06:10 PM.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User bradsorensen's Avatar
    Join Date
    Nov 2011
    Location
    kingston wa
    Posts
    132
    I Support ClubWRX
    did you just recharge your k AND N FILTER

  4. #3
    Good news, everyone! xxxxxxxAnub1s's Avatar
    Join Date
    Jan 2005
    Location
    Eh, whaaaaa?
    Posts
    3,855
    I Support ClubWRX
    Need the code number in order to provide any kind of assistance here. Considering there are hundreds of codes, we could sit here all day long and guess what it could be and never get it right.

    Go to your local parts store (depending on where you are Autozone or O'Reilly's typically) to have the code pulled for free.
    Cody
    Hawk-Eye Alliance #727 N.E.R.D #255.255.255.0

    Your nighttime volunteer of near-useless information.
    Good news, everyone!

  5. #4
    Registered User bradsorensen's Avatar
    Join Date
    Nov 2011
    Location
    kingston wa
    Posts
    132
    I Support ClubWRX
    I HAVE A COBB ACCSES PORT MAPPER AND COADE READER AND I RECHARGERDED THE K&N FILTER AND HAD THE SAME PROBLEM

  6. #5
    zax
    zax is offline
    \_(ツ)_/ zax's Avatar
    Join Date
    Nov 2008
    Location
    Neverland Ranch, Maryland
    Posts
    13,219
    I Support ClubWRX I Support ClubWRX
    Quote Originally Posted by bradsorensen View Post
    I HAVE A COBB ACCSES PORT MAPPER AND COADE READER AND I RECHARGERDED THE K&N FILTER AND HAD THE SAME PROBLEM
    Probably because you're not supposed to use an oiled filter with an MAF metered car. Get some MAF cleaner from Advanced auto parts or whatever and go to town.


    OP there are hundreds of different codes your ECU can produce. We can't help you unless we know what your ECU knows. BTW what engine management and fuel pump are you running?
    2015 CWP WRX STi ... But how did I get roped back into an EJ motor?!
    Zax's utterly unimaginably stock 2015 STi build thread
    Zax's Shaggin' Wagon Build Thread Now tuned for 99% pure Unicorn Jizz!

    Zach | Moderator -- Mid-Atlantic States, Tech & Modifying & General Repairs
    Rollin' with the Bugeye Mafia #302 | N.E.R.D. Subject Zero
    Facebook me here

    Your Mid-A local board: http://www.clubwrx.net/forums/mid-atlantic-states/

  7. #6
    Good news, everyone! xxxxxxxAnub1s's Avatar
    Join Date
    Jan 2005
    Location
    Eh, whaaaaa?
    Posts
    3,855
    I Support ClubWRX
    Could very well be the issue there Brad, but it isn't necessarily guaranteed to be the problem. New members often forget or don't know that in order to troubleshoot an OBD car effectively, the code needs to be provided to even know where to start. Thanks for posting up your experience though.

    That K&N oil is hell on MAF sensors, that's for sure.
    Cody
    Hawk-Eye Alliance #727 N.E.R.D #255.255.255.0

    Your nighttime volunteer of near-useless information.
    Good news, everyone!

  8. #7
    Registered User
    Join Date
    Dec 2011
    Posts
    14
    ok heres the thing, i just bought this car knowing that there was a CEL, the guy i bought it from was really cool, real nice, sad hed help me out with anything i needed. he had the car read and it came up as an 02 sensor failure. he said it came on a few weeks ago and since then has been eating gas. Car runs pretty good. (i posted this to see what you guys thought, cuz i want to buy new 02 sensor and i was wondering if you guys defiantly think this could be the problem???) otherwise ill jus go get it checked out at a shop, but i dont want to. thank, sorry for the little trick.

  9. #8
    Registered User teflon_jones's Avatar
    Join Date
    Apr 2007
    Location
    8000' up in Colorado
    Posts
    6,753
    As Cody said, it's impossible to troubleshoot without having the code(s).

    Please post those and we can probably help get you started on the road to fixing it.
    Scott
    Past Subies - '11 STI Limited stage 1+ and '04 STi stage 2+
    '13 Wrangler Rubicon - custom front bumper w/12k lb winch & off-road lights, skid plates, diff guards, etc.
    '04 Porsche 911 Turbo GT2 clone 600 HP/TQ
    '77 F-150 heavily modded for off-roading

  10. #9
    Registered User
    Join Date
    Dec 2011
    Posts
    14
    o and free, ya ill go to autozone, thanks. but ya what do u think, came up as 02 sensor (what guy said)

  11. #10
    zax
    zax is offline
    \_(ツ)_/ zax's Avatar
    Join Date
    Nov 2008
    Location
    Neverland Ranch, Maryland
    Posts
    13,219
    I Support ClubWRX I Support ClubWRX
    Whoa whoa whoa... You bought the car modified with an aftermarket turbo and don't have engine management capable of reading an obdii code? You have potentially a lot more to worry about than just a code...
    2015 CWP WRX STi ... But how did I get roped back into an EJ motor?!
    Zax's utterly unimaginably stock 2015 STi build thread
    Zax's Shaggin' Wagon Build Thread Now tuned for 99% pure Unicorn Jizz!

    Zach | Moderator -- Mid-Atlantic States, Tech & Modifying & General Repairs
    Rollin' with the Bugeye Mafia #302 | N.E.R.D. Subject Zero
    Facebook me here

    Your Mid-A local board: http://www.clubwrx.net/forums/mid-atlantic-states/

  12. #11
    Good news, everyone! xxxxxxxAnub1s's Avatar
    Join Date
    Jan 2005
    Location
    Eh, whaaaaa?
    Posts
    3,855
    I Support ClubWRX
    Well, there are several codes for the O2 sensor, and a couple of them don't necessarily indicate that the O2 sensor needs to be replaced. So, go to autozone, get that code pulled, then come back and we'll help you decide the best course of action.

    And as Zach said, there may be more issues needing to be addressed here than just your CEL. Can you post up all of the modifications that have been done to the vehicle?
    Cody
    Hawk-Eye Alliance #727 N.E.R.D #255.255.255.0

    Your nighttime volunteer of near-useless information.
    Good news, everyone!

  13. #12
    Registered User bradsorensen's Avatar
    Join Date
    Nov 2011
    Location
    kingston wa
    Posts
    132
    I Support ClubWRX
    yep a good stuff.

  14. #13
    Registered User teflon_jones's Avatar
    Join Date
    Apr 2007
    Location
    8000' up in Colorado
    Posts
    6,753
    ^^^^^^^ +453 what they said...
    Scott
    Past Subies - '11 STI Limited stage 1+ and '04 STi stage 2+
    '13 Wrangler Rubicon - custom front bumper w/12k lb winch & off-road lights, skid plates, diff guards, etc.
    '04 Porsche 911 Turbo GT2 clone 600 HP/TQ
    '77 F-150 heavily modded for off-roading

  15. #14
    Registered User
    Join Date
    Dec 2011
    Posts
    14
    aww man u gettin me worried, it was dynoed at 270hp, ive got all receipts. heres list.....
    ------
    vf-39 turbo
    sti injectors
    front mount intercooler
    hks blow off
    hks exhaust
    stage 2 clutch
    --------
    i believe thats everything, performance wise

  16. #15
    Good news, everyone! xxxxxxxAnub1s's Avatar
    Join Date
    Jan 2005
    Location
    Eh, whaaaaa?
    Posts
    3,855
    I Support ClubWRX
    So it was dynoed, but was it tuned on that dyno as well? If so, do you know who did the tuning? Just need to make sure that the car has been properly tuned for that setup. If not, well... let's just hope that it was.
    Cody
    Hawk-Eye Alliance #727 N.E.R.D #255.255.255.0

    Your nighttime volunteer of near-useless information.
    Good news, everyone!

+ Reply to Thread
Page 1 of 3 123 LastLast

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •