06 wrx SECONDARY AIR PUMP
+ Reply to Thread
Results 1 to 4 of 4

This is a discussion on 06 wrx SECONDARY AIR PUMP within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; I have the dreaded P2443 error code. Is there anything wrong with simply pulling the fuse and relay? Can I ...

  1. #1
    Registered User
    Join Date
    Jul 2006
    Location
    Clark, NJ
    Posts
    35

    06 wrx SECONDARY AIR PUMP

    I have the dreaded P2443 error code. Is there anything wrong with simply pulling the fuse and relay? Can I delete the codes with an access port or do I need to take it to a tuner?


    Thanks

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Supporting Member mjboudreaux77's Avatar
    Join Date
    Sep 2007
    Location
    Northern Vermont
    Posts
    843
    I Support ClubWRX
    you can delete the error code, but it will turn on again.

    This happened to me after I went to stage 2. It is a really stupid error - all its telling you is it either can't put clean air in the exhaust flow, or it can't stop (valve stuck open or stuck closed). In 2005, the car didn't even have the secondary air pump.

    I have no idea what I did to fix it.... I took the IC back off, and really made sure every hose was connected tight. I think what happened was when I was messing around with the IC, I knocked the secondary air system loose a little bit. I didn't see any sign of a bad connection, but I just pushed on all hoses and electrical clamps hard. When I buttoned it all back up, the light never came on again. You have 2 valves, the real PITA of the error code is it doesn't tell you which one is stuck. There is one underneath the pump itself, and another one over by the turbo.

    This system really shouldn't fail - I have to believe you just have a loose connection somewhere.
    If I don't die by Thursday, I'll be roarin Friday night - Jimmy Buffett

  4. #3
    Registered User RDB81's Avatar
    Join Date
    Jul 2007
    Location
    RI
    Posts
    506
    I have not posted in a while but this is one thing I have all to much experience with. I have an 07 and can tell you the whole secondary air system is a PITA. For me I got the same code as you at first and that eventually caused a failure of the whole system. That being said the car runs like there is nothing wrong and if you can figure out how to get rid of the lights without replacing the whole thing for well over $1000 that is the way to go. And it can not be shut off by an access port.

  5. #4
    Registered User goBoating's Avatar
    Join Date
    May 2006
    Location
    South Carolina
    Posts
    329
    Just used my brand new Cobb AP with "AccessTuner Race" to disable that check. Now, my 06 WRX doesn't care what that valve does, ... short of falling off.
    <---Is that not the ugliest critter?
    ---------------------------------------------
    Hawk-Eye Alliance #43

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •