Oil pressure light is on, but pressure is good?
Results 1 to 5 of 5

This is a discussion on Oil pressure light is on, but pressure is good? within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; I have a 2006 WRX with 95k miles, no modifications. Four days ago, the oil pressure light came on. I ...

  1. #1
    Registered User
    Join Date
    Nov 2011
    Location
    Purdys NY
    Posts
    2

    Oil pressure light is on, but pressure is good?

    I have a 2006 WRX with 95k miles, no modifications.

    Four days ago, the oil pressure light came on. I changed the oil, and when this did not help, I took it to my mechanic. He replaced the sender (no help) and then put on an oil pressure gauge, and says the pressure is good.

    If the pressure is good, is the problem just with the oil pressure light, or is there something else?

    Thanks,

    John

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    zax
    zax is offline
    \_(ツ)_/ zax's Avatar
    Join Date
    Nov 2008
    Location
    Neverland Ranch, Maryland
    Posts
    11,718
    I Support ClubWRX I Support ClubWRX
    Are you SURE the pressure is good? I'd be concerned that you may have a fractured oil pickup such as many EJ255/257 owners have experienced...
    2015 CWP WRX STi on order ... But how did I get roped back into an EJ motor?!
    Zax' Shaggin' Wagon Build Thread Now tuned for 99% pure Unicorn Jizz!

    Zach | Moderator -- Mid-Atlantic States, Tech & Modifying & General Repairs
    The REAL 'WTF Tuning?!' Progenitor
    Rollin' with the Bugeye Mafia #302 | N.E.R.D. Subject Zero | Blobeye Synd. #Tree-Fiddy
    Facebook me here

    Your Mid-A local board: http://www.clubwrx.net/forums/mid-atlantic-states/

  4. #3
    Registered User
    Join Date
    Nov 2011
    Location
    Purdys NY
    Posts
    2
    Quote Originally Posted by zax View Post
    Are you SURE the pressure is good? I'd be concerned that you may have a fractured oil pickup such as many EJ255/257 owners have experienced...
    My mechanic said he put a gauge on to test it, and the pressure was fine. I'm just not really sure whether reading with the gauge would necessarily preclude other problems. For instance, if the pressure measured OK, couldn't I still have a fractured oil pickup, or some other problem?

    He also said he had to put a quart of oil in, and I just had it changed four days ago.

  5. #4
    Registered User SRTSamb's Avatar
    Join Date
    Mar 2011
    Location
    Virginia
    Posts
    719
    My guess is your oil pressure is not good and if you don't see a leak somewhere you are burning it up. Take your car in brother.

    Could be that when you had the oil changed the sensor was knocked loose. But sounds like its not that
    2011 OBP WRX::Invidia Catless DP::Cobb CAI::TP 93 STG2::KB STS::Perrin Sways::

  6. #5
    Registered User teflon_jones's Avatar
    Join Date
    Apr 2007
    Location
    8000' up in Colorado
    Posts
    6,752
    If the car is telling you the pressure isn't good, then it probably isn't.
    Scott
    Past Subies - '11 STI Limited stage 1+ and '04 STi stage 2+
    '13 Wrangler Rubicon - custom front bumper w/12k lb winch & off-road lights, skid plates, diff guards, etc.
    '04 Porsche 911 Turbo GT2 clone 600 HP/TQ
    '77 F-150 heavily modded for off-roading

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •